summaryrefslogtreecommitdiffstats
path: root/debian/wheezy/dependencies/tqca-tls/debian/rules
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-09-10 16:13:23 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-09-10 16:13:23 -0500
commit05a59ddb0228494ba27bacbe7d391f06725b0689 (patch)
tree7c028104ac86c3b1e43ea3584528939bd8802426 /debian/wheezy/dependencies/tqca-tls/debian/rules
parenta3210d42cfc1a2eb722dd85b0ddac0a2177f26ab (diff)
downloadtde-packaging-05a59ddb0228494ba27bacbe7d391f06725b0689.tar.gz
tde-packaging-05a59ddb0228494ba27bacbe7d391f06725b0689.zip
Split wheezy off of squeeze
Diffstat (limited to 'debian/wheezy/dependencies/tqca-tls/debian/rules')
-rwxr-xr-xdebian/wheezy/dependencies/tqca-tls/debian/rules110
1 files changed, 110 insertions, 0 deletions
diff --git a/debian/wheezy/dependencies/tqca-tls/debian/rules b/debian/wheezy/dependencies/tqca-tls/debian/rules
new file mode 100755
index 000000000..4ffaf90dc
--- /dev/null
+++ b/debian/wheezy/dependencies/tqca-tls/debian/rules
@@ -0,0 +1,110 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+
+# These are used for cross-compiling and for saving the configure script
+# from having to guess our platform (since we know it already)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+
+CFLAGS = -Wall -g
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+ INSTALL_PROGRAM += -s
+endif
+
+# shared library versions, option 1
+version=2.0.5
+major=2
+# option 2, assuming the library is created as src/.libs/libfoo.so.2.0.5 or so
+#version=`ls src/.libs/lib*.so.* | \
+# awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'`
+#major=`ls src/.libs/lib*.so.* | \
+# awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'`
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+ CFLAGS="$(CFLAGS)" ./configure
+ touch configure-stamp
+
+build: configure-stamp build-stamp
+build-stamp:
+ dh_testdir
+
+ # Add here commands to compile the package.
+ $(MAKE)
+
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+
+ # Add here commands to clean up after the build process.
+ [ ! -f Makefile ] || $(MAKE) distclean
+ rm -rf .ui .moc .obj Makefile conf.log conf.pri extra.pri
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/tmp
+ $(MAKE) install INSTALL_ROOT=$(CURDIR)/debian/tmp/
+ [ -e $(CURDIR)/debian/tmp/usr/lib/tqt3/plugins/crypto/libqca-tls.so ] || ( echo "libqca-tls.so not in usr/lib/tqt3/plugins/crypto/libqca-tls.so" && exit 1 )
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+ dh_install --sourcedir=debian/tmp --list-missing
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_perl
+# dh_python
+# dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install