summaryrefslogtreecommitdiffstats
path: root/redhat/applications/tde-style-ia-ora/tde-style-ia-ora.spec
diff options
context:
space:
mode:
authorFrançois Andriot <albator78@libertysurf.fr>2019-03-10 20:22:48 +0100
committerFrançois Andriot <albator78@libertysurf.fr>2019-03-10 20:22:48 +0100
commit5cb16668ed68708c9443ef26989e9ba8c0f863d4 (patch)
tree45e6b9c8151ad6d32eeccf014085c645caad72b2 /redhat/applications/tde-style-ia-ora/tde-style-ia-ora.spec
parent6804945f8a947bd35d7c7346844bd8a20481fc5a (diff)
downloadtde-packaging-5cb16668ed68708c9443ef26989e9ba8c0f863d4.tar.gz
tde-packaging-5cb16668ed68708c9443ef26989e9ba8c0f863d4.zip
RPM: switch many packages to cmake
Diffstat (limited to 'redhat/applications/tde-style-ia-ora/tde-style-ia-ora.spec')
-rw-r--r--redhat/applications/tde-style-ia-ora/tde-style-ia-ora.spec52
1 files changed, 29 insertions, 23 deletions
diff --git a/redhat/applications/tde-style-ia-ora/tde-style-ia-ora.spec b/redhat/applications/tde-style-ia-ora/tde-style-ia-ora.spec
index 56d664a5c..acbee7b52 100644
--- a/redhat/applications/tde-style-ia-ora/tde-style-ia-ora.spec
+++ b/redhat/applications/tde-style-ia-ora/tde-style-ia-ora.spec
@@ -60,7 +60,7 @@ Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
BuildRequires: trinity-tdelibs-devel >= %{tde_version}
BuildRequires: trinity-tdebase-devel >= %{tde_version}
-BuildRequires: autoconf automake libtool m4
+BuildRequires: cmake >= 2.8
BuildRequires: gcc-c++
BuildRequires: pkgconfig
BuildRequires: libtool
@@ -81,38 +81,44 @@ Mandriva theme for Trinity
%prep
%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
-%__cp -f "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
-%__cp -f "/usr/share/libtool/"*"/ltmain.sh" "admin/ltmain.sh" || %__cp -f "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
-%__make -f "admin/Makefile.common"
-
%build
unset QTDIR QTINC QTLIB
export PATH="%{tde_bindir}:${PATH}"
-
-%configure \
- --prefix=%{tde_prefix} \
- --exec-prefix=%{tde_prefix} \
- --bindir=%{tde_bindir} \
- --datadir=%{tde_datadir} \
- --includedir=%{tde_tdeincludedir} \
- --libdir=%{tde_libdir} \
- --mandir=%{tde_mandir} \
+export PKG_CONFIG_PATH="%{tde_libdir}/pkgconfig"
+
+if ! rpm -E %%cmake|grep -q "cd build"; then
+ %__mkdir_p build
+ cd build
+fi
+
+%cmake \
+ -DCMAKE_BUILD_TYPE="RelWithDebInfo" \
+ -DCMAKE_C_FLAGS="${RPM_OPT_FLAGS} -DNDEBUG" \
+ -DCMAKE_CXX_FLAGS="${RPM_OPT_FLAGS} -DNDEBUG" \
+ -DCMAKE_SKIP_RPATH=OFF \
+ -DCMAKE_INSTALL_RPATH="%{tde_libdir}" \
+ -DCMAKE_VERBOSE_MAKEFILE=ON \
+ -DWITH_GCC_VISIBILITY=OFF \
+ \
+ -DCMAKE_INSTALL_PREFIX="%{tde_prefix}" \
+ -DSHARE_INSTALL_PREFIX="%{tde_datadir}" \
+ -DLIB_INSTALL_DIR="%{tde_libdir}" \
+ \
+ -DWITH_ALL_OPTIONS=ON \
+ -DWITH_GCC_VISIBILITY=ON \
\
- --disable-dependency-tracking \
- --disable-debug \
- --enable-new-ldflags \
- --enable-final \
- --enable-closure \
- --enable-rpath \
- --disable-gcc-hidden-visibility
+ -DBUILD_ALL=ON \
+ -DBUILD_DOC=ON \
+ -DBUILD_TRANSLATIONS=ON \
+ ..
-%__make %{?_smp_mflags}
+%__make %{?_smp_mflags} || %__make
%install
%__rm -rf %{buildroot}
-%__make install DESTDIR=%{?buildroot}
+%__make install DESTDIR=%{buildroot} -C build
%clean