summaryrefslogtreecommitdiffstats
path: root/redhat/main/tdebindings/tdebindings-14.0.0.spec
diff options
context:
space:
mode:
authorFrançois Andriot <albator78@libertysurf.fr>2018-11-27 21:34:48 +0100
committerFrançois Andriot <albator78@libertysurf.fr>2018-11-27 21:34:48 +0100
commita615d19df88eb2e989316b480519161945dbc7dc (patch)
tree369970b98042998b86c11024598155e037b76fec /redhat/main/tdebindings/tdebindings-14.0.0.spec
parent76a93e0011ade1583a1ec672f33411dfd35454f3 (diff)
downloadtde-packaging-a615d19df88eb2e989316b480519161945dbc7dc.tar.gz
tde-packaging-a615d19df88eb2e989316b480519161945dbc7dc.zip
RPM: merge redhat directory with master branch
Diffstat (limited to 'redhat/main/tdebindings/tdebindings-14.0.0.spec')
-rw-r--r--redhat/main/tdebindings/tdebindings-14.0.0.spec216
1 files changed, 79 insertions, 137 deletions
diff --git a/redhat/main/tdebindings/tdebindings-14.0.0.spec b/redhat/main/tdebindings/tdebindings-14.0.0.spec
index 9060e0f44..5256a254d 100644
--- a/redhat/main/tdebindings/tdebindings-14.0.0.spec
+++ b/redhat/main/tdebindings/tdebindings-14.0.0.spec
@@ -1,5 +1,5 @@
#
-# spec file for package tdebindings (version R14.0.0)
+# spec file for package tdebindings (version R14)
#
# Copyright (c) 2014 Trinity Desktop Environment
#
@@ -12,16 +12,23 @@
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
#
-# Please submit bugfixes or comments via http:/www.trinitydesktop.org/
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
#
+# Required for PCLinuxOS: removes the ldflag '--no-undefined'
+%if 0%{?pclinuxos}
+%define _disable_ld_no_undefined 1
+%endif
+
# BUILD WARNING:
# Remove qt-devel and qt3-devel and any kde*-devel on your system !
# Having KDE libraries may cause FTBFS here !
# TDE variables
%define tde_epoch 2
+%if "%{?tde_version}" == ""
%define tde_version 14.0.0
+%endif
%define tde_pkg tdebindings
%define tde_prefix /opt/trinity
%define tde_bindir %{tde_prefix}/bin
@@ -35,11 +42,6 @@
%define tde_tdeincludedir %{tde_includedir}/tde
%define tde_tdelibdir %{tde_libdir}/trinity
-# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
-%if "%{?tde_prefix}" != "/usr"
-%define _variant .opt
-%endif
-
# Special note for RHEL4:
# You must create symlink 'libgcj.so' manually because it does not exist by default.
# E.g:
@@ -50,7 +52,7 @@
Name: trinity-%{tde_pkg}
Summary: TDE bindings to non-C++ languages
Version: %{tde_version}
-Release: %{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}%{?_variant}
+Release: %{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
Group: System/GUI/Other
URL: http://www.trinitydesktop.org/
@@ -67,6 +69,7 @@ Prefix: %{tde_prefix}
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: %{name}-%{version}%{?preversion:~%{preversion}}.tar.gz
+Source1: %{name}-rpmlintrc
BuildRequires: trinity-arts-devel >= %{tde_epoch}:1.5.10
BuildRequires: trinity-tdelibs-devel >= %{tde_version}
@@ -119,16 +122,18 @@ BuildRequires: mozilla-xulrunner20-devel
BuildRequires: openssl-devel
# GTK1 support
-%if 0%{?fedora}
+%if 0%{?fedora} || 0%{?rhel} >= 5
%define with_gtk1 1
BuildRequires: glib-devel
BuildRequires: gtk+-devel
%endif
-%if 0%{?rhel} == 5
+%if 0%{?rhel} == 5 || 0%{?rhel} == 6
+%if 0%{?with_gtk1}
%define with_gtk1 1
BuildRequires: glib-devel
BuildRequires: gtk+-devel
%endif
+%endif
%if 0%{?mdkversion} == 201100
%define with_gtk1 1
BuildRequires: %{_lib}glib1.2-devel
@@ -174,17 +179,35 @@ BuildRequires: ruby >= 1.8
%if 0%{?fedora} >= 19
BuildRequires: rubypick
%endif
+
+# Check for Ruby library directory
%if "%{?ruby_libarchdir}" != ""
%define ruby_arch %{?ruby_libarchdir}
%else
+%if "%{?rb_archdir}" != ""
+%define ruby_arch %{?rb_archdir}
+%else
+%if "%{%ruby_archdir}" != ""
+%define ruby_arch %{?ruby_archdir}
+%else
%{!?ruby_arch: %define ruby_arch %(ruby -rrbconfig -e 'puts Config::CONFIG["archdir"]')}
+%{!?ruby_arch: %define ruby_arch %(ruby -rrbconfig -e 'puts RbConfig::CONFIG["archdir"]')}
+%endif
+%endif
+%endif
+%if 0%{?rhel} == 5 || 0%{?rhel} == 6
+%define ruby_arch %(ruby -rrbconfig -e 'puts Config::CONFIG["archdir"]')
%endif
%if "%{?ruby_libdir}" != ""
%define ruby_rubylibdir %{?ruby_libdir}
%else
+%if "%{?rb_libdir}" != ""
+%define ruby_rubylibdir %{?rb_libdir}
+%else
%{!?ruby_rubylibdir: %define ruby_rubylibdir %(ruby -rrbconfig -e 'puts Config::CONFIG["rubylibdir"]')}
%endif
+%endif
# Ruby 1.9 includes are located in strance directories ... (taken from ruby 1.9 spec file)
%global _normalized_cpu %(echo %{_target_cpu} | sed 's/^ppc/powerpc/;s/i.86/i386/;s/sparcv./sparc/;s/armv.*/arm/')
@@ -200,16 +223,22 @@ BuildRequires: gcc-java
# PCLinuxOS use SUN's Java
%if 0%{?pclinuxos}
-BuildRequires: java-1.6.0-sun
-BuildRequires: java-1.6.0-sun-devel
+BuildRequires: java-devel
%else
# Others use OpenJDK
BuildRequires: java-openjdk
BuildRequires: java-devel >= 1.4.2
-%if 0%{?fedora} >= 17 || 0%{?suse_version} >= 1220 || 0%{?mgaversion} >= 3 || 0%{?rhel} >= 7
+%if 0%{?suse_version} >= 1320
+BuildRequires: java-1_8_0-openjdk-devel
+%endif
+%if 0%{?fedora} >= 21 || 0%{?mgaversion} >= 5
+BuildRequires: java-1.8.0-openjdk-devel
+%endif
+%if 0%{?fedora} == 17 || 0%{?fedora} == 18 || 0%{?fedora} == 19 || 0%{?fedora} == 20 || 0%{?suse_version} == 1230 || 0%{?suse_version} == 1310 || 0%{?mgaversion} == 3 || 0%{?mgaversion} == 4 || 0%{?rhel} >= 7
BuildRequires: java-1.7.0-openjdk-devel
-%else
+%endif
+%if 0%{?rhel} == 5 || 0%{?rhel} == 6
BuildRequires: java-1.6.0-openjdk-devel
%endif
@@ -246,7 +275,7 @@ Requires: trinity-tdebindings-java = %{version}-%{release}
Requires: trinity-libsmoketqt = %{version}-%{release}
Requires: trinity-libsmoketde = %{version}-%{release}
Requires: perl-dcop = %{version}-%{release}
-Requires: trinity-python-dcop = %{version}-%{release}
+Requires: python-dcop = %{version}-%{release}
Requires: trinity-libkjsembed1 = %{version}-%{release}
Requires: trinity-kjscmd = %{version}-%{release}
Requires: trinity-juic = %{version}-%{release}
@@ -338,12 +367,6 @@ This package is part of the official TDE bindings module.
%{tde_libdir}/libjavadcop.la
%{tde_libdir}/libjavadcop.so
-%post -n trinity-libdcop3-jni
-/sbin/ldconfig || :
-
-%postun -n trinity-libdcop3-jni
-/sbin/ldconfig || :
-
##########
%package -n trinity-libqt3-java
@@ -389,12 +412,6 @@ This package is part of the official TDE bindings module.
%{tde_libdir}/jni/libqtjava.so.*
%doc qtjava/ChangeLog
-%post -n trinity-libqt3-jni
-/sbin/ldconfig || :
-
-%postun -n trinity-libqt3-jni
-/sbin/ldconfig || :
-
##########
%package -n trinity-libqt3-jni-devel
@@ -489,12 +506,6 @@ This package is part of the official TDE bindings module.
%defattr(-,root,root,-)
%{tde_libdir}/libsmoketqt.so.*
-%post -n trinity-libsmoketqt
-/sbin/ldconfig || :
-
-%postun -n trinity-libsmoketqt
-/sbin/ldconfig || :
-
##########
%package -n trinity-libsmoketqt-devel
@@ -522,12 +533,6 @@ This package is part of the official TDE bindings module.
%{tde_libdir}/libsmoketqt.so
%{tde_libdir}/libsmoketqt.la
-%post -n trinity-libsmoketqt-devel
-/sbin/ldconfig || :
-
-%postun -n trinity-libsmoketqt-devel
-/sbin/ldconfig || :
-
##########
%package -n trinity-libsmoketde
@@ -548,12 +553,6 @@ This package is part of the official TDE bindings module.
%defattr(-,root,root,-)
%{tde_libdir}/libsmoketde.so.*
-%post -n trinity-libsmoketde
-/sbin/ldconfig || :
-
-%postun -n trinity-libsmoketde
-/sbin/ldconfig || :
-
##########
%package -n trinity-libsmoketde-devel
@@ -580,12 +579,6 @@ This package is part of the official TDE bindings module.
%{tde_libdir}/libsmoketde.so
%{tde_libdir}/libsmoketde.la
-%post -n trinity-libsmoketde-devel
-/sbin/ldconfig || :
-
-%postun -n trinity-libsmoketde-devel
-/sbin/ldconfig || :
-
##########
%package -n perl-dcop
@@ -616,12 +609,15 @@ Perl bindings to the DCOP interprocess communication protocol used by TDE
##########
-%package -n trinity-python-dcop
+%package -n python-dcop
Summary: DCOP bindings for Python
Group: System/Libraries
Requires: python
-%description -n trinity-python-dcop
+Obsoletes: trinity-python-dcop < %{version}-%{release}
+Provides: trinity-python-dcop = %{version}-%{release}
+
+%description -n python-dcop
This package contains the shared libraries necessary to run and
develop Python programs using the Python DCOP bindings
libraries. DCOP is the TDE Desktop COmmunications Protocol, used for
@@ -629,7 +625,7 @@ communicating with running TDE applications.
This package is part of the official TDE bindings module.
-%files -n trinity-python-dcop
+%files -n python-dcop
%defattr(-,root,root,-)
%{python_sitearch}/pcop.la
%{python_sitearch}/pcop.so
@@ -677,18 +673,6 @@ This package is part of the official TDE bindings module.
%{tde_datadir}/services/javascript.desktop
%doc kjsembed/docs/ChangeLog
-%post -n trinity-libkjsembed1
-/sbin/ldconfig ||:
-touch --no-create %{tde_datadir}/icons/hicolor ||:
-gtk-update-icon-cache -q %{tde_datadir}/icons/hicolor 2> /dev/null ||:
-update-desktop-database >& /dev/null ||:
-
-%postun -n trinity-libkjsembed1
-/sbin/ldconfig ||:
-touch --no-create %{tde_datadir}/icons/hicolor ||:
-gtk-update-icon-cache -q %{tde_datadir}/icons/hicolor 2> /dev/null ||:
-update-desktop-database >& /dev/null ||:
-
##########
%package -n trinity-libkjsembed-devel
@@ -714,12 +698,6 @@ This package is part of the official TDE bindings module.
%{tde_libdir}/libkjsembed.la
%{tde_docdir}/trinity-libkjsembed-devel/
-%post -n trinity-libkjsembed-devel
-/sbin/ldconfig || :
-
-%postun -n trinity-libkjsembed-devel
-/sbin/ldconfig || :
-
##########
%package -n trinity-kjscmd
@@ -740,12 +718,6 @@ This package is part of the official TDE bindings module.
%{tde_tdelibdir}/libjsconsoleplugin.la
%{tde_tdelibdir}/libjsconsoleplugin.so
-%post -n trinity-kjscmd
-update-desktop-database >& /dev/null ||:
-
-%postun -n trinity-kjscmd
-update-desktop-database >& /dev/null ||:
-
##########
%package -n trinity-juic
@@ -796,12 +768,6 @@ This package is part of the official TDE bindings module.
%{ruby_arch}/korundum.so*
%doc korundum/ChangeLog
-%post -n trinity-libkorundum0-ruby
-/sbin/ldconfig || :
-
-%postun -n trinity-libkorundum0-ruby
-/sbin/ldconfig || :
-
##########
%package -n trinity-libqt0-ruby
@@ -833,12 +799,6 @@ This package is part of the official TDE bindings module.
%{ruby_arch}/tqui.la
%doc qtruby/ChangeLog
-%post -n trinity-libqt0-ruby
-/sbin/ldconfig || :
-
-%postun -n trinity-libqt0-ruby
-/sbin/ldconfig || :
-
##########
%if 0
@@ -877,12 +837,6 @@ xpart_notepad is a small XPart editor. Use it to understand how to use XPart.
%{tde_datadir}/services/xp_notepad.desktop
%doc xparts/xpart_notepad/README
-%post -n trinity-xpart-notepad
-/sbin/ldconfig || :
-
-%postun -n trinity-xpart-notepad
-/sbin/ldconfig || :
-
##########
%if 0%{?with_gtk1}
@@ -898,11 +852,6 @@ This package contains the xparts library for GTK.
%{tde_libdir}/libgtkxparts.so.*
%{tde_libdir}/libgtkxparts.la
-%post -n trinity-libgtkxparts1
-/sbin/ldconfig || :
-
-%postun -n trinity-libgtkxparts1
-/sbin/ldconfig || :
%endif
##########
@@ -922,12 +871,6 @@ This package contains the xparts library for TDE.
%{tde_libdir}/libtdexparts.so.*
%{tde_libdir}/libtdexparts.la
-%post -n trinity-libtdexparts
-/sbin/ldconfig || :
-
-%postun -n trinity-libtdexparts
-/sbin/ldconfig || :
-
##########
%package -n trinity-libxparts-devel
@@ -949,12 +892,6 @@ This package contains the development files for Xparts library.
%endif
%{tde_libdir}/libtdexparts.so
-%post -n trinity-libxparts-devel
-/sbin/ldconfig || :
-
-%postun -n trinity-libxparts-devel
-/sbin/ldconfig || :
-
##########
%package xparts-extras
@@ -991,12 +928,6 @@ This package contains the DCOP bindings for C.
%defattr(-,root,root,-)
%{tde_libdir}/libdcopc.so.*
-%post -n trinity-libdcop-c
-/sbin/ldconfig || :
-
-%postun -n trinity-libdcop-c
-/sbin/ldconfig || :
-
###########
%package -n trinity-libdcop-c-devel
@@ -1013,12 +944,6 @@ This package contains the development files for DCOP bindings for C.
%{tde_libdir}/libdcopc.la
%{tde_tdeincludedir}/dcopc/
-%post -n trinity-libdcop-c-devel
-/sbin/ldconfig || :
-
-%postun -n trinity-libdcop-c-devel
-/sbin/ldconfig || :
-
##########
%package devel
@@ -1042,7 +967,7 @@ Requires: trinity-libqt3-jni-devel = %{version}-%{release}
Requires: trinity-libtrinity-jni-devel = %{version}-%{release}
%description devel
-Development files for the TDE bindings.
+This package contains the development files for the TDE bindings.
%files devel
%defattr(-,root,root,-)
@@ -1064,21 +989,38 @@ exit 1
# [tdebindings] Function 'rb_frame_this_func' does not exist in RHEL4/5
%if 0%{?rhel} >= 4 && 0%{?rhel} <= 5
-%__sed -i "qtruby/rubylib/qtruby/Qt.cpp" -e "s|rb_frame_this_func|rb_frame_last_func|g"
+%__sed -i "qtruby/rubylib/qtruby/Qt.cpp" \
+ -i "korundum/rubylib/korundum/Korundum.cpp" \
+ -e "s|rb_frame_this_func|rb_frame_last_func|g"
+%endif
+
+# Another strange FTBFS in RHEL 5
+%if 0%{?rhel} >= 4 && 0%{?rhel} <= 5
+%__sed -i "xparts/xpart_notepad/shell_xparthost.cpp" \
+ -i "xparts/xpart_notepad/xp_notepad.cpp" \
+ -e "/TDEApplication/ s| );|, true, true, true);|"
%endif
# Disable kmozilla, it does not build with recent xulrunner (missing 'libmozjs.so')
%__sed -i "xparts/Makefile.am" \
- -e "s|SUBDIRS = .*|SUBDIRS = src xpart_notepad|"
+ -e "s|SUBDIRS = .*|SUBDIRS = src xpart_notepad|"
+
+# Fix Fedora >= 28 automatic invalid dependency to '/usr/bin/kjscmd'
+%if 0%{?fedora} >= 28
+%__sed -i "kjsembed/tdescript/swaptabs.js" \
+ -i "kjsembed/stdlib/cmdline.js" \
+ -e "s|/usr/bin/env kjscmd|%{tde_bindir}/kjscmd|"
+%endif
%__cp -f "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
-%__cp -f "/usr/share/libtool/config/ltmain.sh" "admin/ltmain.sh" || %__cp -f "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
+%__cp -f "/usr/share/libtool/"*"/ltmain.sh" "admin/ltmain.sh" || %__cp -f "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
%__make -f "admin/Makefile.common"
%build
unset QTDIR QTINC QTLIB
export PATH="%{tde_bindir}:${PATH}"
+export TDEDIR=%{tde_prefix}
unset JAVA_HOME ||:
%{?java_home:JAVA_HOME=%{java_home}; export JAVA_HOME}
@@ -1092,20 +1034,23 @@ if [ -d "/usr/include/%{_normalized_cpu}-linux" ]; then
fi
# Specific path for RHEL4
-if [ -d /usr/X11R6 ]; then
+if [ -d "/usr/X11R6" ]; then
export RPM_OPT_FLAGS="${RPM_OPT_FLAGS} -I/usr/X11R6/include -L/usr/X11R6/%{_lib}"
fi
-if [ -d /usr/evolution28 ]; then
+if [ -d "/usr/evolution28" ]; then
export PATH="/usr/evolution28/bin:${PATH}"
export PKG_CONFIG_PATH="/usr/evolution28/%{_lib}/pkgconfig:${PKG_CONFIG_PATH}"
fi
# Warning: openSUSE 13.1: /usr/include/ruby-2.0.0/ruby.h
-%if 0%{?suse_version} >= 1310
+%if 0%{?suse_version} == 1310 || 0%{?suse_version} == 1320
EXTRA_INCLUDES="/usr/include/ruby-%{rb20_ver}:/usr/include/ruby-%{rb20_ver}/%{_target}"
%endif
+%if 0%{?suse_version} >= 1330
+EXTRA_INCLUDES="/usr/include/ruby-%{rb_ver}:/usr/include/ruby-%{rb_ver}/%{_target}-gnu"
+%endif
-# Warning: GCC visibility causes FTBFS [Bug #1285]
+# Warning: GCC visibility causes FTBFS [Bug #1285]
%configure \
--prefix=%{tde_prefix} \
--exec-prefix=%{tde_prefix} \
@@ -1136,8 +1081,7 @@ pushd dcopperl
CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
# [Bug #348] Ugly hack to modify the man pages directory
-sed -i Makefile \
- -e "s|/usr/share/man|%{tde_mandir}|g"
+sed -i "Makefile" -e "s|/usr/share/man|%{tde_mandir}|g"
%__make OPTIMIZE="$RPM_OPT_FLAGS" ||:
popd
@@ -1201,5 +1145,3 @@ fi
%changelog
-* Fri Jul 05 2013 Francois Andriot <francois.andriot@free.fr> - 14.0.0-1
-- Initial release for TDE R14.0.0