summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/keep/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-05-23 17:04:43 +0200
committerSlávek Banko <slavek.banko@axis.cz>2019-05-23 17:05:10 +0200
commit4b4ec4e90a2ec4b9525ed145cf631ce0816b2d6e (patch)
tree642fbd7675e509bd7eec90f149906e2d41329b6d /ubuntu/_base/applications/keep/debian/rules
parent8d12e9d981e44c0768c00deebd3c8818d0bad656 (diff)
downloadtde-packaging-4b4ec4e90a2ec4b9525ed145cf631ce0816b2d6e.tar.gz
tde-packaging-4b4ec4e90a2ec4b9525ed145cf631ce0816b2d6e.zip
DEB keep: Switch to cmake.
The man page has been moved to the main tree. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 5c8ccdde9bb66eba020514dc54c4baee453aea37)
Diffstat (limited to 'ubuntu/_base/applications/keep/debian/rules')
-rwxr-xr-xubuntu/_base/applications/keep/debian/rules49
1 files changed, 11 insertions, 38 deletions
diff --git a/ubuntu/_base/applications/keep/debian/rules b/ubuntu/_base/applications/keep/debian/rules
index aef7a1ca5..cee2a3058 100755
--- a/ubuntu/_base/applications/keep/debian/rules
+++ b/ubuntu/_base/applications/keep/debian/rules
@@ -1,46 +1,19 @@
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-tde.mk
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_INSTALL_MANPAGES_keep := keep.1
-
-DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/tde
-
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
-post-patches:: debian/stamp-bootstrap
-
-debian/stamp-bootstrap:
-ifneq "$(wildcard /usr/share/libtool/ltmain.sh)" ""
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -f /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- make -f admin/Makefile.common cvs
- touch debian/stamp-bootstrap
-
-build/keep-trinity::
- /usr/bin/docbook2x-man debian/keep.xml
-
-install/keep-trinity::
- dh_installman keep.1
- mv debian/$(cdbs_curpkg)/usr/share/man debian/$(cdbs_curpkg)/opt/trinity/share/
-
-clean::
- rm -f debian/stamp-bootstrap
- rm -f keep.1
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"