summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/kooldock/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-05 00:49:32 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-05 00:49:32 +0200
commit58963caed1b872df8093556f532bd85384d15df7 (patch)
treec3b9f7951f7a49001dff7d5c8c39b8287dac7493 /ubuntu/_base/applications/kooldock/debian/rules
parenta25ffb359df5adf90bbb3a687f0c4eab1d9366cd (diff)
downloadtde-packaging-58963caed1b872df8093556f532bd85384d15df7.tar.gz
tde-packaging-58963caed1b872df8093556f532bd85384d15df7.zip
DEB kooldock: Add packaging files.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'ubuntu/_base/applications/kooldock/debian/rules')
-rwxr-xr-xubuntu/_base/applications/kooldock/debian/rules19
1 files changed, 19 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/kooldock/debian/rules b/ubuntu/_base/applications/kooldock/debian/rules
new file mode 100755
index 000000000..cee2a3058
--- /dev/null
+++ b/ubuntu/_base/applications/kooldock/debian/rules
@@ -0,0 +1,19 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"