summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/system/adept/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-07-11 21:27:29 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-07-11 21:27:29 +0200
commit5195a57d4919924c7e7970506b1994e83fdebbbb (patch)
tree0939379ca3d176975efd109ea2cd66fb9f1f11d9 /ubuntu/_base/applications/system/adept/debian/rules
parentcb277da52ac1a12d1b8f855fca48cd013948f4dc (diff)
downloadtde-packaging-5195a57d4919924c7e7970506b1994e83fdebbbb.tar.gz
tde-packaging-5195a57d4919924c7e7970506b1994e83fdebbbb.zip
DEB: Rearranged applications folder into sub categories.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'ubuntu/_base/applications/system/adept/debian/rules')
-rwxr-xr-xubuntu/_base/applications/system/adept/debian/rules21
1 files changed, 21 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/system/adept/debian/rules b/ubuntu/_base/applications/system/adept/debian/rules
new file mode 100755
index 000000000..83626c5cb
--- /dev/null
+++ b/ubuntu/_base/applications/system/adept/debian/rules
@@ -0,0 +1,21 @@
+#!/usr/bin/make -f
+
+# Currently is not possible to build piklab with --enable-final
+DEB_BUILD_OPTIONS += noopt
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_MAKE_CHECK_TARGET := check
+DEB_CONFIGURE_EXTRA_FLAGS += --enable-adept --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
+
+# Enable us to locate the old libept-trinity library and includes
+CPPFLAGS += -I/opt/trinity/include
+LDFLAGS += -L/opt/trinity/lib -lept