summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/kbarcode/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-02-24 15:27:32 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-02-24 15:27:32 +0100
commit36f8fe535ea852baa93dcdd9cf1a71241e7b04e2 (patch)
tree95e44f63c69c7b5019029fd5a3b5ea1e9de191d9 /ubuntu/maverick/applications/kbarcode/debian/rules
parent598dd003cf7926d87db817e29df47cbf195f936b (diff)
downloadtde-packaging-36f8fe535ea852baa93dcdd9cf1a71241e7b04e2.tar.gz
tde-packaging-36f8fe535ea852baa93dcdd9cf1a71241e7b04e2.zip
DEB kbarcode: Switch to cmake.
The man page has been moved to the main tree. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'ubuntu/maverick/applications/kbarcode/debian/rules')
-rwxr-xr-xubuntu/maverick/applications/kbarcode/debian/rules48
1 files changed, 12 insertions, 36 deletions
diff --git a/ubuntu/maverick/applications/kbarcode/debian/rules b/ubuntu/maverick/applications/kbarcode/debian/rules
index f0aedb1c7..e5c16cf8a 100755
--- a/ubuntu/maverick/applications/kbarcode/debian/rules
+++ b/ubuntu/maverick/applications/kbarcode/debian/rules
@@ -1,44 +1,20 @@
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
-include debian/cdbs/kde.mk
+include /usr/share/cdbs/1/class/cmake.mk
#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
-include /usr/share/cdbs/1/rules/utils.mk
-
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_INSTALL_MANPAGES_kbarcode-trinity := debian/kbarcode.1
-
-DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
+include debian/cdbs/debian-qt-kde.mk
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
-post-patches:: debian/stamp-bootstrap
-
-debian/stamp-bootstrap:
-ifneq "$(wildcard /usr/share/libtool/ltmain.sh)" ""
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -f /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- make -f admin/Makefile.common cvs
- touch debian/stamp-bootstrap
-
-makebuilddir/kbarcode-trinity::
- find . -type f -name Makefile.in | xargs rm -f
- $(MAKE) -f admin/Makefile.common
-
-binary-install/kbarcode-trinity::
- mv debian/kbarcode-trinity/usr/share/man debian/kbarcode-trinity/opt/trinity/share/
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"