summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/kbfx/debian/cmake.mk
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-07-10 16:17:43 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-07-10 16:17:43 -0500
commit9b2075d9b89fc628c447fbb98f43ef72e4a9c81d (patch)
tree2de9e866f064b1c7d36df24de1df305474f949fe /ubuntu/maverick/applications/kbfx/debian/cmake.mk
downloadtde-packaging-9b2075d9b89fc628c447fbb98f43ef72e4a9c81d.tar.gz
tde-packaging-9b2075d9b89fc628c447fbb98f43ef72e4a9c81d.zip
Initial import from old SVN repository
Note that only the Debian and Ubuntu folders were preserved
Diffstat (limited to 'ubuntu/maverick/applications/kbfx/debian/cmake.mk')
-rw-r--r--ubuntu/maverick/applications/kbfx/debian/cmake.mk76
1 files changed, 76 insertions, 0 deletions
diff --git a/ubuntu/maverick/applications/kbfx/debian/cmake.mk b/ubuntu/maverick/applications/kbfx/debian/cmake.mk
new file mode 100644
index 000000000..4c7e2e24c
--- /dev/null
+++ b/ubuntu/maverick/applications/kbfx/debian/cmake.mk
@@ -0,0 +1,76 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright (C) 2006 Peter Rockai <me@mornfall.net>
+# Copyright (C) 2006 Fathi Boudra <fboudra@free.fr>
+# Description: A class for cmake packages
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_cmake
+_cdbs_class_cmake := 1
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+DEB_MAKE_INSTALL_TARGET = install DESTDIR=$(DEB_DESTDIR)
+DEB_CMAKE_PREFIX =/usr
+
+# Overriden from makefile-vars.mk
+# We pass CFLAGS and friends to ./configure, so no need to pass them to make
+DEB_MAKE_INVOKE = $(DEB_MAKE_ENVVARS) $(MAKE) -C $(DEB_BUILDDIR)
+
+include $(_cdbs_class_path)/makefile.mk$(_cdbs_makefile_suffix)
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+# well, -O0
+endif
+
+ifneq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+# semi-debug
+else
+# final
+endif
+
+ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
+# debug
+endif
+
+#DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+
+common-configure-arch common-configure-indep:: common-configure-impl
+common-configure-impl:: $(DEB_BUILDDIR)/CMakeCache.txt
+$(DEB_BUILDDIR)/CMakeCache.txt:
+ cd $(DEB_BUILDDIR) && cmake $(CURDIR)/$(DEB_SRCDIR) \
+ -DCMAKE_INSTALL_PREFIX="$(DEB_CMAKE_PREFIX)" \
+ $(DEB_CMAKE_EXTRA_FLAGS) -DCMAKE_CXX_FLAGS="$(CXXFLAGS)" \
+ -DCMAKE_C_FLAGS="$(CFLAGS)" -DCMAKE_VERBOSE_MAKEFILE=ON
+ mkdir -p $(DEB_DESTDIR)
+
+cleanbuilddir::
+ -if test "$(DEB_BUILDDIR)" != "$(DEB_SRCDIR)"; then rm -rf $(DEB_BUILDDIR); fi
+
+endif
+