summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/kde-style-qtcurve/debian/cdbs/uploaders.mk
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-24 20:08:05 -0600
committerSlávek Banko <slavek.banko@axis.cz>2012-09-01 19:24:07 +0200
commit53e3cfefab51bd844a28bc02c47a667690e2384b (patch)
treeb9af9babb2dff7148588ffd761b3fdac8e16b1ad /ubuntu/maverick/applications/kde-style-qtcurve/debian/cdbs/uploaders.mk
parent08196adb14359837d49d4504429817919973ad44 (diff)
downloadtde-packaging-53e3cfefab51bd844a28bc02c47a667690e2384b.tar.gz
tde-packaging-53e3cfefab51bd844a28bc02c47a667690e2384b.zip
Fix tde-style-qtcurve on Debian and Ubuntu
(cherry picked from commit 65a3fe0c81c103ee83cd326cf05a3b6ce18f2b4d)
Diffstat (limited to 'ubuntu/maverick/applications/kde-style-qtcurve/debian/cdbs/uploaders.mk')
-rw-r--r--ubuntu/maverick/applications/kde-style-qtcurve/debian/cdbs/uploaders.mk29
1 files changed, 29 insertions, 0 deletions
diff --git a/ubuntu/maverick/applications/kde-style-qtcurve/debian/cdbs/uploaders.mk b/ubuntu/maverick/applications/kde-style-qtcurve/debian/cdbs/uploaders.mk
new file mode 100644
index 000000000..31adfe31e
--- /dev/null
+++ b/ubuntu/maverick/applications/kde-style-qtcurve/debian/cdbs/uploaders.mk
@@ -0,0 +1,29 @@
+
+MAINTAINER=Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
+UPLOADERS=$(shell grep -e +++ -e "^ -- " debian/changelog | grep -v "debian-qt-kde@lists.debian.org" | head -13 | /bin/sed 's/^\s*//;s/\s*$$//;s/^+++\? Changes by //;s/^+++\? //;s/-- //;s/:$$//;s/ <.*//' | sort -u | while read line ; do grep "$$line" debian/cdbs/team-members ; done | tr "\n" ", " | sed 's/,/, /g;s/, $$//')
+
+
+debian/control.tmp:
+ @if [ ! -e debian/control.in ] ; then \
+ echo "this package is not yet prepared for using automatic update of uploaders"; \
+ echo "Please do so."; \
+ exit 1; \
+ fi
+ @sed 's/@@@UPLOADERS@@@/$(UPLOADERS)/;s#@@@MAINTAINER@@@#$(MAINTAINER)#' debian/control.in > debian/control.tmp
+
+check-uploaders: debian/control.tmp
+ @if ! diff -q debian/control debian/control.tmp ; then \
+ echo "WARNING:: Control file differs from manually generated one" ; \
+ echo "WARNING:: Please update it manually and check it afterwards" ; \
+ echo "WARNING:: Uploaders are updated by debian/rules update-uploaders" ;\
+ echo "WARNING:: If this is a binNMU, NMU or security upload, just ignore" ;\
+ fi
+
+
+clean::
+ rm -f debian/control.tmp
+
+update-uploaders: debian/control.tmp
+ @mv -f debian/control.tmp debian/control
+
+makebuilddir:: check-uploaders