summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/kmplayer/debian/rules
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-07-10 16:17:43 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-07-10 16:17:43 -0500
commit9b2075d9b89fc628c447fbb98f43ef72e4a9c81d (patch)
tree2de9e866f064b1c7d36df24de1df305474f949fe /ubuntu/maverick/applications/kmplayer/debian/rules
downloadtde-packaging-9b2075d9b89fc628c447fbb98f43ef72e4a9c81d.tar.gz
tde-packaging-9b2075d9b89fc628c447fbb98f43ef72e4a9c81d.zip
Initial import from old SVN repository
Note that only the Debian and Ubuntu folders were preserved
Diffstat (limited to 'ubuntu/maverick/applications/kmplayer/debian/rules')
-rwxr-xr-xubuntu/maverick/applications/kmplayer/debian/rules46
1 files changed, 46 insertions, 0 deletions
diff --git a/ubuntu/maverick/applications/kmplayer/debian/rules b/ubuntu/maverick/applications/kmplayer/debian/rules
new file mode 100755
index 000000000..b23d91457
--- /dev/null
+++ b/ubuntu/maverick/applications/kmplayer/debian/rules
@@ -0,0 +1,46 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/rules/simple-patchsys.mk
+include debian/cdbs/kde.mk
+include /usr/share/cdbs/1/rules/utils.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+_P=)
+GCC_VERSION := $(shell gcc --version | sed -n "/^gcc/s/^[^$(_P)]*$(_P) \(.\..\).*/\1/p")
+ifeq ($(GCC_VERSION),4.3)
+ CXX = g++ -fpermissive
+endif
+
+DEB_CONFIGURE_EXTRA_FLAGS := --enable-maintainer-mode --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/kde
+DEB_DH_INSTALL_ARGS = --sourcedir=debian/tmp
+DEB_INSTALL_MANPAGES_kmplayer = kmplayer.1
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ make -f admin/Makefile.common cvs
+ touch debian/stamp-bootstrap
+
+build/kmplayer-trinity::
+ docbook2x-man debian/kmplayer.1.docbook
+
+clean::
+ rm -f kmplayer.1
+
+get-orig-source-dpatch:
+ @@dh_testdir
+ @@[ -d ../tarballs/. ]
+ @@dpatch-get-origtargz ../tarballs