summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/kpilot/debian/cdbs/debian-qt-kde.mk
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-01-03 04:15:17 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-01-03 04:15:17 +0100
commit67af8bb6b90637d6169bf9785b34b713ed6be476 (patch)
tree797ea83f9f76fd85aff16aa2e8aeb33dfe8a9bb5 /ubuntu/maverick/applications/kpilot/debian/cdbs/debian-qt-kde.mk
parent611c4063a91e80b6e9a17e3161cdbb5798b60c06 (diff)
downloadtde-packaging-67af8bb6b90637d6169bf9785b34b713ed6be476.tar.gz
tde-packaging-67af8bb6b90637d6169bf9785b34b713ed6be476.zip
DEB kpilot: Switch to cmake.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'ubuntu/maverick/applications/kpilot/debian/cdbs/debian-qt-kde.mk')
-rw-r--r--ubuntu/maverick/applications/kpilot/debian/cdbs/debian-qt-kde.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/ubuntu/maverick/applications/kpilot/debian/cdbs/debian-qt-kde.mk b/ubuntu/maverick/applications/kpilot/debian/cdbs/debian-qt-kde.mk
index 9f8f97776..60310a01a 100644
--- a/ubuntu/maverick/applications/kpilot/debian/cdbs/debian-qt-kde.mk
+++ b/ubuntu/maverick/applications/kpilot/debian/cdbs/debian-qt-kde.mk
@@ -10,6 +10,7 @@ _cdbs_class_debian-qt-kde := 1
# Note: This _must_ be included before autotools.mk, or it won't work.
common-configure-arch common-configure-indep:: debian/stamp-cvs-make
debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
@@ -18,6 +19,7 @@ ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
endif
$(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
touch debian/stamp-cvs-make
include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
@@ -102,6 +104,7 @@ binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
done
clean::
+ifndef _cdbs_class_cmake
if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
cd $(DEB_SRCDIR); \
find . -name Makefile.in -print | \
@@ -110,6 +113,7 @@ clean::
configure configure.files configure.in stamp-h.in \
subdirs; \
fi
+endif
rm -f debian/stamp-cvs-make
endif