summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/kpowersave/debian/rules
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-07-20 17:41:02 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-07-20 17:41:02 -0500
commit3c19a9ebc3392847a7bc39d5a3831c9d16baa307 (patch)
tree52cfa0d17f3eb57a87383d96e2dad215f8c8fcca /ubuntu/maverick/applications/kpowersave/debian/rules
parentecb34e8dd2bad1e72eba5a63e8e2154eabb05e29 (diff)
downloadtde-packaging-3c19a9ebc3392847a7bc39d5a3831c9d16baa307.tar.gz
tde-packaging-3c19a9ebc3392847a7bc39d5a3831c9d16baa307.zip
Use Autotools to build kpowersave under ubuntu
Diffstat (limited to 'ubuntu/maverick/applications/kpowersave/debian/rules')
-rwxr-xr-xubuntu/maverick/applications/kpowersave/debian/rules47
1 files changed, 34 insertions, 13 deletions
diff --git a/ubuntu/maverick/applications/kpowersave/debian/rules b/ubuntu/maverick/applications/kpowersave/debian/rules
index 7f153b395..2c4fb87d0 100755
--- a/ubuntu/maverick/applications/kpowersave/debian/rules
+++ b/ubuntu/maverick/applications/kpowersave/debian/rules
@@ -1,24 +1,45 @@
#!/usr/bin/make -f
-# Set LD_LIBRARY_PATH to the installed library directory to allow dh_shlibdeps to function
-# Also include the main Trinity path
-ifeq ("$(LD_LIBRARY_PATH)", "")
-LD_LIBRARY_PATH=debian/tmp/opt/trinity/lib
-else
-LD_LIBRARY_PATH += :debian/tmp/opt/trinity/lib
-endif
-export LD_LIBRARY_PATH
-
+include debian/cdbs/kde.mk
include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/cmake.mk
include /usr/share/cdbs/1/rules/simple-patchsys.mk
-include /usr/share/cdbs/1/rules/utils.mk
-include debian/cdbs/debian-qt-kde.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
DEB_INSTALL_DOCS_ALL := AUTHORS NEWS
+DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/kde
-DEB_CMAKE_EXTRA_FLAGS := -DLIB_SUFFIX="" -DCMAKE_INSTALL_PREFIX="/opt/trinity" -DCONFIG_INSTALL_DIR="/etc/trinity" -DSYSCONF_INSTALL_DIR="/etc/trinity" -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" -DCMAKE_LIBRARY_PATH="/opt/trinity/lib" -DCMAKE_INCLUDE_PATH="/opt/trinity/include/" -DAUTODETECT_QT_DIRS="ON" -DCMAKE_VERBOSE_MAKEFILE="ON" -DBUILD_ALL="ON" -DCMAKE_SKIP_RPATH="OFF"
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ make -f admin/Makefile.common cvs
+ touch debian/stamp-bootstrap
install/kpowersave::
install -p -D -m644 debian/kpowersave-trinity.lintian debian/kpowersave/opt/trinity/share/lintian/overrides/kpowersave
install -p -D -m644 debian/kpowersave-trinity.linda debian/kpowersave/opt/trinity/share/linda/overrides/kpowersave
+
+clean::
+ find . -name Makefile.in | xargs rm -f
+ rm -f acinclude.m4
+ rm -f aclocal.m4
+ rm -f configure
+ rm -f configure.files
+ rm -f configure.in
+ rm -f config.h.in
+ rm -f stamp-h.in
+ rm -f subdirs
+ rm -f admin/ltmain.sh
+ rm -f admin/libtool.m4.in
+ rm -f debian/stamp-bootstrap