summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/kscope/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2013-10-09 01:13:31 +0200
committerSlávek Banko <slavek.banko@axis.cz>2013-10-09 01:13:31 +0200
commit26882ca86584e3ceecc0104ddfbf4f9d118c8e04 (patch)
tree6074483ea9db86f4e118bd3ee987b9f78f63f143 /ubuntu/maverick/applications/kscope/debian/rules
parent89a05bd6892fe4d744b81917cfaa91d1d47a071c (diff)
downloadtde-packaging-26882ca86584e3ceecc0104ddfbf4f9d118c8e04.tar.gz
tde-packaging-26882ca86584e3ceecc0104ddfbf4f9d118c8e04.zip
Add kscope packaging files for Debian and Ubuntu
Diffstat (limited to 'ubuntu/maverick/applications/kscope/debian/rules')
-rwxr-xr-xubuntu/maverick/applications/kscope/debian/rules40
1 files changed, 40 insertions, 0 deletions
diff --git a/ubuntu/maverick/applications/kscope/debian/rules b/ubuntu/maverick/applications/kscope/debian/rules
new file mode 100755
index 000000000..65883a481
--- /dev/null
+++ b/ubuntu/maverick/applications/kscope/debian/rules
@@ -0,0 +1,40 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/kde.mk
+include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include /usr/share/cdbs/1/rules/utils.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ dh_testdir
+
+ # Regenerate build system
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ autoreconf --install && automake -f && \
+ $(MAKE) -f admin/Makefile.common && \
+ touch debian/stamp-bootstrap
+
+build/kscope-trinity::
+ /usr/bin/docbook2x-man debian/kscope.xml
+
+binary-install/kscope-trinity::
+ mv debian/$(cdbs_curpkg)/usr/share/man debian/$(cdbs_curpkg)/opt/trinity/share/
+
+clean::
+ rm -f kscope.1
+ rm -f debian/stamp-bootstrap