summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/tdeio-ftps/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2013-07-27 12:53:59 +0200
committerSlávek Banko <slavek.banko@axis.cz>2013-07-27 12:53:59 +0200
commit4091eb1d72ab057aba851b60e266b9a443c34b35 (patch)
tree8a9497f59b773863dc773747496e0eb3a8b31123 /ubuntu/maverick/applications/tdeio-ftps/debian/rules
parente2546c5b64bbae2a17a3802ac5c691c6370f54d5 (diff)
downloadtde-packaging-4091eb1d72ab057aba851b60e266b9a443c34b35.tar.gz
tde-packaging-4091eb1d72ab057aba851b60e266b9a443c34b35.zip
Fix tdeio-ftps packaging files for Debian and Ubuntu
Diffstat (limited to 'ubuntu/maverick/applications/tdeio-ftps/debian/rules')
-rwxr-xr-xubuntu/maverick/applications/tdeio-ftps/debian/rules38
1 files changed, 24 insertions, 14 deletions
diff --git a/ubuntu/maverick/applications/tdeio-ftps/debian/rules b/ubuntu/maverick/applications/tdeio-ftps/debian/rules
index 9c0411fc5..55935a695 100755
--- a/ubuntu/maverick/applications/tdeio-ftps/debian/rules
+++ b/ubuntu/maverick/applications/tdeio-ftps/debian/rules
@@ -1,22 +1,32 @@
#!/usr/bin/make -f
-cdbs_kde_enable_debug = --disable-debug
-
include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/kde.mk
+include debian/cdbs/kde.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
-DEB_CONFIGURE_EXTRA_FLAGS := --disable-rpath --libdir=/usr/lib/kde3
+post-patches:: debian/stamp-bootstrap
-build-stamp:
+debian/stamp-bootstrap:
dh_testdir
- /usr/bin/libtoolize -f
+ # Regenerate build system
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
- cp -f /usr/share/misc/config.guess admin/config.guess
- cp -f /usr/share/misc/config.sub admin/config.sub
-
- $(MAKE) -f admin/Makefile.common
-
- QTDIR=/usr/share/tqt3 ./configure $(configkde) --disable-final
- $(MAKE)
- touch build-stamp
+
+ autoreconf --install && automake -f && \
+ $(MAKE) -f admin/Makefile.common && \
+ touch debian/stamp-bootstrap
+
+clean::
+ dh_testdir
+ rm -f debian/stamp-bootstrap