summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/tdeio-ftps/debian
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2018-09-13 09:56:12 +0200
committerSlávek Banko <slavek.banko@axis.cz>2018-09-13 09:56:12 +0200
commit35d5990302db69a9d3d60d7915b2e30194b37939 (patch)
treefc54ba66f412a0663ded4f25661175646779298d /ubuntu/maverick/applications/tdeio-ftps/debian
parent4d840737b301cf320555f00712a6a0a34d363c74 (diff)
downloadtde-packaging-35d5990302db69a9d3d60d7915b2e30194b37939.tar.gz
tde-packaging-35d5990302db69a9d3d60d7915b2e30194b37939.zip
DEB tdeio-ftps: Switch to cmake
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'ubuntu/maverick/applications/tdeio-ftps/debian')
-rw-r--r--ubuntu/maverick/applications/tdeio-ftps/debian/cdbs/debian-qt-kde.mk4
-rw-r--r--ubuntu/maverick/applications/tdeio-ftps/debian/cdbs/kde.mk4
-rw-r--r--ubuntu/maverick/applications/tdeio-ftps/debian/control2
-rw-r--r--ubuntu/maverick/applications/tdeio-ftps/debian/docs1
-rwxr-xr-xubuntu/maverick/applications/tdeio-ftps/debian/rules45
5 files changed, 25 insertions, 31 deletions
diff --git a/ubuntu/maverick/applications/tdeio-ftps/debian/cdbs/debian-qt-kde.mk b/ubuntu/maverick/applications/tdeio-ftps/debian/cdbs/debian-qt-kde.mk
index b4b889c6d..32ba4acfb 100644
--- a/ubuntu/maverick/applications/tdeio-ftps/debian/cdbs/debian-qt-kde.mk
+++ b/ubuntu/maverick/applications/tdeio-ftps/debian/cdbs/debian-qt-kde.mk
@@ -10,6 +10,7 @@ _cdbs_class_debian-qt-kde := 1
# Note: This _must_ be included before autotools.mk, or it won't work.
common-configure-arch common-configure-indep:: debian/stamp-cvs-make
debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
@@ -18,6 +19,7 @@ ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
endif
$(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
touch debian/stamp-cvs-make
include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
@@ -103,6 +105,7 @@ binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
done
clean::
+ifndef _cdbs_class_cmake
if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
cd $(DEB_SRCDIR); \
find . -name Makefile.in -print | \
@@ -111,6 +114,7 @@ clean::
configure configure.files configure.in stamp-h.in \
subdirs; \
fi
+endif
rm -f debian/stamp-cvs-make
endif
diff --git a/ubuntu/maverick/applications/tdeio-ftps/debian/cdbs/kde.mk b/ubuntu/maverick/applications/tdeio-ftps/debian/cdbs/kde.mk
index 765560c89..023886fc8 100644
--- a/ubuntu/maverick/applications/tdeio-ftps/debian/cdbs/kde.mk
+++ b/ubuntu/maverick/applications/tdeio-ftps/debian/cdbs/kde.mk
@@ -35,7 +35,9 @@ else
DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
endif
+ifndef _cdbs_class_cmake
include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+endif
export kde_cgidir = \$${libdir}/cgi-bin
export kde_confdir = \$${sysconfdir}/trinity
@@ -59,7 +61,7 @@ endif
cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
-DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include/tde"
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
diff --git a/ubuntu/maverick/applications/tdeio-ftps/debian/control b/ubuntu/maverick/applications/tdeio-ftps/debian/control
index 4a68281df..ded3d5042 100644
--- a/ubuntu/maverick/applications/tdeio-ftps/debian/control
+++ b/ubuntu/maverick/applications/tdeio-ftps/debian/control
@@ -2,7 +2,7 @@ Source: tdeio-ftps-trinity
Section: tde
Priority: optional
Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
-Build-Depends: debhelper (>= 7.0.50~), cdbs, autotools-dev, automake, libtool, tdelibs14-trinity-dev
+Build-Depends: debhelper (>= 7.0.50~), cdbs, cmake, tdelibs14-trinity-dev
Standards-Version: 3.8.3
Package: tdeio-ftps-trinity
diff --git a/ubuntu/maverick/applications/tdeio-ftps/debian/docs b/ubuntu/maverick/applications/tdeio-ftps/debian/docs
index e845566c0..6f12db508 100644
--- a/ubuntu/maverick/applications/tdeio-ftps/debian/docs
+++ b/ubuntu/maverick/applications/tdeio-ftps/debian/docs
@@ -1 +1,2 @@
+AUTHORS
README
diff --git a/ubuntu/maverick/applications/tdeio-ftps/debian/rules b/ubuntu/maverick/applications/tdeio-ftps/debian/rules
index 14f8d0476..4c83c4c6d 100755
--- a/ubuntu/maverick/applications/tdeio-ftps/debian/rules
+++ b/ubuntu/maverick/applications/tdeio-ftps/debian/rules
@@ -1,37 +1,24 @@
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
-include debian/cdbs/kde.mk
+include /usr/share/cdbs/1/class/cmake.mk
+#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include debian/cdbs/debian-qt-kde.mk
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+# Honour "parallel=N" option of DEB_BUILD_OPTIONS. Comment out to
+# never build in parallel, regardless of DEB_BUILD_OPTIONS.
+DEB_BUILD_PARALLEL = true
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
-post-patches:: debian/stamp-bootstrap
-
-debian/stamp-bootstrap:
- dh_testdir
-
- # Regenerate build system
-ifneq "$(wildcard /usr/share/libtool/ltmain.sh)" ""
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -f /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- autoreconf --install && automake -f && \
- $(MAKE) -f admin/Makefile.common && \
- touch debian/stamp-bootstrap
-
-clean::
- dh_testdir
- rm -f debian/stamp-bootstrap
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"