summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/tdeio-locate/debian/rules
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-03-06 14:38:41 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-03-06 14:38:41 -0600
commite473251d6d5a894f939a57e580e38e9e96b9cd69 (patch)
treed28b7cf287c6fcd65ebdb01573389885e2133ebc /ubuntu/maverick/applications/tdeio-locate/debian/rules
parent309f28e865c2733f3752110254ba8c227b980876 (diff)
downloadtde-packaging-e473251d6d5a894f939a57e580e38e9e96b9cd69.tar.gz
tde-packaging-e473251d6d5a894f939a57e580e38e9e96b9cd69.zip
Update Debian and Ubuntu packaging to match new module names
Diffstat (limited to 'ubuntu/maverick/applications/tdeio-locate/debian/rules')
-rwxr-xr-xubuntu/maverick/applications/tdeio-locate/debian/rules32
1 files changed, 32 insertions, 0 deletions
diff --git a/ubuntu/maverick/applications/tdeio-locate/debian/rules b/ubuntu/maverick/applications/tdeio-locate/debian/rules
new file mode 100755
index 000000000..ecf59da08
--- /dev/null
+++ b/ubuntu/maverick/applications/tdeio-locate/debian/rules
@@ -0,0 +1,32 @@
+#!/usr/bin/make -f
+
+# Set LD_LIBRARY_PATH to the installed library directory to allow dh_shlibdeps to function
+# Also include the main Trinity path
+ifeq ("$(LD_LIBRARY_PATH)", "")
+LD_LIBRARY_PATH=debian/tmp/opt/trinity/lib
+else
+LD_LIBRARY_PATH += :debian/tmp/opt/trinity/lib
+endif
+export LD_LIBRARY_PATH
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include /usr/share/cdbs/1/rules/simple-patchsys.mk
+include /usr/share/cdbs/1/rules/utils.mk
+include debian/cdbs/debian-qt-kde.mk
+
+DEB_KDE_APIDOX := yes
+
+CXXFLAGS := -DSMB_CTX_FLAG_USE_KERBEROS -DSMB_CTX_FLAG_FALLBACK_AFTER_KERBEROS -g -Wall $(DEB_OPT_FLAG)
+
+DEB_CMAKE_EXTRA_FLAGS := -DLIB_SUFFIX="" -DCMAKE_INSTALL_PREFIX="/opt/trinity" -DCONFIG_INSTALL_DIR="/etc/trinity" -DSYSCONF_INSTALL_DIR="/etc/trinity" -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" -DCMAKE_LIBRARY_PATH="/opt/trinity/lib" -DCMAKE_INCLUDE_PATH="/opt/trinity/include/" -DAUTODETECT_QT_DIRS="ON" -DCMAKE_VERBOSE_MAKEFILE="ON" -DBUILD_ALL="ON" -DCMAKE_SKIP_RPATH="OFF" \
+-DCMAKE_BUILD_TYPE=RelWithDebInfo
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+# Honour "parallel=N" option of DEB_BUILD_OPTIONS. Comment out to
+# never build in parallel, regardless of DEB_BUILD_OPTIONS.
+DEB_BUILD_PARALLEL = true
+
+DEB_INSTALL_DOCS_kio-locate-trinity := -XREADME -XNEWS -XTODO -XAUTHORS