summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/dependencies/tqtinterface/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2012-12-11 03:02:18 +0100
committerSlávek Banko <slavek.banko@axis.cz>2012-12-11 03:51:58 +0100
commit64aefa71763dd8803f9db537f4b16c24092ce763 (patch)
tree6a3d62e0a6c7d2aee9d0ecac288cd746d06f8714 /ubuntu/maverick/dependencies/tqtinterface/debian/rules
parentd14557087bc123c802c56d30190a2c4f6151b586 (diff)
downloadtde-packaging-64aefa71763dd8803f9db537f4b16c24092ce763.tar.gz
tde-packaging-64aefa71763dd8803f9db537f4b16c24092ce763.zip
Use xz (or bzip2) compression for Debian and Ubuntu binary packages
(cherry picked from commit e12b7beacb145e0359e66ec5d4cfc0494d3ca908)
Diffstat (limited to 'ubuntu/maverick/dependencies/tqtinterface/debian/rules')
-rwxr-xr-xubuntu/maverick/dependencies/tqtinterface/debian/rules3
1 files changed, 3 insertions, 0 deletions
diff --git a/ubuntu/maverick/dependencies/tqtinterface/debian/rules b/ubuntu/maverick/dependencies/tqtinterface/debian/rules
index 928631538..ed3f07a6d 100755
--- a/ubuntu/maverick/dependencies/tqtinterface/debian/rules
+++ b/ubuntu/maverick/dependencies/tqtinterface/debian/rules
@@ -14,6 +14,9 @@ DEB_OPT_FLAG += -DDEBIAN_VERSION=$(DEB_VERSION)
DEB_CMAKE_EXTRA_FLAGS := -DPKGCONFIG_INSTALL_DIR="/usr/lib/pkgconfig" -DLIB_SUFFIX="" -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_LIBRARY_PATH="/usr/lib" -DCMAKE_INCLUDE_PATH="/usr/include" -DCMAKE_VERBOSE_MAKEFILE="ON" -DWITH_QT3="ON" -DQTDIR="/usr/share/qt3" -DQT_LIBRARY_DIRS="/usr/share/qt3/lib" -DBUILD_ALL="ON" -DUSE_QT3="ON" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
# Honour "parallel=N" option of DEB_BUILD_OPTIONS. Comment out to
# never build in parallel, regardless of DEB_BUILD_OPTIONS.
DEB_BUILD_PARALLEL = true