summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/tdelibs/debian/patches
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-04 12:06:08 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-04 12:06:08 -0500
commit1b6efb141bcf333e5c73a520e701d1de8cafcf4e (patch)
tree2c8231c62e760299a8109716eecf4647514b3315 /ubuntu/maverick/tdelibs/debian/patches
parenta2c2f2ed2eaad5d897c9a00ff5d804486751e603 (diff)
downloadtde-packaging-1b6efb141bcf333e5c73a520e701d1de8cafcf4e.tar.gz
tde-packaging-1b6efb141bcf333e5c73a520e701d1de8cafcf4e.zip
Rename kde packages to tde
Diffstat (limited to 'ubuntu/maverick/tdelibs/debian/patches')
-rw-r--r--ubuntu/maverick/tdelibs/debian/patches/kubuntu_19_debianize_useragent.diff39
-rw-r--r--ubuntu/maverick/tdelibs/debian/patches/kubuntu_38_no_generate_kdepot.diff14
-rw-r--r--ubuntu/maverick/tdelibs/debian/patches/kubuntu_64_rosetta_translation.diff11
3 files changed, 64 insertions, 0 deletions
diff --git a/ubuntu/maverick/tdelibs/debian/patches/kubuntu_19_debianize_useragent.diff b/ubuntu/maverick/tdelibs/debian/patches/kubuntu_19_debianize_useragent.diff
new file mode 100644
index 000000000..715b2bd22
--- /dev/null
+++ b/ubuntu/maverick/tdelibs/debian/patches/kubuntu_19_debianize_useragent.diff
@@ -0,0 +1,39 @@
+--- a/kio/kio/kprotocolmanager.cpp
++++ b/kio/kio/kprotocolmanager.cpp
+@@ -450,14 +450,19 @@
+ return d->useragent;
+
+ TQString supp;
++ int debian_append = 0;
+ struct utsname nam;
+ if( uname(&nam) >= 0 )
+ {
+ if( modifiers.contains('o') )
+ {
+ supp += TQString("; %1").arg(nam.sysname);
++ debian_append = 1;
+ if ( modifiers.contains('v') )
++ {
+ supp += TQString(" %1").arg(nam.release);
++ debian_append = 2;
++ }
+ }
+ if( modifiers.contains('p') )
+ {
+@@ -485,6 +490,16 @@
+ }
+ d->modifiers = modifiers;
+ d->useragent = CFG_DEFAULT_UAGENT(supp);
++
++ if (debian_append == 1)
++ d->useragent.append(" (Debian)");
++ else if (debian_append == 2)
++ {
++#define STRINGIFY(macro_or_string) STRINGIFY_ARG(macro_or_string)
++#define STRINGIFY_ARG(contents) #contents
++ d->useragent.append(" (Debian package " STRINGIFY(DEBIAN_VERSION) ")");
++ }
++
+ return d->useragent;
+ }
+
diff --git a/ubuntu/maverick/tdelibs/debian/patches/kubuntu_38_no_generate_kdepot.diff b/ubuntu/maverick/tdelibs/debian/patches/kubuntu_38_no_generate_kdepot.diff
new file mode 100644
index 000000000..d5b892428
--- /dev/null
+++ b/ubuntu/maverick/tdelibs/debian/patches/kubuntu_38_no_generate_kdepot.diff
@@ -0,0 +1,14 @@
+--- kdelibs/Makefile.am.in 2006-06-26 16:14:54.000000000 +0000
++++ kdelibs/Makefile.am.in 2006-06-26 16:16:33.000000000 +0000
+@@ -54,10 +54,8 @@
+ find $$dirs -maxdepth 1 -name "*.cc" -print >> files ;\
+ find $$dirs -maxdepth 1 -name "*.h" -print >> files ;\
+ echo ./kdecore/kde-config.cpp.in >> files ;\
+- $(EXTRACTRC) `find $$dirs -maxdepth 1 \( -name "*.rc" -o -name "*.ui" \) ` ./dnssd/kcm_kdnssd.kcfg > rc.cpp; \
+- : > kde.pot ;\
++ $(EXTRACTRC) `find $$dirs -maxdepth 1 \( -name "*.rc" -o -name "*.ui" \) ` ./dnssd/kcm_kdnssd.kcfg > rc.cpp;
+ $(XGETTEXT) -ktranslate -x qt-messages.pot rc.cpp `cat files` && cat messages.po qt-messages.pot > $(podir)/kdelibs.pot
+- $(XGETTEXT) common_texts.cpp -o kde.pot
+ rm -f dirs
+
+ EXTRA_DIST = admin kde.pot \
diff --git a/ubuntu/maverick/tdelibs/debian/patches/kubuntu_64_rosetta_translation.diff b/ubuntu/maverick/tdelibs/debian/patches/kubuntu_64_rosetta_translation.diff
new file mode 100644
index 000000000..b21ebe312
--- /dev/null
+++ b/ubuntu/maverick/tdelibs/debian/patches/kubuntu_64_rosetta_translation.diff
@@ -0,0 +1,11 @@
+--- kdelibs/kdecore/kaboutdata.cpp 2006-03-17 10:19:05.000000000 +0000
++++ kdelibs/kdecore/kaboutdata.cpp 2006-12-05 19:46:12.000000000 +0000
+@@ -389,7 +389,7 @@
+ "of the translation teams all over the world.</p>"
+ "<p>For more information on KDE internationalization "
+ "visit <a href=\"http://l10n.kde.org\">http://l10n.kde.org</a></p>"
+- );
++ ) + i18n("<p>Debian includes additions and alterations to the KDE translation from <a href=\"https://translations.launchpad.net/\">Launchpad</a>.</p>");
+ }
+
+ TQString