summaryrefslogtreecommitdiffstats
path: root/ubuntu/precise/tdenetwork/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2014-04-17 13:57:20 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2014-04-17 13:57:20 +0900
commit2d59086b104acd7b4711fd067c9bb4480158e6ab (patch)
tree7d3d9aff90930e65a491c055510aba94debc6da9 /ubuntu/precise/tdenetwork/debian/rules
parent55b519366b1dcd7ab5b2f1f720d275b33fc4bd49 (diff)
downloadtde-packaging-2d59086b104acd7b4711fd067c9bb4480158e6ab.tar.gz
tde-packaging-2d59086b104acd7b4711fd067c9bb4480158e6ab.zip
Removed Ubuntu/precise folder
Diffstat (limited to 'ubuntu/precise/tdenetwork/debian/rules')
-rwxr-xr-xubuntu/precise/tdenetwork/debian/rules64
1 files changed, 0 insertions, 64 deletions
diff --git a/ubuntu/precise/tdenetwork/debian/rules b/ubuntu/precise/tdenetwork/debian/rules
deleted file mode 100755
index 51643631e..000000000
--- a/ubuntu/precise/tdenetwork/debian/rules
+++ /dev/null
@@ -1,64 +0,0 @@
-#!/usr/bin/make -f
-
-DEB_HOST_ARCH_OS=$(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
-DEB_HOST_ARCH=$(shell dpkg-architecture -qDEB_HOST_ARCH)
-
-ifeq ($(DEB_HOST_ARCH),s390)
-DONT_BUILD+= kwifimanager
-endif
-ifneq ($(DEB_HOST_ARCH_OS),linux)
-DONT_BUILD+= kwifimanager tdednssd
-endif
-export DH_OPTIONS
-
-# include debian/cdbs/buildvars.mk
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/cmake.mk
-include debian/cdbs/debian-qt-kde.mk
-#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
-include /usr/share/cdbs/1/rules/utils.mk
-
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
-
-DEB_CMAKE_EXTRA_FLAGS := \
- -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
- -DCONFIG_INSTALL_DIR="/etc/trinity" \
- -DSYSCONF_INSTALL_DIR="/etc/trinity" \
- -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_VERBOSE_MAKEFILE="ON" \
- -DCMAKE_SKIP_RPATH="OFF" \
- -DBUILD_ALL="ON" \
- -DWITH_ARTS="ON" \
- -DWITH_SLP="ON" \
- -DBUILD_KOPETE_PROTOCOL_ALL="ON" \
- -DBUILD_KOPETE_PLUGIN_ALL="ON"
-
-DEB_DH_STRIP_ARGS := --dbg-package=tdenetwork-trinity-dbg
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
-PACKAGES_WITH_LIBS := librss1-trinity kopete-trinity ksirc-trinity kwifimanager-trinity
-
-#shlibs_ver = 4:3.5.0-1
-#$(foreach p,$(PACKAGES_WITH_LIBS),$(eval DEB_DH_MAKESHLIBS_ARGS_$(p) := -V'$(p) (>= $(shlibs_ver))'))
-
-DEB_FIXPERMS_EXCLUDE := opt/trinity/bin/kppp opt/trinity/bin/kppplogview \
- opt/trinity/etc/ppp/peers/kppp-options
-
-DOC_HTML_PRUNE := kcontrol
-
-binary-install/kppp-trinity::
- chown root:dip debian/kppp-trinity/opt/trinity/bin/kppp*
- chown root:dip debian/kppp-trinity/opt/trinity/etc/ppp/peers/kppp-options
- chmod 4754 debian/kppp-trinity/opt/trinity/bin/kppp
- chmod 0754 debian/kppp-trinity/opt/trinity/bin/kppplogview
- chmod 0640 debian/kppp-trinity/opt/trinity/etc/ppp/peers/kppp-options