summaryrefslogtreecommitdiffstats
path: root/arch/3.5.13/trinity-extras/trinity-kdesdk/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'arch/3.5.13/trinity-extras/trinity-kdesdk/PKGBUILD')
-rw-r--r--arch/3.5.13/trinity-extras/trinity-kdesdk/PKGBUILD75
1 files changed, 0 insertions, 75 deletions
diff --git a/arch/3.5.13/trinity-extras/trinity-kdesdk/PKGBUILD b/arch/3.5.13/trinity-extras/trinity-kdesdk/PKGBUILD
deleted file mode 100644
index b7cec01c2..000000000
--- a/arch/3.5.13/trinity-extras/trinity-kdesdk/PKGBUILD
+++ /dev/null
@@ -1,75 +0,0 @@
-# Maintainer: Pawel 'l0ner' Soltys <pwslts@gmail.com>
-# Contributor: Calvin Morrison <mutantturkey@gmail.com>
-
-pkgname=trinity-kdesdk
-pkgver=3513
-pkgrel=2
-arch=('i686' 'x86_64')
-url='http://www.trinitydesktop.org'
-license=('GPL')
-groups=('trinity-extras')
-pkgdesc="Trinity Software Developement Kit"
-depends=('trinity-kdebase' 'subversion')
-makedepends=('pkgconfig' 'cmake' 'imake')
-options=('libtool' '!strip')
-source=('http://mirror.ets.kth.se/trinity/releases/3.5.13/kdesdk-3.5.13.tar.gz' 'kdesdk.patch')
-source=('http://anduin.linuxfromscratch.org/sources/trinity/kdesdk-3.5.13.tar.gz' 'kdesdk.patch')
-md5sums=('130662f683be1a49d56a713c5ae87e46'
- 'a1d0b533ae427847bd84e601c587f882')
-
-build() {
- msg "Setting PATH, CMAKE and Trinity Environment variables"
- [ "$QTDIR" = "" ] && . /etc/profile.d/qt3.sh
- [ "$TDEDIR" = "" ] && . /etc/profile.d/trinity.sh
-
- patch -N -d ${srcdir} -p0 < kdesdk.patch
-
- cd $srcdir/kdesdk
-
- msg "Starting configure..."
- cp -f "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
- cp -f "/usr/share/libtool/config/ltmain.sh" "admin/ltmain.sh"
- sed -i -e "s@/usr/include/tqt@$TDEDIR/include/tqt@" admin/acinclude.m4.in
- make -f admin/Makefile.common
-
- msg "Starting configure..."
- ./configure --with-qt-dir=${QTDIR} \
- --prefix=${TDEDIR} \
- --enable-closure \
- --with-berkeley-db \
- --with-subversion
- #--with-extra-includes=${TDEDIR}/include:/usr/include/dbus-1.0:${TDEDIR}/include/libkrandr \
- #--with-extra-libs=${TDEDIR}/lib:${TDEDIR}/lib/trinity:${TDEDIR}/pkgconfig \
-
- make
-
- #msg "Starting cmake..."
- #cmake ${srcdir}/kdesdk \
- # -DCMAKE_INSTALL_PREFIX=${TDEDIR} \
- # -DCMAKE_VERBOSE_MAKEFILE=ON \
- # -DWITH_DBSEARCHENGINE=ON \
- # -DWITH_KCAL=ON \
- # -DBUILD_ALL=ON
- #make
-
- #--with-berkeley-db enable the dictionary plugin based on Berkeley DB IV
- #--with-db-dir=DIR where the root of Berkeley DB IV is installed
- #--with-db-include-dir=DIR where the includes of Berkeley DB IV are installed
- #--with-db-include=FILE path to the Berkeley DB IV header file
- #--with-db-lib-dir=DIR where the libs of Berkeley DB IV are installed
- #--with-db-name=NAME name of the Berkeley DB IV library (default db)
-
- #--with-subversion enable support for subversion [default=check]
- #--with-apr-config=FILE Use the given path to apr-config when determining APR configuration; defaults to "apr-config"
- #--with-apu-config=FILE Use the given path to apu-config when determining APR util configuration; defaults to "apu-config"
- #--with-subversion-dir=DIR where Subversion is installed
- #--with-svn-include=DIR Use the given path to the subversion headers.
- #--with-svn-lib=DIR
-
-}
-
-package() {
- msg "Packaging - $pkgname-$pkgver"
- cd ${srcdir}/kdesdk
- make DESTDIR="$pkgdir" install
-}