summaryrefslogtreecommitdiffstats
path: root/arch/calvin/trinity-qt3/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'arch/calvin/trinity-qt3/PKGBUILD')
-rw-r--r--arch/calvin/trinity-qt3/PKGBUILD90
1 files changed, 90 insertions, 0 deletions
diff --git a/arch/calvin/trinity-qt3/PKGBUILD b/arch/calvin/trinity-qt3/PKGBUILD
new file mode 100644
index 000000000..efa19d7f5
--- /dev/null
+++ b/arch/calvin/trinity-qt3/PKGBUILD
@@ -0,0 +1,90 @@
+# Maintainer: Calvin Morrison <MutantTurkey@gmail.com>
+pkgname=trinity-qt3
+pkgver=20110907
+pkgrel=1
+pkgdesc="The Qt3 gui toolkit - with Trinity upstream"
+_prefix="/opt/qt"
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://trinitydesktop.org"
+# install=qt.install
+groups=('trinity')
+depends=('libjpeg-turbo' 'libmng' 'libmysqlclient' 'libpng' 'libxmu' 'libxcursor' 'libxinerama' 'libxft' 'libxrandr' 'mesa' 'postgresql-libs' 'unixodbc')
+makedepends=('cups' 'libxi' 'mysql' 'postgresql' 'unixodbc' 'sqlite3')
+optdepends=()
+# optdepends=('libmysqlclient' 'postgresql-libs' 'unixodbc')
+provides=('trinity-qt3' 'qt3')
+conflicts=('qt3' 'qt3-enhanced')
+replaces=('trinity-qt3')
+_prefix="opt/qt3"
+source=()
+options=(!libtool)
+
+
+_gitroot="http://scm.trinitydesktop.org/scm/git/tde"
+_gitname="tde/main/dependencies/qt3"
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [ -d $_gitname ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting make..."
+
+
+
+ cd "$srcdir/$_gitname"
+
+
+
+ # remove unwanted mkspecs
+ rm -rf mkspecs/{*aix*,*bsd*,cygwin*,dgux*,darwin*,hpux*,hurd*,irix*,lynxos*,macx*,qnx*,reliant*,sco*,solaris*,tru64*,unixware*,win32*}
+
+ # set arch if x86_64 build
+ if [ "$CARCH" = "x86_64" ]; then
+ export ARCH="-64"
+ else unset ARCH
+ fi
+
+# ./configure -prefix /opt/qt -platform linux-g++$ARCH \
+# -system-zlib -qt-gif -release -shared -sm -nis -thread -stl \
+# -system-lib{png,jpeg,mng} \
+# -no-g++-exceptions -plugin-sql-{mysql,psql,sqlite,odbc}
+
+
+ msg "Starting configure..."
+ ./configure -prefix ${_prefix} \
+ -sysconfdir /etc/qt \
+ -qt-gif \
+ -system-zlib \
+ -system-libjpeg \
+ -plugin-imgfmt-jpeg \
+ -system-libmng \
+ -plugin-imgfmt-mng \
+ -system-libpng \
+ -plugin-imgfmt-png \
+ -plugin-sql-mysql \
+ -plugin-sql-psql \
+ -plugin-sql-sqlite \
+ -no-exceptions \
+ -thread \
+ -no-tablet
+ #-platform linux-g++
+ make -C qmake || return 1
+ make
+
+}
+
+package() {
+
+echo $PWD
+echo "woooot!"
+ make DESTDIR=${pkgdir} install
+}