summaryrefslogtreecommitdiffstats
path: root/arch/master/trinity-app-amarok/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'arch/master/trinity-app-amarok/PKGBUILD')
-rw-r--r--arch/master/trinity-app-amarok/PKGBUILD100
1 files changed, 100 insertions, 0 deletions
diff --git a/arch/master/trinity-app-amarok/PKGBUILD b/arch/master/trinity-app-amarok/PKGBUILD
new file mode 100644
index 000000000..007ccbb58
--- /dev/null
+++ b/arch/master/trinity-app-amarok/PKGBUILD
@@ -0,0 +1,100 @@
+# $Id$
+# Maintainer: David C. Rankin <drankinatty@gmail.com>
+#
+# All modifications and uses of this file are licensed under
+# the software for which this file was made for, should the software
+# be under an Open Source License, at least version 1.9, defined
+# by the Open Source Initiative. In other cases, this file is automatically
+# released to the Public Domain.
+#
+
+pkgbase=trinity
+pkgname=trinity-app-amarok
+pkgver=1236712
+pkgrel=1
+arch=('i686' 'x86_64')
+url='http://www.kde.org'
+license=('GPL')
+groups=('trinity')
+pkgdesc="Trinity - amarok"
+depends=('trinity-kdebase' 'libifp' 'libmtp' 'libnjb' 'python-daap')
+makedepends=('pkgconfig' 'cmake' 'autoconf' 'subversion' 'imake')
+provides=('trinity-app-amarok')
+conflicts=('trinity-app-amarok')
+replaces=('trinity-app-amarok')
+options=('libtool' '!strip')
+source=()
+
+_svnmod=amarok
+_svntrunk="svn://anonsvn.kde.org/home/kde/branches/trinity/applications/${_svnmod}"
+
+build() {
+
+ cd ${srcdir}
+
+ msg "Connecting to SVN server to update or checkout ${_svnmod}...."
+ if [ -d ${_svnmod}/.svn ]; then
+ (cd ${_svnmod} && svn up)
+ [[ $? -eq 0 ]] || _co_failed=1
+ else
+ (svn co $_svntrunk ${_svnmod})
+ [[ $? -eq 0 ]] || _co_failed=1
+ fi
+
+ # if update or checkout failed - bail...
+ if [[ $_co_failed -ne 1 ]]; then
+ msg "SVN checkout of revision $pkgver -- Complete."
+ else
+ msg "SVN checkout of revision $pkgver -- Failed or server timeout."
+ exit 1
+ fi
+
+ msg "Setting PATH, CMAKE and Trinity Environment variables"
+ export CMAKE_PREFIX_PATH=/opt/qt:/opt/trinity
+ export CMAKE_INCLUDE_PATH=/opt/qt/include/tqt:\
+/usr/include/dbus-1.0:\
+/opt/trinity/include
+ export LD_LIBRARY_PATH=/opt/trinity/lib:/opt/trinity/lib/kde3:$LD_LIBRARY_PATH
+ export PKG_CONFIG_PATH=:/opt/qt/lib/pkgconfig
+# export PKG_CONFIG_PATH=:/opt/trinity/lib/pkgconfig:/opt/qt/lib/pkgconfig
+# /opt/qt/include:\
+
+# cd ${srcdir}/${_svnmod}
+
+ trinity_prefix="/opt/trinity"
+
+ cd $srcdir
+ msg "Creating out-of-source build directory: ${srcdir}/build"
+ mkdir -p build
+ cd build
+
+ # Baho additions
+ CFLAGS=${CFLAGS}" -fpermissive"
+ CXXFLAGS=${CXXFLAGS}" -fpermissive"
+
+ msg "Starting cmake..."
+ cmake ${srcdir}/${_svnmod} \
+ -DCMAKE_INSTALL_PREFIX=${trinity_prefix} \
+ -DCMAKE_VERBOSE_MAKEFILE=ON \
+ -DQT_VERSION=3 \
+ -DWITH_IFP=ON \
+ -DWITH_NJB=ON \
+ -DWITH_MTP=ON \
+ -DWITH_DAAP=ON \
+ -DBUILD_ALL=ON
+ make
+# -DWITH_QT3=ON \
+# -DQTDIR=/opt/qt \
+# -DQT_DOCDIR=/opt/qt/man \
+# -DQT_LIBRARY_DIRS=/opt/qt/lib \
+}
+
+package() {
+ msg "Packaging - $pkgname-$pkgver"
+# cd ${srcdir}/${_svnmod}
+ cd ${srcdir}/build
+
+ make DESTDIR="$pkgdir/" install
+
+# rm -r ${srcdir}/${_svnmod}
+}