summaryrefslogtreecommitdiffstats
path: root/arch/tde-extra/tde-tdmtheme/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'arch/tde-extra/tde-tdmtheme/PKGBUILD')
-rw-r--r--arch/tde-extra/tde-tdmtheme/PKGBUILD34
1 files changed, 20 insertions, 14 deletions
diff --git a/arch/tde-extra/tde-tdmtheme/PKGBUILD b/arch/tde-extra/tde-tdmtheme/PKGBUILD
index c6c368ab2..0d17958d1 100644
--- a/arch/tde-extra/tde-tdmtheme/PKGBUILD
+++ b/arch/tde-extra/tde-tdmtheme/PKGBUILD
@@ -1,22 +1,26 @@
# Contributor: e1z0 <justinas at eofnet dot lt>
-pkgname=tde-tdmtheme
-pkgver=14.0.10
+_mod=tdmtheme
+_cat=applications/themes/
+_kdemod="${_mod/tde/kde}"
+
+pkgname="tde-${_mod/tde-}"
+pkgver=14.1.1
pkgrel=1
pkgdesc="TDM Theme"
-arch=('i686' 'x86_64')
-url='https://scm.trinitydesktop.org/scm/git/applications/tdmtheme'
+arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'powerpc64le')
+url="https://scm.trinitydesktop.org/scm/git/${_mod}"
license=('GPL')
groups=('tde-extra')
depends=('tde-tdelibs')
-makedepends=('pkgconfig' 'cmake')
-#provides=('tdmtheme')
-#conflicts=('tdmtheme')
-#replaces=('tdmtheme')
+makedepends=('tde-cmake-trinity')
+provides=("${_mod}")
+conflicts=("trinity-${_kdemod}" "kdemod3-${_kdemod}")
+replaces=("trinity-${_mod}")
options=('staticlibs' 'libtool' '!strip')
-source=("https://mirror.ppa.trinitydesktop.org/trinity/releases/R${pkgver}/main/applications/tdmtheme-trinity-${pkgver}.tar.xz")
-md5sums=('b085fa2792024415fb2174633875adbe')
-# install=''
+source=("https://mirror.ppa.trinitydesktop.org/trinity/releases/R${pkgver}/main/${_cat}${_mod}-trinity-${pkgver}.tar.xz")
+md5sums=('a933db297dd6e73522d150db0398386f')
+install=''
[ -n "$TDEDIR" ] || TDEDIR=/opt/trinity
@@ -27,16 +31,18 @@ build() {
msg "Starting cmake..."
cmake ${srcdir}/${pkgname#*-}-trinity-${pkgver} \
+ -GNinja \
-DCMAKE_VERBOSE_MAKEFILE=ON \
-DCMAKE_INSTALL_PREFIX=${TDEDIR} \
- -DBUILD_ALL=ON
+ -DBUILD_ALL=ON \
+ -DWITH_ALL_OPTIONS=ON
msg "Building - ${pkgname#*-}..."
- make $NUMJOBS
+ ninja $NUMJOBS
}
package() {
msg "Packaging - $pkgname-$pkgver"
cd ${srcdir}/build
- make -j1 DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" ninja -j1 install
}