summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/graphics/gwenview/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/graphics/gwenview/debian/rules')
-rwxr-xr-xdebian/_base/applications/graphics/gwenview/debian/rules27
1 files changed, 27 insertions, 0 deletions
diff --git a/debian/_base/applications/graphics/gwenview/debian/rules b/debian/_base/applications/graphics/gwenview/debian/rules
new file mode 100755
index 000000000..7c5315da0
--- /dev/null
+++ b/debian/_base/applications/graphics/gwenview/debian/rules
@@ -0,0 +1,27 @@
+#! /usr/bin/make -f
+
+DEB_PATCHDIRS := debian/patches/common debian/patches
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_CONFIGURE_EXTRA_FLAGS := --enable-kipi --enable-final --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
+DEB_INSTALL_DOCS_ALL :=
+DEB_INSTALL_CHANGELOGS_ALL := NEWS
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = debian/gwenview-trinity/opt/trinity/lib
+
+install/gwenview-trinity::
+ install -p -D -m644 debian/gwenview.xpm debian/$(cdbs_curpkg)/opt/trinity/share/pixmaps/gwenview.xpm
+ install -p -D -m644 debian/gwenview.lintian debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg)
+
+ cd $(CURDIR)/debian/$(cdbs_curpkg)/opt/trinity/share/doc/tde/HTML/en/gwenview; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/gwenview/index.docbook