summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/internet/smb4k/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/internet/smb4k/debian')
-rw-r--r--debian/_base/applications/internet/smb4k/debian/README.Debian8
-rw-r--r--debian/_base/applications/internet/smb4k/debian/cdbs/debian-tde.mk246
-rw-r--r--debian/_base/applications/internet/smb4k/debian/cdbs/versions.pl19
-rw-r--r--debian/_base/applications/internet/smb4k/debian/changelog222
-rw-r--r--debian/_base/applications/internet/smb4k/debian/compat1
-rw-r--r--debian/_base/applications/internet/smb4k/debian/control17
-rw-r--r--debian/_base/applications/internet/smb4k/debian/copyright29
-rw-r--r--debian/_base/applications/internet/smb4k/debian/docs3
-rw-r--r--debian/_base/applications/internet/smb4k/debian/menu8
-rwxr-xr-xdebian/_base/applications/internet/smb4k/debian/rules16
-rw-r--r--debian/_base/applications/internet/smb4k/debian/source/format1
-rw-r--r--debian/_base/applications/internet/smb4k/debian/source/options6
-rw-r--r--debian/_base/applications/internet/smb4k/debian/watch6
13 files changed, 582 insertions, 0 deletions
diff --git a/debian/_base/applications/internet/smb4k/debian/README.Debian b/debian/_base/applications/internet/smb4k/debian/README.Debian
new file mode 100644
index 000000000..995d110e5
--- /dev/null
+++ b/debian/_base/applications/internet/smb4k/debian/README.Debian
@@ -0,0 +1,8 @@
+smb4k for Debian
+----------------
+
+Thanks to Mindaugas Zaksauskas and Alexander Reinholdt who packaged a first version of this program.
+I modified for an up-to-date policy and added cdbs debianizing tool support.
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Fri, 18 Jun 2004 17:00:05 +0200
+
diff --git a/debian/_base/applications/internet/smb4k/debian/cdbs/debian-tde.mk b/debian/_base/applications/internet/smb4k/debian/cdbs/debian-tde.mk
new file mode 100644
index 000000000..f36e3527c
--- /dev/null
+++ b/debian/_base/applications/internet/smb4k/debian/cdbs/debian-tde.mk
@@ -0,0 +1,246 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Copyright © 2019 TDE Team
+# Description: A class for TDE packages; sets TDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+endif
+ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
+endif
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
+ touch debian/stamp-cvs-make
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+ifndef _cdbs_class_cmake
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+endif
+
+ifdef _cdbs_class_cmake
+ifneq "$(wildcard /usr/bin/ninja)" ""
+MAKE = ninja -v
+DEB_MAKE_ENVVARS += DESTDIR=$(DEB_DESTDIR)
+DEB_MAKE_INSTALL_TARGET = install
+DEB_CMAKE_NORMAL_ARGS += -GNinja
+endif
+endif
+
+ifndef _cdbs_rules_patchsys_quilt
+DEB_PATCHDIRS := debian/patches/common debian/patches
+endif
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/tde/HTML
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
+DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+DEB_BUILD_PARALLEL ?= true
+
+cdbs_configure_flags += \
+ --with-qt-dir=/usr/share/qt3 \
+ --disable-rpath \
+ --with-xinerama \
+ $(cdbs_kde_enable_final) \
+ $(cdbs_kde_enable_debug)
+
+
+# This is a convenience target for calling manually.
+# It's not part of the build process.
+buildprep: clean apply-patches
+ifndef _cdbs_class_cmake
+ $(MAKE) -f admin/Makefile.common dist
+endif
+ debian/rules clean
+
+.tdepkginfo:
+ echo "# TDE package information" >.tdepkginfo
+ dpkg-parsechangelog | sed -n "s|^Source: |Name: |p" >>.tdepkginfo
+ dpkg-parsechangelog | sed -n "s|^Version: |Version: |p" >>.tdepkginfo
+ date +"DateTime: %m/%d/%Y %H:%M" -u -d "$$(dpkg-parsechangelog | sed -n 's|^Date: ||p')" >>.tdepkginfo
+
+post-patches:: .tdepkginfo
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+ # update multi-arch path in install files
+ ls -d debian/* | \
+ grep -E "(install|links)$$" | \
+ while read a; do \
+ [ -d $$a ] || [ -f $$a.arch ] || \
+ ! grep -q "\$$(DEB_HOST_MULTIARCH)" $$a || \
+ sed -i.arch "s|\$$(DEB_HOST_MULTIARCH)|$(DEB_HOST_MULTIARCH)|g" $$a; \
+ done
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+ # revert multi-arch path in install files
+ ls -d debian/* | \
+ grep -E "(install|links)$$" | \
+ while read a; do \
+ [ ! -f $$a.arch ] || \
+ mv $$a.arch $$a; \
+ done
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ done
+
+common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+DESTDIR=$(DEB_DESTDIR) $(DEB_MAKE_INVOKE) install-apidox)
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+clean::
+ifndef _cdbs_class_cmake
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+endif
+ rm -f .tdepkginfo
+ rm -f debian/stamp-kde-apidox
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/debian/_base/applications/internet/smb4k/debian/cdbs/versions.pl b/debian/_base/applications/internet/smb4k/debian/cdbs/versions.pl
new file mode 100644
index 000000000..75c9add4b
--- /dev/null
+++ b/debian/_base/applications/internet/smb4k/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "KDE-Version3=$version3\n";
+print "KDE-Version2=$version2\n";
+print "KDE-Next-Version3=$version3_next\n";
+print "KDE-Next-Version2=$version2_next\n";
diff --git a/debian/_base/applications/internet/smb4k/debian/changelog b/debian/_base/applications/internet/smb4k/debian/changelog
new file mode 100644
index 000000000..aa842f771
--- /dev/null
+++ b/debian/_base/applications/internet/smb4k/debian/changelog
@@ -0,0 +1,222 @@
+smb4k-trinity (0.9.4-0ubuntu3) karmic; urgency=low
+
+ * Karmic rebuild
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 02 Jul 2009 16:08:00 -0600
+
+smb4k-trinity (0.9.4-0ubuntu2) intrepid; urgency=low
+
+ * Moved Trinity to /opt/trinity
+ * Integrated properly with KDE4.2+
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Wed, 05 March 2009 01:11:00 -0600
+
+smb4k-trinity (0.9.4-0ubuntu1) intrepid; urgency=low
+
+ * Added -trinity suffix
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Sat, 07 Feb 2009 21:34:00 -0600
+
+smb4k (0.9.4-1) unstable; urgency=low
+
+ * New upstream release.
+ (closes: #477419)
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Tue, 29 Apr 2008 11:00:22 +0200
+
+smb4k (0.9.2-1) unstable; urgency=low
+
+ * New upstream release
+ * Updated minimal build-deps to 3.3 as required upstream.
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Mon, 28 Jan 2008 10:48:11 +0100
+
+smb4k (0.9.1-1) unstable; urgency=low
+
+ * New upstream release.
+ (closes: #343950, #456077, #461370)
+ * Policy bumped to 3.7.3 (no changes)
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Fri, 18 Jan 2008 14:48:20 +0100
+
+smb4k (0.8.6-1) unstable; urgency=low
+
+ * New upstream release.
+ * Introduced Homepage field in debian/control
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Mon, 22 Oct 2007 20:06:08 +0200
+
+smb4k (0.8.4-2) unstable; urgency=low
+
+ * debian/menu transitioned to new sections.
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Tue, 17 Jul 2007 23:03:05 +0200
+
+smb4k (0.8.4-1) unstable; urgency=low
+
+ * New upstream release with minor fixes.
+ * debian/copyright file updated.
+ (closes: #432224)
+ * debian/watch revised.
+ * debian/control revised for description.
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Tue, 10 Jul 2007 09:56:17 +0200
+
+smb4k (0.8.3-1) unstable; urgency=low
+
+ * New upstream release
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Mon, 18 Jun 2007 21:38:37 +0200
+
+smb4k (0.8.1-1) unstable; urgency=high
+
+ * New upstream release (fixes a few security issues)
+ (closes: #417697)
+ * Revised watch file.
+
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Tue, 10 Apr 2007 11:40:40 +0200
+
+smb4k (0.8.0-1) unstable; urgency=low
+
+ * New upstream release
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Fri, 22 Dec 2006 12:27:05 +0100
+
+smb4k (0.7.5-1) unstable; urgency=high
+
+ * New upstream release
+ This version fixes a grave security bug present in all 0.7 versions with
+ sudoers file management.
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Mon, 27 Nov 2006 12:57:57 +0100
+
+smb4k (0.7.3-1) unstable; urgency=low
+
+ * New upstream release
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Wed, 25 Oct 2006 23:30:11 +0200
+
+smb4k (0.7.2-1) unstable; urgency=low
+
+ * New upstream version.
+ * Moved debian/watch to version 3 syntax.
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Thu, 3 Aug 2006 14:55:25 +0200
+
+smb4k (0.7.1-1) unstable; urgency=low
+
+ * New upstream release
+ This version works only with Samba 3.0+
+ * Policy bumped to 3.7.2 without changes.
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Sun, 25 Jun 2006 10:55:40 +0200
+
+smb4k (0.6.9-1) unstable; urgency=low
+
+ * New upstream release
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Fri, 24 Mar 2006 17:01:31 +0100
+
+smb4k (0.6.8-1) unstable; urgency=low
+
+ * New upstream release
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Fri, 17 Mar 2006 22:55:33 +0100
+
+smb4k (0.6.7-1) unstable; urgency=low
+
+ * New upstream release
+ * Removed superfluous libfam-dev build-dep.
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Sun, 5 Feb 2006 23:19:33 +0100
+
+smb4k (0.6.5-1) unstable; urgency=low
+
+ * New upstream release
+ (closes: #343094,#314240)
+ * Transitioned to xorg dependencies.
+ (closes: #346905)
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Mon, 9 Jan 2006 15:25:45 +0100
+
+smb4k (0.6.4-1) unstable; urgency=high
+
+ * New upstream release
+ * Truly fix of #313908 and related issues.
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Fri, 4 Nov 2005 14:54:26 +0100
+
+smb4k (0.6.3-1) unstable; urgency=high
+
+ * New upstream release
+ Fixes a few security flaws due to symlinking abuse.
+ IMHO it require major changes to properly manage IPC with sudo/super,
+ anywy better than nothing...
+ * Little modification (partially yet done by upstream) to de.po
+ (closes: #313908)
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Wed, 31 Aug 2005 15:26:55 +0200
+
+smb4k (0.6.1-1) unstable; urgency=low
+
+ * New upstream release
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Tue, 23 Aug 2005 23:44:01 +0200
+
+smb4k (0.6.0-1) unstable; urgency=low
+
+ * New upstream release
+ * Added missing kdebase-dev build-dep
+ * Policy bumped to 3.6.2
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Tue, 23 Aug 2005 23:29:26 +0200
+
+smb4k (0.5.2-1) unstable; urgency=low
+
+ * New upstream release
+ (closes: #294458, #296458)
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Tue, 29 Mar 2005 12:15:53 +0200
+
+smb4k (0.5.1-1) unstable; urgency=low
+
+ * New upstream release
+ * Added sudo to recommended pkgs in control file.
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Mon, 31 Jan 2005 10:35:10 +0100
+
+smb4k (0.5.0-1) unstable; urgency=low
+
+ * New upstream release
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Thu, 13 Jan 2005 15:21:07 +0100
+
+smb4k (0.4.1a-1) unstable; urgency=high
+
+ * New upstream release.
+ A severe bug in Smb4K's exit code has been found and fixed, which led
+ under certain circumstances to complete data loss on remote shares.
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Mon, 6 Sep 2004 11:40:26 +0200
+
+smb4k (0.4.1-1) unstable; urgency=low
+
+ * New upstream release
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Mon, 30 Aug 2004 21:10:00 +0200
+
+smb4k (0.4.0-2) unstable; urgency=low
+
+ * Missing debhelper dependency added. It is only recommended in cdbs, why?
+ (closes: #257367)
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Sat, 3 Jul 2004 10:14:59 +0200
+
+smb4k (0.4.0-1) unstable; urgency=low
+
+ * Initial release.
+ (closes: #255072)
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Fri, 18 Jun 2004 20:02:30 +0200
+
diff --git a/debian/_base/applications/internet/smb4k/debian/compat b/debian/_base/applications/internet/smb4k/debian/compat
new file mode 100644
index 000000000..7f8f011eb
--- /dev/null
+++ b/debian/_base/applications/internet/smb4k/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/_base/applications/internet/smb4k/debian/control b/debian/_base/applications/internet/smb4k/debian/control
new file mode 100644
index 000000000..628025dc7
--- /dev/null
+++ b/debian/_base/applications/internet/smb4k/debian/control
@@ -0,0 +1,17 @@
+Source: smb4k-trinity
+Section: kde
+Priority: optional
+Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
+Build-Depends: kdebase-trinity-dev, kdelibs4-trinity-dev, libart-2.0-dev, libpng-dev, zlib1g-dev, debhelper (>= 7.0.50~), quilt, cdbs, libx11-dev, libxext-dev, libxpm-dev, x-dev | x11proto-core-dev | libx11-dev, automake, autoconf, libtool, libltdl-dev
+Standards-Version: 3.8.4
+Homepage: http://smb4k.berlios.de/
+
+Package: smb4k-trinity
+Architecture: any
+Depends: ${shlibs:Depends}, samba-common, smbclient, smbfs
+Recommends: super | sudo-trinity
+Description: A Samba (SMB) share advanced browser for Trinity
+ Smb4K is a SMB (Windows) share browser for KDE. It uses the Samba software
+ suite to access the SMB shares of the local network neighborhood. Its purpose
+ is to provide a program that's easy to use and has as many features as
+ possible.
diff --git a/debian/_base/applications/internet/smb4k/debian/copyright b/debian/_base/applications/internet/smb4k/debian/copyright
new file mode 100644
index 000000000..d32c049ef
--- /dev/null
+++ b/debian/_base/applications/internet/smb4k/debian/copyright
@@ -0,0 +1,29 @@
+This package was debianized by Alexander Reinholdt <dustpuppy@mail.berlios.de>
+on Sun, 2 May 2004 19:16:57 +0200.
+Keep up to date by Francesco Paolo Lovergine <frankie@debian.org>
+
+It was downloaded from http://smb4k.berlios.de/download.html
+
+Upstream Authors: Alexander Reinholdt <dustpuppy@users.berlios.de>
+ Massimo Callegari <massimocallegari@yahoo.it>
+ Franck Babin <babinfranck@yahoo.ca>
+
+Copyright:
+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; version 2 dated June, 1991.
+
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this package; if not, write to the Free Software
+ Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
+ 02111-1307, USA.
+
+On Debian systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL'.
+
diff --git a/debian/_base/applications/internet/smb4k/debian/docs b/debian/_base/applications/internet/smb4k/debian/docs
new file mode 100644
index 000000000..e4acf0127
--- /dev/null
+++ b/debian/_base/applications/internet/smb4k/debian/docs
@@ -0,0 +1,3 @@
+README
+AUTHORS
+BUGS
diff --git a/debian/_base/applications/internet/smb4k/debian/menu b/debian/_base/applications/internet/smb4k/debian/menu
new file mode 100644
index 000000000..7f7c9cb2a
--- /dev/null
+++ b/debian/_base/applications/internet/smb4k/debian/menu
@@ -0,0 +1,8 @@
+?package(smb4k):\
+ needs="X11"\
+ section="Applications/Network"\
+ hints="KDE"\
+ kderemove="1"\
+ title="SAMBA for KDE"\
+ longtitle="SAMBA Advanced Browser"\
+ command="/opt/trinity/bin/smb4k"
diff --git a/debian/_base/applications/internet/smb4k/debian/rules b/debian/_base/applications/internet/smb4k/debian/rules
new file mode 100755
index 000000000..c8022b5a5
--- /dev/null
+++ b/debian/_base/applications/internet/smb4k/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+#
+# Uhm, too much complicated eh?
+#
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
diff --git a/debian/_base/applications/internet/smb4k/debian/source/format b/debian/_base/applications/internet/smb4k/debian/source/format
new file mode 100644
index 000000000..163aaf8d8
--- /dev/null
+++ b/debian/_base/applications/internet/smb4k/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/_base/applications/internet/smb4k/debian/source/options b/debian/_base/applications/internet/smb4k/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/debian/_base/applications/internet/smb4k/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*
diff --git a/debian/_base/applications/internet/smb4k/debian/watch b/debian/_base/applications/internet/smb4k/debian/watch
new file mode 100644
index 000000000..70154d877
--- /dev/null
+++ b/debian/_base/applications/internet/smb4k/debian/watch
@@ -0,0 +1,6 @@
+version=3
+opts=downloadurlmangle=s/prdownload/download/ \
+ http://developer.berlios.de/project/showfiles.php?group_id=769 \
+ http://prdownload.berlios.de/smb4k/smb4k-([\d\.]+)\.tar\.bz2
+
+