summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/kompose
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/kompose')
-rw-r--r--debian/_base/applications/kompose/debian/cdbs/debian-tde.mk237
-rw-r--r--debian/_base/applications/kompose/debian/cdbs/versions.pl19
-rw-r--r--debian/_base/applications/kompose/debian/changelog139
-rw-r--r--debian/_base/applications/kompose/debian/compat1
-rw-r--r--debian/_base/applications/kompose/debian/control18
-rw-r--r--debian/_base/applications/kompose/debian/copyright35
-rw-r--r--debian/_base/applications/kompose/debian/docs2
-rw-r--r--debian/_base/applications/kompose/debian/kompose-trinity.menu5
-rw-r--r--debian/_base/applications/kompose/debian/patches/series0
-rwxr-xr-xdebian/_base/applications/kompose/debian/rules17
-rw-r--r--debian/_base/applications/kompose/debian/source/format1
-rw-r--r--debian/_base/applications/kompose/debian/source/options6
12 files changed, 0 insertions, 480 deletions
diff --git a/debian/_base/applications/kompose/debian/cdbs/debian-tde.mk b/debian/_base/applications/kompose/debian/cdbs/debian-tde.mk
deleted file mode 100644
index 5b4e8bfd7..000000000
--- a/debian/_base/applications/kompose/debian/cdbs/debian-tde.mk
+++ /dev/null
@@ -1,237 +0,0 @@
-# -*- mode: makefile; coding: utf-8 -*-
-# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
-# Copyright © 2019 TDE Team
-# Description: A class for TDE packages; sets TDE environment variables, etc
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2, or (at
-# your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
-# 02111-1307 USA.
-
-ifndef _cdbs_bootstrap
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-endif
-
-ifndef _cdbs_class_debian-qt-kde
-_cdbs_class_debian-qt-kde := 1
-
-# for dh_icons
-CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
-
-# Note: This _must_ be included before autotools.mk, or it won't work.
-common-configure-arch common-configure-indep:: debian/stamp-cvs-make
-debian/stamp-cvs-make:
-ifndef _cdbs_class_cmake
- cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
-endif
- touch debian/stamp-cvs-make
-
-include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
-
-ifdef _cdbs_tarball_dir
-DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
-else
-DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
-endif
-
-ifndef _cdbs_class_cmake
-include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
-endif
-
-ifndef _cdbs_rules_patchsys_quilt
-DEB_PATCHDIRS := debian/patches/common debian/patches
-endif
-
-export kde_cgidir = \$${libdir}/cgi-bin
-export kde_confdir = \$${sysconfdir}/trinity
-export kde_htmldir = \$${datadir}/doc/tde/HTML
-
-DEB_KDE_ENABLE_FINAL := yes
-DEB_INSTALL_DOCS_ALL :=
-
-DEB_DH_MAKESHLIBS_ARGS_ALL := -V
-DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
-
-DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
-DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
-DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
-
-# The default gzip compressor has been changed in dpkg >= 1.17.0.
-deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
- sed -e "s|.*version ||" -e "s| .*||" | \
- xargs -r dpkg --compare-versions 1.17.0 lt \
- && echo xz || echo gzip)
-ifeq ($(deb_default_compress),gzip)
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-endif
-
-ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
- ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
- cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
- else
- cdbs_kde_enable_final =
- endif
-endif
-
-ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_final =
- cdbs_kde_enable_debug = --enable-debug=yes
-else
- cdbs_kde_enable_debug = --disable-debug
-endif
-
-ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_debug = --enable-debug=full
-endif
-
-DEB_BUILD_PARALLEL ?= true
-
-cdbs_configure_flags += \
- --with-qt-dir=/usr/share/qt3 \
- --disable-rpath \
- --with-xinerama \
- $(cdbs_kde_enable_final) \
- $(cdbs_kde_enable_debug)
-
-
-# This is a convenience target for calling manually.
-# It's not part of the build process.
-buildprep: clean apply-patches
-ifndef _cdbs_class_cmake
- $(MAKE) -f admin/Makefile.common dist
-endif
- debian/rules clean
-
-.tdepkginfo:
- echo "# TDE package information" >.tdepkginfo
- dpkg-parsechangelog | sed -n "s|^Source: |Name: |p" >>.tdepkginfo
- dpkg-parsechangelog | sed -n "s|^Version: |Version: |p" >>.tdepkginfo
- date +"DateTime: %m/%d/%Y %H:%M" -u -d "$$(dpkg-parsechangelog | sed -n 's|^Date: ||p')" >>.tdepkginfo
-
-post-patches:: .tdepkginfo
-
-common-build-arch:: debian/stamp-man-pages
-debian/stamp-man-pages:
- if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
- for f in $$(find debian/man -name '*.sgml'); do \
- docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
- done
- for f in $$(find debian/man -name '*.man'); do \
- soelim -I debian/man $$f \
- > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
- done
- touch debian/stamp-man-pages
-
-common-binary-indep::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_INDEP_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
-
-common-binary-arch::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_ARCH_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
- # update multi-arch path in install files
- ls -d debian/* | \
- grep -E "(install|links)$$" | \
- while read a; do \
- [ -d $$a ] || [ -f $$a.arch ] || \
- ! grep -q "\$$(DEB_HOST_MULTIARCH)" $$a || \
- sed -i.arch "s|\$$(DEB_HOST_MULTIARCH)|$(DEB_HOST_MULTIARCH)|g" $$a; \
- done
-
-clean::
- rm -rf debian/man/out
- -rmdir debian/man
- rm -f debian/stamp-man-pages
- rm -rf debian/shlibs-check
- # revert multi-arch path in install files
- ls -d debian/* | \
- grep -E "(install|links)$$" | \
- while read a; do \
- [ ! -f $$a.arch ] || \
- mv $$a.arch $$a; \
- done
-
-$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
- if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
- if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
- if test -e debian/$(cdbs_curpkg).lintian; then \
- install -p -D -m644 debian/$(cdbs_curpkg).lintian \
- debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
- fi
- if test -e debian/$(cdbs_curpkg).presubj; then \
- install -p -D -m644 debian/$(cdbs_curpkg).presubj \
- debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
- fi
-
-binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
- set -e; \
- for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
- pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
- echo Building $$pkg HTML docs...; \
- mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
- done
- for pkg in $(DOC_HTML_PRUNE) ; do \
- rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- done
-
-common-build-indep:: debian/stamp-kde-apidox
-debian/stamp-kde-apidox:
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
- touch $@
-
-common-install-indep:: common-install-kde-apidox
-common-install-kde-apidox::
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
-
-cleanbuilddir::
- -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
-
-clean::
-ifndef _cdbs_class_cmake
- if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
- cd $(DEB_SRCDIR); \
- find . -name Makefile.in -print | \
- xargs --no-run-if-empty rm -f; \
- rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
- configure configure.files configure.in stamp-h.in \
- subdirs; \
- fi
-endif
- rm -f .tdepkginfo
- rm -f debian/stamp-kde-apidox
- rm -f debian/stamp-cvs-make
-
-endif
diff --git a/debian/_base/applications/kompose/debian/cdbs/versions.pl b/debian/_base/applications/kompose/debian/cdbs/versions.pl
deleted file mode 100644
index 1b110f7af..000000000
--- a/debian/_base/applications/kompose/debian/cdbs/versions.pl
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/usr/bin/env perl
-
-use strict;
-use warnings;
-
-my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
-my ($version3, $version3_next);
-my ($version2, $version2_next);
-
-($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
-($version2 = $version3) =~ s/\.[^.]+$//;
-
-($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
-($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
-
-print "TDE-Version3=$version3\n";
-print "TDE-Version2=$version2\n";
-print "TDE-Next-Version3=$version3_next\n";
-print "TDE-Next-Version2=$version2_next\n";
diff --git a/debian/_base/applications/kompose/debian/changelog b/debian/_base/applications/kompose/debian/changelog
deleted file mode 100644
index f0d588126..000000000
--- a/debian/_base/applications/kompose/debian/changelog
+++ /dev/null
@@ -1,139 +0,0 @@
-kompose-trinity (0.5.4-3) testing; urgency=low
-
- * Initial release for TDE
-
- -- Michele Calgaro <michele.calgaro@yahoo.it> Sun, 06 Apr 2021 11:12:07 +0900
-
-kompose (0.5.4-3) unstable; urgency=low
-
- * Relocate patches to not use -p0. (Closes: #484954)
-
- -- Ana Beatriz Guerrero Lopez <ana@debian.org> Mon, 23 Jun 2008 13:16:59 +0200
-
-kompose (0.5.4-2) unstable; urgency=low
-
- * Update to Standards-Version 3.7.3, no changes required.
- * Bump to debhelper 6.
- * Move Homepage into source field.
- * Fix clean target in debian/rules.
- * Patch desktop file:
- - Add categories to the desktop file. (Closes: #448828)
- - Remove deprecated TerminalOptions entry.
- * Replace (c) by © in the copyright file to make lintian happy.
-
- -- Ana Beatriz Guerrero Lopez <ana@debian.org> Sun, 10 Feb 2008 03:25:20 +0100
-
-kompose (0.5.4-1) unstable; urgency=low
-
- * New maintainers. (Closes: #393035)
- * New upstream release. (Closes: #390087)
- * Acknowledge NMU. (Closes: #342994)
-
- [ Ana Beatriz Guerrero Lopez ]
- * Bumped compat to 5.
- * Bumped Build-Depends to 3.7.2, no changes required.
- * Added Homepage to description.
- * Moved .desktop file to the right place.
- * Added quilt to manage patches.
- * Added patch to fix kompose version number.
- * Improved debian/copyright file.
-
- [ Sune Vuorela ]
- * Added a patch from gentoo bugtracker to make it build
- (10_fix-komposetaskprefswidget.cpp.diff)
- * Added 01_autoconf-2.6.diff to be able to create 98_buildprep.diff
- * While I am at buildprep, take the 'common' patches from kde packaging
- * Improved debian/copyright file.
- * Added 02_no-libxfixes-configure-in-in.diff to not link against non-needed
- libxfixes.
- * Added 03_fix-ld-flags.diff to not link against multiple non-needed
- libraries.
-
- -- Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org> Sat, 28 Oct 2006 02:29:39 +0200
-
-kompose (0.5.3-1.3) unstable; urgency=high
-
- * Non-maintainer upload.
- * Split xlibs-dev build-dep (Closes: #347079).
- * Remove explicit build-dep on g++-3.4 (Closes: #342994).
-
- -- Luk Claes <luk@debian.org> Wed, 11 Jan 2006 16:24:15 +0100
-
-kompose (0.5.3-1.2) unstable; urgency=low
-
- * Non-maintainer upload to complete the previous one.
- * Upstream's tarball has some botched timestamps in autotools files;
- introduce some touch-fu in debian/rules to allow compilation without
- automake and autoconf.
-
- -- Adeodato Simó <dato@net.com.org.es> Sat, 10 Dec 2005 16:58:47 +0100
-
-kompose (0.5.3-1.1) unstable; urgency=low
-
- * Non-maintainer upload.
- * Upload to get rebuilt against kdelibs4c2a after failed binNMU.
- * Do not build-depend on removed automake1.6, since it is not needed (not
- called from debian/rules, no Makefile.am touched from diff.gz); instead,
- build-depend on autotools-dev for the update of config.{sub,guess}
- snippet. (Closes: #335126)
-
- -- Adeodato Simó <dato@net.com.org.es> Fri, 09 Dec 2005 03:42:22 +0100
-
-kompose (0.5.3-1) unstable; urgency=low
-
- * New upstream release. (Closes: #299654)
-
- -- Luis Mayoral <mayoral@linuxadicto.org> Sat, 8 Oct 2005 21:58:46 +0200
-
-kompose (0.5.1-2.2) unstable; urgency=low
-
- * Non-maintainer upload.
- * Build-dep on g++-3.4 on arm, hppa and m68k (Closes: #330938)
-
- -- Luk Claes <luk@debian.org> Sat, 1 Oct 2005 19:53:58 +0200
-
-kompose (0.5.1-2.1) unstable; urgency=medium
-
- * Non-maintainer upload.
- * Trigger rebuild for the Qt/KDE transition, no source changes needed.
- (Closes: #327970)
-
- -- Adeodato Simó <asp16@alu.ua.es> Tue, 27 Sep 2005 16:07:53 +0200
-
-kompose (0.5.1-2) unstable; urgency=low
-
- * Added xlibs-dev to Build-Depends.
-
- -- Luis Mayoral <mayoral@linuxadicto.org> Fri, 11 Feb 2005 13:12:15 +0100
-
-kompose (0.5.1-1) unstable; urgency=low
-
- * New upstream release.
-
- -- Luis Mayoral <mayoral@linuxadicto.org> Wed, 9 Feb 2005 13:01:28 +0100
-
-kompose (0.5-2) unstable; urgency=low
-
- * Fixed Build-Depends in debian/control (closes: Bug#287104).
-
- -- Luis Mayoral <mayoral@linuxadicto.org> Fri, 24 Dec 2004 19:47:34 +0100
-
-kompose (0.5-1) unstable; urgency=low
-
- * New upstream release.
-
- -- Luis Mayoral <mayoral@linuxadicto.org> Tue, 19 Oct 2004 10:44:38 +0200
-
-kompose (0.4.2-1) unstable; urgency=low
-
- * New upstream release.
-
- -- Luis Mayoral <mayoral@linuxadicto.org> Sun, 5 Sep 2004 14:15:04 +0200
-
-kompose (0.4.1-1) unstable; urgency=low
-
- * Initial Release (closes: Bug#267579).
- * Modified src/Makefile.in in order to fix a bug in imlib2-config.
-
- -- Luis Mayoral <mayoral@linuxadicto.org> Mon, 23 Aug 2004 19:56:57 +0200
-
diff --git a/debian/_base/applications/kompose/debian/compat b/debian/_base/applications/kompose/debian/compat
deleted file mode 100644
index ec635144f..000000000
--- a/debian/_base/applications/kompose/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-9
diff --git a/debian/_base/applications/kompose/debian/control b/debian/_base/applications/kompose/debian/control
deleted file mode 100644
index f7d5561d9..000000000
--- a/debian/_base/applications/kompose/debian/control
+++ /dev/null
@@ -1,18 +0,0 @@
-Source: kompose-trinity
-Section: admin
-Priority: optional
-Maintainer: TDE Debian Team <team-debian@trinitydesktop.org>
-XSBC-Original-Maintainer: Ana Beatriz Guerrero Lopez <ana@debian.org>, Sune Vuorela <debian@pusling.com>
-Build-Depends: cdbs, debhelper (>= 9~), quilt, cmake, tdelibs14-trinity-dev, libimlib2-dev, libx11-dev, libxdamage-dev, libxcomposite-dev
-Standards-Version: 3.8.4
-
-Package: kompose-trinity
-Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}
-Replaces: kompose-trinity (<< 4:14.0.0~)
-Breaks: kompose-trinity (<< 4:14.0.0~)
-Description: full screen task manager for TDE
- Kompose offers a great new way to manage a big number of windows on
- different Virtual Desktops. It creates a fullscreen view where every
- window is represented by a scaled screenshot of its own.
-
diff --git a/debian/_base/applications/kompose/debian/copyright b/debian/_base/applications/kompose/debian/copyright
deleted file mode 100644
index 442aca6c0..000000000
--- a/debian/_base/applications/kompose/debian/copyright
+++ /dev/null
@@ -1,35 +0,0 @@
-This package was debianized by Luis Mayoral <mayoral@linuxadicto.org> on
-Mon, 23 Aug 2004 19:56:57 +0200.
-Maintenance was taken over by Debian KDE Extras Team
-<pkg-kde-extras@lists.alioth.debian.org> on Fri, 27 Oct 2006 17:55:21 +0200
-
-It was downloaded from http://kompose.berlios.de
-
-Upstream Author: Hans Oischinger <oisch@waidlafragger.de>
-
-Copyright:
- © 2004-2006, Hans Oischinger <oisch@waidlafragger.de>
-
-License terms:
-
- This package is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 2 of the License, or
- (at your option) any later version.
-
- This package is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this package; if not, write to the Free Software
- Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
-
-This program is released under the Gnu Public License version 2.
-Fhe full text of the GNU General Public License version 2 is available on
-Debian systems in /usr/share/common-licenses/GPL-2.
-
-The Debian packaging is under the same license as the program.
- (C) 2004-2005 Luis Mayoral <mayoral@linuxadicto.org>
- (C) 2006 Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>
diff --git a/debian/_base/applications/kompose/debian/docs b/debian/_base/applications/kompose/debian/docs
deleted file mode 100644
index 6f12db508..000000000
--- a/debian/_base/applications/kompose/debian/docs
+++ /dev/null
@@ -1,2 +0,0 @@
-AUTHORS
-README
diff --git a/debian/_base/applications/kompose/debian/kompose-trinity.menu b/debian/_base/applications/kompose/debian/kompose-trinity.menu
deleted file mode 100644
index 089419f7b..000000000
--- a/debian/_base/applications/kompose/debian/kompose-trinity.menu
+++ /dev/null
@@ -1,5 +0,0 @@
-?package(kompose-trinity):needs="X11"\
- section="Apps/System"\
- hints="TDE,kompose"\
- title="kompose"\
- command="/opt/trinity/bin/kompose"
diff --git a/debian/_base/applications/kompose/debian/patches/series b/debian/_base/applications/kompose/debian/patches/series
deleted file mode 100644
index e69de29bb..000000000
--- a/debian/_base/applications/kompose/debian/patches/series
+++ /dev/null
diff --git a/debian/_base/applications/kompose/debian/rules b/debian/_base/applications/kompose/debian/rules
deleted file mode 100755
index 5a0da42af..000000000
--- a/debian/_base/applications/kompose/debian/rules
+++ /dev/null
@@ -1,17 +0,0 @@
-#!/usr/bin/make -f
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/cmake.mk
-include debian/cdbs/debian-tde.mk
-
-DEB_CMAKE_EXTRA_FLAGS := \
- -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
- -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
- -DCONFIG_INSTALL_DIR="/etc/trinity" \
- -DSYSCONF_INSTALL_DIR="/etc" \
- -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_VERBOSE_MAKEFILE="ON" \
- -DCMAKE_SKIP_RPATH="OFF" \
- -DBUILD_ALL="ON" \
- -DWITH_ALL_OPTIONS="ON"
diff --git a/debian/_base/applications/kompose/debian/source/format b/debian/_base/applications/kompose/debian/source/format
deleted file mode 100644
index 163aaf8d8..000000000
--- a/debian/_base/applications/kompose/debian/source/format
+++ /dev/null
@@ -1 +0,0 @@
-3.0 (quilt)
diff --git a/debian/_base/applications/kompose/debian/source/options b/debian/_base/applications/kompose/debian/source/options
deleted file mode 100644
index 72f1f5450..000000000
--- a/debian/_base/applications/kompose/debian/source/options
+++ /dev/null
@@ -1,6 +0,0 @@
-# Use xz instead of gzip
-compression = "xz"
-compression-level = 9
-
-# Don't run differences
-diff-ignore = .*