summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/kpilot/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/kpilot/debian/rules')
-rwxr-xr-xdebian/_base/applications/kpilot/debian/rules17
1 files changed, 1 insertions, 16 deletions
diff --git a/debian/_base/applications/kpilot/debian/rules b/debian/_base/applications/kpilot/debian/rules
index 3c342bcfc..7a6c3e8e4 100755
--- a/debian/_base/applications/kpilot/debian/rules
+++ b/debian/_base/applications/kpilot/debian/rules
@@ -1,7 +1,7 @@
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
-include debian/cdbs/kde.mk
+include debian/cdbs/debian-tde.mk
DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
@@ -11,18 +11,3 @@ DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/kde
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
-post-patches:: debian/stamp-bootstrap
-
-debian/stamp-bootstrap:
- ! [ -f /usr/share/libtool/ltmain.sh ] || \
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
- ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- make -f admin/Makefile.common cvs
- touch debian/stamp-bootstrap