summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/multimedia/k9copy/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/multimedia/k9copy/debian/rules')
-rwxr-xr-xdebian/_base/applications/multimedia/k9copy/debian/rules26
1 files changed, 26 insertions, 0 deletions
diff --git a/debian/_base/applications/multimedia/k9copy/debian/rules b/debian/_base/applications/multimedia/k9copy/debian/rules
new file mode 100755
index 000000000..e0b9d3f6f
--- /dev/null
+++ b/debian/_base/applications/multimedia/k9copy/debian/rules
@@ -0,0 +1,26 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_INSTALL_MANPAGES_k9copy = k9copy-trinity.1
+
+DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --includedir="/opt/trinity/include/kde" --mandir="/opt/trinity/share/man" --infodir="/opt/trinity/share/info"
+
+install/k9copy-trinity::
+ dh_installman k9copy.1
+ mv debian/$(cdbs_curpkg)/usr/share/man debian/$(cdbs_curpkg)/opt/trinity/share/
+ dh_link opt/trinity/share/doc/tde/HTML/en/k9copy usr/share/doc/$(cdbs_curpkg)/html
+
+build/k9copy-trinity::
+ docbook2x-man debian/k9copy.1.docbook
+
+clean::
+ rm -f k9copy.1