summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/office/kbibtex/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/office/kbibtex/debian')
-rw-r--r--debian/_base/applications/office/kbibtex/debian/cdbs/debian-tde.mk246
-rw-r--r--debian/_base/applications/office/kbibtex/debian/cdbs/versions.pl19
-rw-r--r--debian/_base/applications/office/kbibtex/debian/changelog154
-rw-r--r--debian/_base/applications/office/kbibtex/debian/compat1
-rw-r--r--debian/_base/applications/office/kbibtex/debian/control29
-rw-r--r--debian/_base/applications/office/kbibtex/debian/copyright27
-rw-r--r--debian/_base/applications/office/kbibtex/debian/docs2
-rw-r--r--debian/_base/applications/office/kbibtex/debian/menu2
-rwxr-xr-xdebian/_base/applications/office/kbibtex/debian/rules10
-rw-r--r--debian/_base/applications/office/kbibtex/debian/source/format1
-rw-r--r--debian/_base/applications/office/kbibtex/debian/source/options6
-rw-r--r--debian/_base/applications/office/kbibtex/debian/watch3
12 files changed, 500 insertions, 0 deletions
diff --git a/debian/_base/applications/office/kbibtex/debian/cdbs/debian-tde.mk b/debian/_base/applications/office/kbibtex/debian/cdbs/debian-tde.mk
new file mode 100644
index 000000000..f36e3527c
--- /dev/null
+++ b/debian/_base/applications/office/kbibtex/debian/cdbs/debian-tde.mk
@@ -0,0 +1,246 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Copyright © 2019 TDE Team
+# Description: A class for TDE packages; sets TDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+endif
+ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
+endif
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
+ touch debian/stamp-cvs-make
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+ifndef _cdbs_class_cmake
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+endif
+
+ifdef _cdbs_class_cmake
+ifneq "$(wildcard /usr/bin/ninja)" ""
+MAKE = ninja -v
+DEB_MAKE_ENVVARS += DESTDIR=$(DEB_DESTDIR)
+DEB_MAKE_INSTALL_TARGET = install
+DEB_CMAKE_NORMAL_ARGS += -GNinja
+endif
+endif
+
+ifndef _cdbs_rules_patchsys_quilt
+DEB_PATCHDIRS := debian/patches/common debian/patches
+endif
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/tde/HTML
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
+DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+DEB_BUILD_PARALLEL ?= true
+
+cdbs_configure_flags += \
+ --with-qt-dir=/usr/share/qt3 \
+ --disable-rpath \
+ --with-xinerama \
+ $(cdbs_kde_enable_final) \
+ $(cdbs_kde_enable_debug)
+
+
+# This is a convenience target for calling manually.
+# It's not part of the build process.
+buildprep: clean apply-patches
+ifndef _cdbs_class_cmake
+ $(MAKE) -f admin/Makefile.common dist
+endif
+ debian/rules clean
+
+.tdepkginfo:
+ echo "# TDE package information" >.tdepkginfo
+ dpkg-parsechangelog | sed -n "s|^Source: |Name: |p" >>.tdepkginfo
+ dpkg-parsechangelog | sed -n "s|^Version: |Version: |p" >>.tdepkginfo
+ date +"DateTime: %m/%d/%Y %H:%M" -u -d "$$(dpkg-parsechangelog | sed -n 's|^Date: ||p')" >>.tdepkginfo
+
+post-patches:: .tdepkginfo
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+ # update multi-arch path in install files
+ ls -d debian/* | \
+ grep -E "(install|links)$$" | \
+ while read a; do \
+ [ -d $$a ] || [ -f $$a.arch ] || \
+ ! grep -q "\$$(DEB_HOST_MULTIARCH)" $$a || \
+ sed -i.arch "s|\$$(DEB_HOST_MULTIARCH)|$(DEB_HOST_MULTIARCH)|g" $$a; \
+ done
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+ # revert multi-arch path in install files
+ ls -d debian/* | \
+ grep -E "(install|links)$$" | \
+ while read a; do \
+ [ ! -f $$a.arch ] || \
+ mv $$a.arch $$a; \
+ done
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ done
+
+common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+DESTDIR=$(DEB_DESTDIR) $(DEB_MAKE_INVOKE) install-apidox)
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+clean::
+ifndef _cdbs_class_cmake
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+endif
+ rm -f .tdepkginfo
+ rm -f debian/stamp-kde-apidox
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/debian/_base/applications/office/kbibtex/debian/cdbs/versions.pl b/debian/_base/applications/office/kbibtex/debian/cdbs/versions.pl
new file mode 100644
index 000000000..75c9add4b
--- /dev/null
+++ b/debian/_base/applications/office/kbibtex/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "KDE-Version3=$version3\n";
+print "KDE-Version2=$version2\n";
+print "KDE-Next-Version3=$version3_next\n";
+print "KDE-Next-Version2=$version2_next\n";
diff --git a/debian/_base/applications/office/kbibtex/debian/changelog b/debian/_base/applications/office/kbibtex/debian/changelog
new file mode 100644
index 000000000..c06f2a183
--- /dev/null
+++ b/debian/_base/applications/office/kbibtex/debian/changelog
@@ -0,0 +1,154 @@
+kbibtex-trinity (0.2.3.91-1) squeeze; urgency=low
+
+ * Initial Release for TDE
+
+ -- Slávek Banko <slavek.banko@axis.cz> Sat, 29 Jun 2013 02:28:40 +0200
+
+kbibtex (0.2.3.90-1) unstable; urgency=low
+
+ * New upstream release (Closes: #563684).
+ * Switch to source package version 3.0 (quilt).
+ * Bumped Standards-Version to 3.9.0, no changes necessary.
+ * Link against libyaz to enable Z39.50 support (Closes: #550547).
+
+ -- Michael Hanke <michael.hanke@gmail.com> Wed, 21 Jul 2010 12:02:48 -0400
+
+kbibtex (0.2.3-1) unstable; urgency=low
+
+ * New upstream version. New Google Scholar search engine.
+ * Bumped Standards-Version to 3.8.3.0 No changes necessary.
+
+ -- Michael Hanke <michael.hanke@gmail.com> Sun, 23 Aug 2009 19:18:34 -0400
+
+kbibtex (0.2.2-1) unstable; urgency=low
+
+ * New upstream version (Closes: #487301, #507837, #518959, #520392).
+ * Bumped Standards-Version to 3.8.1. No changes necessary.
+ * Added 'DM-Upload-Allowed: yes'.
+ * Added missing '${misc:Depends}'.
+ * Support for per-file encoding settings (Closes: #514356)
+ * Upgrade debhelper compatibility to version 5.
+ * Update debian/copyright for 2009 release.
+
+ -- Michael Hanke <michael.hanke@gmail.com> Mon, 15 Jun 2009 12:41:19 +0200
+
+kbibtex (0.2.1-1) unstable; urgency=low
+
+ * New Upstream Version.
+ * Bumped Standards-version to 3.7.3 (no changes necessary).
+
+ -- Michael Hanke <michael.hanke@gmail.com> Mon, 17 Mar 2008 21:58:16 +0100
+
+kbibtex (0.2-2) unstable; urgency=low
+
+ * Link binary with --as-needed to dramatically reduce the number of package
+ dependencies.
+
+ -- Michael Hanke <michael.hanke@gmail.com> Tue, 27 Nov 2007 09:48:11 +0100
+
+kbibtex (0.2-1) unstable; urgency=low
+
+ * New Upstream Version
+ * Moved homepage link to new Homepage filed in debian/control.
+ * Added VCS information to debian/control.
+ * KBibTeX now notices when a file was modified outside and asks whether
+ it should reload that file (Closes: #427983).
+
+ -- Michael Hanke <michael.hanke@gmail.com> Sun, 28 Oct 2007 10:21:01 +0100
+
+kbibtex (0.1.5.55-1) unstable; urgency=low
+
+ * New upstream release. Merged patches with upstream.
+ * Packaging is now maintained in a GIT repository. Removing obsolete dpatch
+ build-dependency.
+ * Merge functionality was added (Closes: #434746).
+ * Support for exporting to Reference Manager RIS format was added.
+ * Updated menu file for the new menu policy.
+
+ -- Michael Hanke <michael.hanke@gmail.com> Fri, 21 Sep 2007 14:16:18 +0200
+
+kbibtex (0.1.5-5) unstable; urgency=low
+
+ * Added latex2rtf as suggested package, because it is required for export
+ into the RTF format.
+ * Improved package description. Thanks to Yaroslav Halchenko for pointing
+ to this issue.
+ * Added patch to fix broken XSLT export.
+
+ -- Michael Hanke <michael.hanke@gmail.com> Sat, 17 Mar 2007 08:35:37 +0100
+
+kbibtex (0.1.5-4) unstable; urgency=low
+
+ * Modified package dependencies to be compatible with texlive.
+ * Switch from tetex-bin suggestion to tetex-extra to have url.sty available
+ for exporting via latex.
+ * Added recommendation of texlive-bibtex-extra for additional citation
+ styles.
+ * Added patches to fix empty search results when doing multiple pubmed
+ queries and a bug when storing search URLs. Thanks Thomas Fischer.
+
+ -- Michael Hanke <michael.hanke@gmail.com> Fri, 2 Mar 2007 20:11:34 +0100
+
+kbibtex (0.1.5-3) unstable; urgency=low
+
+ * Included upstream patch that fixes the display of accented characters
+ (Closes: #400065).
+
+ -- Michael Hanke <michael.hanke@gmail.com> Sat, 25 Nov 2006 19:11:01 +0100
+
+kbibtex (0.1.5-2) unstable; urgency=low
+
+ * Fix FTBFS due to an invalid pure specifier. Thanks to Matthias Klose and
+ Martin Michlmayr. (Closes: #395378, #394143)
+
+ -- Michael Hanke <michael.hanke@gmail.com> Thu, 26 Oct 2006 21:50:18 +0200
+
+kbibtex (0.1.5-1) unstable; urgency=low
+
+ * New upstream release.
+
+ -- Michael Hanke <michael.hanke@gmail.com> Sat, 7 Oct 2006 08:37:00 +0200
+
+kbibtex (0.1.4.85-1) unstable; urgency=low
+
+ * New upstream release-candidate.
+
+ -- Michael Hanke <michael.hanke@gmail.com> Fri, 6 Oct 2006 07:09:06 +0200
+
+kbibtex (0.1.4.81-1) unstable; urgency=low
+
+ * New upstream release-candiate.
+
+ -- Michael Hanke <michael.hanke@gmail.com> Thu, 5 Oct 2006 10:15:59 +0200
+
+kbibtex (0.1.4.80-1) unstable; urgency=low
+
+ * New upstream release-candidate.
+
+ -- Michael Hanke <michael.hanke@gmail.com> Wed, 4 Oct 2006 09:36:33 +0200
+
+kbibtex (0.1.4-2) unstable; urgency=low
+
+ * Bumped Standards-Version to 3.7.2 (no changes necessary).
+ * Added missing debian/compat file to note debhelper v4 compatibility.
+
+ -- Michael Hanke <michael.hanke@gmail.com> Wed, 19 Jul 2006 12:10:55 +0200
+
+kbibtex (0.1.4-1) unstable; urgency=low
+
+ * New upstream release.
+
+ -- Michael Hanke <michael.hanke@gmail.com> Wed, 26 Apr 2006 15:59:31 +0200
+
+kbibtex (0.1.3.95-1) unstable; urgency=low
+
+ * New upstream release-candidate.
+
+ -- Michael Hanke <michael.hanke@gmail.com> Wed, 22 Feb 2006 21:06:12 +0100
+
+kbibtex (0.1.3-2) unstable; urgency=low
+
+ * Initial Release. (Closes: #328106)
+
+ -- Michael Hanke <michael.hanke@gmail.com> Sat, 17 Dec 2005 21:57:40 +0100
+
diff --git a/debian/_base/applications/office/kbibtex/debian/compat b/debian/_base/applications/office/kbibtex/debian/compat
new file mode 100644
index 000000000..7f8f011eb
--- /dev/null
+++ b/debian/_base/applications/office/kbibtex/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/_base/applications/office/kbibtex/debian/control b/debian/_base/applications/office/kbibtex/debian/control
new file mode 100644
index 000000000..a85448cb6
--- /dev/null
+++ b/debian/_base/applications/office/kbibtex/debian/control
@@ -0,0 +1,29 @@
+Source: kbibtex-trinity
+Section: kde
+Priority: optional
+Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
+Build-Depends: debhelper (>= 7.0.50~), quilt, autotools-dev, cdbs, automake, libtool, kdelibs4-trinity-dev (>= 3.3.2), libxslt1-dev, libyaz4-dev | libyaz-dev
+Standards-Version: 3.9.0
+Homepage: http://www.unix-ag.uni-kl.de/~fischer/kbibtex
+Vcs-Browser: http://git.debian.org/?p=pkg-exppsy/kbibtex.git
+Vcs-Git: git://git.debian.org/git/pkg-exppsy/kbibtex.git
+XS-DM-Upload-Allowed: yes
+
+
+Package: kbibtex-trinity
+Architecture: any
+Depends: ${misc:Depends}, ${shlibs:Depends}
+Suggests: texlive-latex-base | tetex-extra, bibtex2html, latex2rtf
+Recommends: texlive-bibtex-extra
+Description: BibTeX editor for TDE
+ An application to manage bibliography databases in the BibTeX format. KBibTeX
+ can be used as a standalone program, but can also be embedded into other TDE
+ applications (e.g. as bibliography editor into Kile).
+ .
+ KBibTeX can query online ressources (e.g. Google scholar) via customizable
+ search URLs. It is also able to import complete datasets from NCBI Pubmed.
+ It also supports tagging references with keywords and manages references to
+ local files.
+ .
+ BibTeX files can be exported into HTML, XML, PDF, PS and RTF format using a
+ number of citation styles.
diff --git a/debian/_base/applications/office/kbibtex/debian/copyright b/debian/_base/applications/office/kbibtex/debian/copyright
new file mode 100644
index 000000000..a3860eab7
--- /dev/null
+++ b/debian/_base/applications/office/kbibtex/debian/copyright
@@ -0,0 +1,27 @@
+This package was debianized by Michael Hanke <michael.hanke@gmail.com> on
+Thu, 8 Sep 2005 19:33:07 +0200.
+
+It was downloaded from http://www.unix-ag.uni-kl.de/~fischer/kbibtex/
+
+Copyright (C) 2004-2009 by Thomas Fischer <fischer@unix-ag.uni-kl.de>
+
+License:
+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this package; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA
+ 02110-1301 USA.
+
+On Debian systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL-2'.
+
diff --git a/debian/_base/applications/office/kbibtex/debian/docs b/debian/_base/applications/office/kbibtex/debian/docs
new file mode 100644
index 000000000..166765aba
--- /dev/null
+++ b/debian/_base/applications/office/kbibtex/debian/docs
@@ -0,0 +1,2 @@
+NEWS
+TODO
diff --git a/debian/_base/applications/office/kbibtex/debian/menu b/debian/_base/applications/office/kbibtex/debian/menu
new file mode 100644
index 000000000..63d91bc0c
--- /dev/null
+++ b/debian/_base/applications/office/kbibtex/debian/menu
@@ -0,0 +1,2 @@
+?package(kbibtex):needs="X11" section="Applications/Editors"\
+ title="KBiBTeX" command="/opt/trinity/bin/kbibtex"
diff --git a/debian/_base/applications/office/kbibtex/debian/rules b/debian/_base/applications/office/kbibtex/debian/rules
new file mode 100755
index 000000000..b3b256352
--- /dev/null
+++ b/debian/_base/applications/office/kbibtex/debian/rules
@@ -0,0 +1,10 @@
+#!/usr/bin/make -f
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+LDFLAGS += -Wl,--as-needed
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/debian-tde.mk
diff --git a/debian/_base/applications/office/kbibtex/debian/source/format b/debian/_base/applications/office/kbibtex/debian/source/format
new file mode 100644
index 000000000..163aaf8d8
--- /dev/null
+++ b/debian/_base/applications/office/kbibtex/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/_base/applications/office/kbibtex/debian/source/options b/debian/_base/applications/office/kbibtex/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/debian/_base/applications/office/kbibtex/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*
diff --git a/debian/_base/applications/office/kbibtex/debian/watch b/debian/_base/applications/office/kbibtex/debian/watch
new file mode 100644
index 000000000..a0b02fa2d
--- /dev/null
+++ b/debian/_base/applications/office/kbibtex/debian/watch
@@ -0,0 +1,3 @@
+version=3
+http://www.unix-ag.uni-kl.de/~fischer/kbibtex/download/kbibtex-([\d\.]+)\.tar\.bz2
+