summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/office/kile/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/office/kile/debian/rules')
-rwxr-xr-xdebian/_base/applications/office/kile/debian/rules73
1 files changed, 26 insertions, 47 deletions
diff --git a/debian/_base/applications/office/kile/debian/rules b/debian/_base/applications/office/kile/debian/rules
index bd5478578..59bca7cd4 100755
--- a/debian/_base/applications/office/kile/debian/rules
+++ b/debian/_base/applications/office/kile/debian/rules
@@ -1,60 +1,39 @@
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-tde.mk
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_CONFIGURE_SCRIPT_ENV += LDFLAGS="-Wl,--as-needed"
-DEB_DH_INSTALL_ARGS := --sourcedir=debian/tmp
-DEB_INSTALL_MANPAGES_kile := debian/kile.1
-DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/tde
-
-post-patches:: debian/stamp-bootstrap
-
-debian/stamp-bootstrap:
-ifneq "$(wildcard /usr/share/libtool/ltmain.sh)" ""
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -f /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- make -f admin/Makefile.common cvs
- touch debian/stamp-bootstrap
-
-install/kile-trinity-i18n-br::
- -for language in `cd translations; ls -1d */`; do \
- cd $(CURDIR)/$(DEB_BUILDDIR)/translations/$$language; \
- $(MAKE) install DESTDIR=$(CURDIR)/debian/kile-trinity-i18n-$$language; \
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"
+
+common-install-indep::
+ # Install translations into individual packages
+ -for language in `cd debian/tmp/opt/trinity/share/locale; ls -1d */`; do \
+ pkg_lang=$$(echo $$language | tr '[:upper:]' '[:lower:]' | sed -e s/@latn/latin/ -e s/[@_]//g); \
+ install -d $(CURDIR)/debian/kile-trinity-i18n-$$pkg_lang/opt/trinity/share/locale; \
+ cp -a $(CURDIR)/debian/tmp/opt/trinity/share/locale/$$language \
+ $(CURDIR)/debian/kile-trinity-i18n-$$pkg_lang/opt/trinity/share/locale/$$language; \
+ done
+ -for language in `cd debian/tmp/opt/trinity/share/doc/tde/HTML; ls -1d */ | grep -v '^en/'`; do \
+ pkg_lang=$$(echo $$language | tr '[:upper:]' '[:lower:]' | sed -e s/@latn/latin/ -e s/[@_]//g); \
+ install -d $(CURDIR)/debian/kile-trinity-i18n-$$pkg_lang/opt/trinity/share/doc/tde/HTML; \
+ cp -a $(CURDIR)/debian/tmp/opt/trinity/share/doc/tde/HTML/$$language \
+ $(CURDIR)/debian/kile-trinity-i18n-$$pkg_lang/opt/trinity/share/doc/tde/HTML/$$language; \
done
-
- cd $(CURDIR)/$(DEB_BUILDDIR)/translations/en_GB/; \
- $(MAKE) install DESTDIR=$(CURDIR)/debian/kile-trinity-i18n-engb
-
- cd $(CURDIR)/$(DEB_BUILDDIR)/translations/pt_BR/; \
- $(MAKE) install DESTDIR=$(CURDIR)/debian/kile-trinity-i18n-ptbr
-
- cd $(CURDIR)/$(DEB_BUILDDIR)/translations/sr@Latn/;\
- $(MAKE) install DESTDIR=$(CURDIR)/debian/kile-trinity-i18n-srlatin
-
- cd $(CURDIR)/$(DEB_BUILDDIR)/translations/zh_CN/; \
- $(MAKE) install DESTDIR=$(CURDIR)/debian/kile-trinity-i18n-zhcn
install/kile-trinity::
# Install pixmap
install -D -p -m0644 debian/kile.xpm debian/kile-trinity/opt/trinity/share/pixmaps/kile.xpm
- chmod +x debian/tmp/opt/trinity/share/apps/kile/test/runTests.sh
-
clean::
rm -rf debian/kile-trinity-i18n-*