summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/settings/kdesudo
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/settings/kdesudo')
-rw-r--r--debian/_base/applications/settings/kdesudo/debian/cdbs/debian-tde.mk246
-rw-r--r--debian/_base/applications/settings/kdesudo/debian/cdbs/versions.pl19
-rw-r--r--debian/_base/applications/settings/kdesudo/debian/changelog111
-rw-r--r--debian/_base/applications/settings/kdesudo/debian/compat1
-rw-r--r--debian/_base/applications/settings/kdesudo/debian/control13
-rw-r--r--debian/_base/applications/settings/kdesudo/debian/copyright57
-rw-r--r--debian/_base/applications/settings/kdesudo/debian/kdesudo-trinity.1.docbook168
-rw-r--r--debian/_base/applications/settings/kdesudo/debian/links1
-rw-r--r--debian/_base/applications/settings/kdesudo/debian/patches/series0
-rw-r--r--debian/_base/applications/settings/kdesudo/debian/postinst21
-rw-r--r--debian/_base/applications/settings/kdesudo/debian/postrm25
-rw-r--r--debian/_base/applications/settings/kdesudo/debian/preinst36
-rwxr-xr-xdebian/_base/applications/settings/kdesudo/debian/rules22
-rw-r--r--debian/_base/applications/settings/kdesudo/debian/source/format1
-rw-r--r--debian/_base/applications/settings/kdesudo/debian/source/options6
15 files changed, 727 insertions, 0 deletions
diff --git a/debian/_base/applications/settings/kdesudo/debian/cdbs/debian-tde.mk b/debian/_base/applications/settings/kdesudo/debian/cdbs/debian-tde.mk
new file mode 100644
index 000000000..f36e3527c
--- /dev/null
+++ b/debian/_base/applications/settings/kdesudo/debian/cdbs/debian-tde.mk
@@ -0,0 +1,246 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Copyright © 2019 TDE Team
+# Description: A class for TDE packages; sets TDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+endif
+ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
+endif
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
+ touch debian/stamp-cvs-make
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+ifndef _cdbs_class_cmake
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+endif
+
+ifdef _cdbs_class_cmake
+ifneq "$(wildcard /usr/bin/ninja)" ""
+MAKE = ninja -v
+DEB_MAKE_ENVVARS += DESTDIR=$(DEB_DESTDIR)
+DEB_MAKE_INSTALL_TARGET = install
+DEB_CMAKE_NORMAL_ARGS += -GNinja
+endif
+endif
+
+ifndef _cdbs_rules_patchsys_quilt
+DEB_PATCHDIRS := debian/patches/common debian/patches
+endif
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/tde/HTML
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
+DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+DEB_BUILD_PARALLEL ?= true
+
+cdbs_configure_flags += \
+ --with-qt-dir=/usr/share/qt3 \
+ --disable-rpath \
+ --with-xinerama \
+ $(cdbs_kde_enable_final) \
+ $(cdbs_kde_enable_debug)
+
+
+# This is a convenience target for calling manually.
+# It's not part of the build process.
+buildprep: clean apply-patches
+ifndef _cdbs_class_cmake
+ $(MAKE) -f admin/Makefile.common dist
+endif
+ debian/rules clean
+
+.tdepkginfo:
+ echo "# TDE package information" >.tdepkginfo
+ dpkg-parsechangelog | sed -n "s|^Source: |Name: |p" >>.tdepkginfo
+ dpkg-parsechangelog | sed -n "s|^Version: |Version: |p" >>.tdepkginfo
+ date +"DateTime: %m/%d/%Y %H:%M" -u -d "$$(dpkg-parsechangelog | sed -n 's|^Date: ||p')" >>.tdepkginfo
+
+post-patches:: .tdepkginfo
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+ # update multi-arch path in install files
+ ls -d debian/* | \
+ grep -E "(install|links)$$" | \
+ while read a; do \
+ [ -d $$a ] || [ -f $$a.arch ] || \
+ ! grep -q "\$$(DEB_HOST_MULTIARCH)" $$a || \
+ sed -i.arch "s|\$$(DEB_HOST_MULTIARCH)|$(DEB_HOST_MULTIARCH)|g" $$a; \
+ done
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+ # revert multi-arch path in install files
+ ls -d debian/* | \
+ grep -E "(install|links)$$" | \
+ while read a; do \
+ [ ! -f $$a.arch ] || \
+ mv $$a.arch $$a; \
+ done
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ done
+
+common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+DESTDIR=$(DEB_DESTDIR) $(DEB_MAKE_INVOKE) install-apidox)
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+clean::
+ifndef _cdbs_class_cmake
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+endif
+ rm -f .tdepkginfo
+ rm -f debian/stamp-kde-apidox
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/debian/_base/applications/settings/kdesudo/debian/cdbs/versions.pl b/debian/_base/applications/settings/kdesudo/debian/cdbs/versions.pl
new file mode 100644
index 000000000..75c9add4b
--- /dev/null
+++ b/debian/_base/applications/settings/kdesudo/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "KDE-Version3=$version3\n";
+print "KDE-Version2=$version2\n";
+print "KDE-Next-Version3=$version3_next\n";
+print "KDE-Next-Version2=$version2_next\n";
diff --git a/debian/_base/applications/settings/kdesudo/debian/changelog b/debian/_base/applications/settings/kdesudo/debian/changelog
new file mode 100644
index 000000000..d245ff2e7
--- /dev/null
+++ b/debian/_base/applications/settings/kdesudo/debian/changelog
@@ -0,0 +1,111 @@
+kdesudo-trinity (4:2.5.1-4ubuntu0) karmic; urgency=low
+
+ * Karmic rebuild
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 02 Jul 2009 16:08:00 -0600
+
+kdesudo-trinity (4:2.5.1-3ubuntu8) intrepid; urgency=low
+
+ * Moved Trinity to /opt/trinity
+ * Integrated properly with KDE4.2+
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Wed, 01 March 2009 23:25:00 -0600
+
+kdesudo-trinity (4:2.5.1-3ubuntu6) intrepid; urgency=low
+
+ * Added -trinity suffix
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Tue, 04 Nov 2008 08:49:00 -0600
+
+kdesudo (2.5.1-0ubuntu3) hardy; urgency=low
+
+ * Improved kubuntu_02_spaced_args.patch:
+ - Now deals with -c command option too
+ * Added kubutu_04_nice_password_prompt.patch:
+ - Fixed dialog when typing commands like "ls *"
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Mon, 21 Apr 2008 09:20:30 +0200
+
+kdesudo (2.5.1-0ubuntu2) hardy; urgency=low
+
+ * Added kubuntu_02_spaced_args.patch:
+ - Closes LP: #209831
+ * Added kubuntu_03_export_kdesycoca.patch:
+ - Closes LP: #175909
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Thu, 17 Apr 2008 23:47:16 +0200
+
+kdesudo (2.5.1-0ubuntu1) hardy; urgency=low
+
+ * New upstream release. Fixes issue building towards gcc 4.3.0
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Fri, 28 Mar 2008 15:27:57 +0100
+
+kdesudo (2.5-0ubuntu1) hardy; urgency=low
+
+ * New upstream release. Closes LP: #203690
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Tue, 18 Mar 2008 23:49:19 +0100
+
+kdesudo (2.4-0ubuntu1) hardy; urgency=low
+
+ * New upstream release. Closes LP: #187053
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Mon, 18 Feb 2008 13:43:57 +0100
+
+kdesudo (2.3-0ubuntu1) hardy; urgency=low
+
+ * New upstream release
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Sun, 17 Feb 2008 02:34:43 +0100
+
+kdesudo (2.2-0ubuntu1) hardy; urgency=low
+
+ * New upstream release
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Mon, 04 Feb 2008 20:07:55 +0100
+
+kdesudo (2.1-0ubuntu1) hardy; urgency=low
+
+ * New upstream release.
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Thu, 24 Jan 2008 13:44:16 +0100
+
+kdesudo (2.0-0ubuntu1) hardy; urgency=low
+
+ * New upstream release :
+ - Closes LP: #157043, #162823, #144970, #148255,#172749, #173319
+ * Fixed packaging to divert both binary and manpage.
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Tue, 04 Dec 2007 16:41:58 +0100
+
+kdesudo (1.4-0ubuntu1) hardy; urgency=low
+
+ * New upstream release
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Tue, 20 Nov 2007 12:46:56 +0100
+
+kdesudo (1.3-0ubuntu1) hardy; urgency=low
+
+ * New upstream release. Closes LP: #163417
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Mon, 19 Nov 2007 20:36:49 +0100
+
+kdesudo (1.2-0ubuntu2) hardy; urgency=low
+
+ * Reupload as the build farm should now be fixed
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Mon, 12 Nov 2007 12:22:07 +0100
+
+kdesudo (1.2-0ubuntu1) hardy; urgency=low
+
+ * New upstream release, fixes the user's $HOME usage
+ potential corrupting files issue
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Sat, 10 Nov 2007 12:58:57 +0100
+
+kdesudo (1.1-0ubuntu1) gutsy; urgency=low
+
+ * Initial release
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Fri, 01 Jun 2007 01:04:36 +0200
diff --git a/debian/_base/applications/settings/kdesudo/debian/compat b/debian/_base/applications/settings/kdesudo/debian/compat
new file mode 100644
index 000000000..7f8f011eb
--- /dev/null
+++ b/debian/_base/applications/settings/kdesudo/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/_base/applications/settings/kdesudo/debian/control b/debian/_base/applications/settings/kdesudo/debian/control
new file mode 100644
index 000000000..267ec5d4f
--- /dev/null
+++ b/debian/_base/applications/settings/kdesudo/debian/control
@@ -0,0 +1,13 @@
+Source: kdesudo-trinity
+Section: kde
+Priority: optional
+Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
+Build-Depends: debhelper (>= 7.0.50~), quilt, cdbs, kdelibs4-trinity-dev, docbook2x, automake, autoconf, libtool, libltdl-dev
+Standards-Version: 3.8.4
+
+Package: kdesudo-trinity
+Architecture: any
+Depends: ${shlibs:Depends}, sudo
+Description: sudo frontend for Trinity
+ KdeSudo is a graphical frontend for the sudo utility.
+ It allows you to run programs as another user by entering your password.
diff --git a/debian/_base/applications/settings/kdesudo/debian/copyright b/debian/_base/applications/settings/kdesudo/debian/copyright
new file mode 100644
index 000000000..9cd32407b
--- /dev/null
+++ b/debian/_base/applications/settings/kdesudo/debian/copyright
@@ -0,0 +1,57 @@
+This package was debianized by Anthony Mercatante <tonio@ubuntu.com>
+on Fri, 01 Jun 2007 01:07:10 +0200
+
+It was downloaded from
+ https://code.launchpad.net/kdesudo
+
+This version is a fork of the original kdesudo from
+ http://ksudo.sourceforge.net/kdesudo/
+
+Upstream authors:
+ Robert Gruber
+ Anthony Mercatante
+ Martin Böhm
+ Jonathan Riddell
+
+Copyright:
+ (C) 2003 Robert Gruber <rgruber@users.sourceforge.net>
+ (C) 2007 Anthony Mercatante <tonio@ubuntu.com>
+ (C) 2007 Martin Böhm <martin.bohm@kubuntu.org
+ (C) 2007 Canonical Ltd (Jonathan Riddell <jriddell@ubuntu.com>)
+
+License:
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the
+ Free Software Foundation, Inc.,
+ 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
+
+On Debian systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL'.
+
+---
+
+The documentation is licensed under the terms of the GNU Free
+Documentation License version 1.2 with no Invariant Sections, no
+Front-Cover Texts and no Back-Cover Texts.
+
+On Debian systems, the complete text of the GNU GNU Free Documentation
+License can be found in `/usr/share/common-licenses/GFDL'.
+
+---
+
+The packaging in debian/ is licensed under the terms of the GNU General
+Public License either version 2 of the License, or
+(at your option) any later version.
+
+On Debian systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL'.
diff --git a/debian/_base/applications/settings/kdesudo/debian/kdesudo-trinity.1.docbook b/debian/_base/applications/settings/kdesudo/debian/kdesudo-trinity.1.docbook
new file mode 100644
index 000000000..0e1ba2b60
--- /dev/null
+++ b/debian/_base/applications/settings/kdesudo/debian/kdesudo-trinity.1.docbook
@@ -0,0 +1,168 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
+"http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd" [
+]>
+<refentry>
+ <refentryinfo>
+ <author>
+ <firstname>Anthony</firstname>
+ <surname>Mercatante</surname>
+ <email>tonio@ubuntu.com</email>
+ </author>
+ <copyright>
+ <year>2007</year>
+ <holder>Anthony Mercatante</holder>
+ </copyright>
+ <!-- XXX IMPORTANT XXX -->
+ <!-- Keep this date up to date: -->
+ <date>2007-03-26</date>
+ <!-- ^^^^^^^^^^ -->
+ </refentryinfo>
+ <refmeta>
+ <refentrytitle>kdesudo</refentrytitle>
+ <manvolnum>1</manvolnum>
+ </refmeta>
+ <refnamediv>
+ <refname>kdesudo</refname>
+ <refpurpose>a sudo frontend for KDE</refpurpose>
+ </refnamediv>
+ <refsynopsisdiv>
+ <cmdsynopsis>
+ <command>kdesudo</command>
+ <arg choice="opt">
+ <option><replaceable>Generic-options</replaceable></option>
+ </arg>
+ <arg choice="opt">
+ <option><replaceable>kdesudo-options</replaceable></option>
+ </arg>
+ </cmdsynopsis>
+ </refsynopsisdiv>
+ <refsect1>
+ <title>DESCRIPTION</title>
+ <para>
+ kdesudo is a frontend for sudo for the <productname>KDE</productname> desktop.
+ </para>
+ </refsect1>
+ <refsect1>
+ <title>OPTIONS</title>
+ <para>
+ <variablelist>
+ <title>Generic options:</title>
+ <varlistentry>
+ <term> <option>--help</option> </term>
+ <listitem> <para>Show help about options</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--help-qt</option> </term>
+ <listitem> <para>Show Qt specific options</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--help-kde</option> </term>
+ <listitem> <para>Show KDE specific options</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--help-all</option> </term>
+ <listitem> <para>Show all options</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--author</option> </term>
+ <listitem> <para>Show author information</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>-v</option>, <option>--version</option> </term>
+ <listitem> <para>Show version information</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--license</option> </term>
+ <listitem> <para>Show license information</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--</option> </term>
+ <listitem> <para>Indicates end of options</para> </listitem>
+ </varlistentry>
+ </variablelist>
+ <variablelist>
+ <title>KdeSudo Options:</title>
+ <varlistentry>
+ <term> <option>-c « command »</option> </term>
+ <listitem> <para>Specifies the command to run</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>-u « user »</option> </term>
+ <listitem> <para>Specifies the target uid [default is root]</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>-n</option> </term>
+ <listitem> <para>Do not keep password</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>-s</option> </term>
+ <listitem> <para>Forgets all passwords</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>-p « priority »</option> </term>
+ <listitem> <para>Set priority value: between 0 and 100, 0 is lowest [default is 50]</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--nonewdcop</option> </term>
+ <listitem> <para>Let command use existing dcopserver</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--comment « comment »</option> </term>
+ <listitem> <para>Comment to display in the dialog box</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--noignorebutton</option> </term>
+ <listitem> <para>Do not display « ignore » button</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>-i « icon_name »</option> </term>
+ <listitem> <para>Specify icon to use in the password dialog</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>-d</option> </term>
+ <listitem> <para>Do not show the command to be run in the dialog</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>-r</option> </term>
+ <listitem> <para>Use realtime scheduling</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>-f « file »</option> </term>
+ <listitem> <para>Use target UID if « file » is not writeable</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>-t</option> </term>
+ <listitem> <para>Enable terminal output (no password keeping)</para> </listitem>
+ </varlistentry>
+ </variablelist>
+ </para>
+ <para>
+ <variablelist>
+ <title>KdeSudo options:</title>
+ <varlistentry>
+ <term> <option>-u</option> </term>
+ <listitem> <para>Sets a runas user</para> </listitem>
+ </varlistentry>
+ </variablelist>
+ <!-- TODO * add all the rest of the options, but maybe find an automated
+ way to keep it up to date -->
+ </para>
+ </refsect1>
+ <refsect1>
+ <title>COPYRIGHT</title>
+ <para>
+ This manual page was written by Anthony Mercatante
+ <email>tonio@ubuntu.com</email> for the
+ <productname>Ubuntu</productname> system (but may be used by others).
+ Permission is granted to copy, distribute and/or modify this document
+ under the terms of the <acronym>GNU</acronym> General Public License,
+ Version 2 or any later version published by the Free Software Foundation.
+ </para>
+ <para>
+ On Debian systems, the complete text of the GNU General Public
+ License can be found in
+ <filename>/usr/share/common-licenses/GPL</filename>.
+ </para>
+ </refsect1>
+</refentry>
diff --git a/debian/_base/applications/settings/kdesudo/debian/links b/debian/_base/applications/settings/kdesudo/debian/links
new file mode 100644
index 000000000..c30adf9c1
--- /dev/null
+++ b/debian/_base/applications/settings/kdesudo/debian/links
@@ -0,0 +1 @@
+opt/trinity/bin/kdesudo opt/trinity/bin/kdesu
diff --git a/debian/_base/applications/settings/kdesudo/debian/patches/series b/debian/_base/applications/settings/kdesudo/debian/patches/series
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/debian/_base/applications/settings/kdesudo/debian/patches/series
diff --git a/debian/_base/applications/settings/kdesudo/debian/postinst b/debian/_base/applications/settings/kdesudo/debian/postinst
new file mode 100644
index 000000000..7ec0ace2f
--- /dev/null
+++ b/debian/_base/applications/settings/kdesudo/debian/postinst
@@ -0,0 +1,21 @@
+#! /bin/sh
+
+set -e
+
+package_name=kdesudo-trinity
+
+if [ -z "$package_name" ]; then
+ print >&2 "Internal Error. Please report a bug."
+ exit 1;
+fi
+
+case "$1" in
+ configure)
+ ;;
+ abort-upgrade)
+ ;;
+ *) echo "$0: didn't understand being called with \`$1'" 1>&2
+ exit 0;;
+esac
+
+exit 0
diff --git a/debian/_base/applications/settings/kdesudo/debian/postrm b/debian/_base/applications/settings/kdesudo/debian/postrm
new file mode 100644
index 000000000..526a8c60a
--- /dev/null
+++ b/debian/_base/applications/settings/kdesudo/debian/postrm
@@ -0,0 +1,25 @@
+#! /bin/sh
+
+set -e
+
+package_name=kdesudo-trinity
+
+if [ -z "$package_name" ]; then
+ print >&2 "Internal Error. Please report a bug."
+ exit 1;
+fi
+
+case "$1" in
+ remove)
+ dpkg-divert --package $package_name --rename --remove \
+ /opt/trinity/bin/kdesu
+ ;;
+ purge)
+ ;;
+ upgrade)
+ ;;
+ *) echo "$0: didn't understand being called with \`$1'" 1>&2
+ exit 0;;
+esac
+
+exit 0
diff --git a/debian/_base/applications/settings/kdesudo/debian/preinst b/debian/_base/applications/settings/kdesudo/debian/preinst
new file mode 100644
index 000000000..4ce843004
--- /dev/null
+++ b/debian/_base/applications/settings/kdesudo/debian/preinst
@@ -0,0 +1,36 @@
+#! /bin/sh
+
+set -e
+
+package_name=kdesudo-trinity
+
+if [ -z "$package_name" ]; then
+ print >&2 "Internal Error. Please report a bug."
+ exit 1;
+fi
+
+case "$1" in
+ install)
+ dpkg-divert --package $package_name \
+ --divert /opt/trinity/bin/kdesu.distrib \
+ --rename /opt/trinity/bin/kdesu
+ ;;
+ upgrade)
+ divert=`dpkg-divert --listpackage "/usr/trinity/bin/kdesu"`
+ if [ -n "$divert" ] && [ "$divert" = "$package_name" ]; then
+ dpkg-divert --remove --package $package_name --rename "/usr/trinity/bin/kdesu"
+ fi
+ divert=`dpkg-divert --listpackage "/opt/trinity/bin/kdesu"`
+ if [ -z "$divert" ]; then
+ dpkg-divert --package $package_name \
+ --divert /opt/trinity/bin/kdesu.distrib \
+ --rename /opt/trinity/bin/kdesu
+ fi
+ ;;
+ abort-upgrade)
+ ;;
+ *) echo "$0: didn't understand being called with \`$1'" 1>&2
+ exit 0;;
+esac
+
+exit 0
diff --git a/debian/_base/applications/settings/kdesudo/debian/rules b/debian/_base/applications/settings/kdesudo/debian/rules
new file mode 100755
index 000000000..ddcdb7807
--- /dev/null
+++ b/debian/_base/applications/settings/kdesudo/debian/rules
@@ -0,0 +1,22 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/kde
+
+DEB_INSTALL_MANPAGES_kdesudo-trinity = kdesudo-trinity.1
+
+build/kdesudo-trinity::
+ docbook2x-man debian/kdesudo-trinity.1.docbook
+ mv kdesudo.1 kdesudo-trinity.1
+
+clean::
+ rm -f kdesudo-trinity.1
diff --git a/debian/_base/applications/settings/kdesudo/debian/source/format b/debian/_base/applications/settings/kdesudo/debian/source/format
new file mode 100644
index 000000000..163aaf8d8
--- /dev/null
+++ b/debian/_base/applications/settings/kdesudo/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/_base/applications/settings/kdesudo/debian/source/options b/debian/_base/applications/settings/kdesudo/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/debian/_base/applications/settings/kdesudo/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*