summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/settings/kiosktool
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/settings/kiosktool')
-rw-r--r--debian/_base/applications/settings/kiosktool/debian/cdbs/debian-tde.mk246
-rw-r--r--debian/_base/applications/settings/kiosktool/debian/cdbs/versions.pl19
-rw-r--r--debian/_base/applications/settings/kiosktool/debian/changelog92
-rw-r--r--debian/_base/applications/settings/kiosktool/debian/compat1
-rw-r--r--debian/_base/applications/settings/kiosktool/debian/control15
-rw-r--r--debian/_base/applications/settings/kiosktool/debian/copyright29
-rw-r--r--debian/_base/applications/settings/kiosktool/debian/kiosktool-kdedirs-trinity.1146
-rw-r--r--debian/_base/applications/settings/kiosktool/debian/kiosktool-trinity.1150
-rw-r--r--debian/_base/applications/settings/kiosktool/debian/kiosktool-trinity.manpages2
-rw-r--r--debian/_base/applications/settings/kiosktool/debian/patches/series0
-rwxr-xr-xdebian/_base/applications/settings/kiosktool/debian/rules11
-rw-r--r--debian/_base/applications/settings/kiosktool/debian/source/format1
-rw-r--r--debian/_base/applications/settings/kiosktool/debian/source/options6
13 files changed, 718 insertions, 0 deletions
diff --git a/debian/_base/applications/settings/kiosktool/debian/cdbs/debian-tde.mk b/debian/_base/applications/settings/kiosktool/debian/cdbs/debian-tde.mk
new file mode 100644
index 000000000..f36e3527c
--- /dev/null
+++ b/debian/_base/applications/settings/kiosktool/debian/cdbs/debian-tde.mk
@@ -0,0 +1,246 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Copyright © 2019 TDE Team
+# Description: A class for TDE packages; sets TDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+endif
+ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
+endif
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
+ touch debian/stamp-cvs-make
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+ifndef _cdbs_class_cmake
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+endif
+
+ifdef _cdbs_class_cmake
+ifneq "$(wildcard /usr/bin/ninja)" ""
+MAKE = ninja -v
+DEB_MAKE_ENVVARS += DESTDIR=$(DEB_DESTDIR)
+DEB_MAKE_INSTALL_TARGET = install
+DEB_CMAKE_NORMAL_ARGS += -GNinja
+endif
+endif
+
+ifndef _cdbs_rules_patchsys_quilt
+DEB_PATCHDIRS := debian/patches/common debian/patches
+endif
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/tde/HTML
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
+DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+DEB_BUILD_PARALLEL ?= true
+
+cdbs_configure_flags += \
+ --with-qt-dir=/usr/share/qt3 \
+ --disable-rpath \
+ --with-xinerama \
+ $(cdbs_kde_enable_final) \
+ $(cdbs_kde_enable_debug)
+
+
+# This is a convenience target for calling manually.
+# It's not part of the build process.
+buildprep: clean apply-patches
+ifndef _cdbs_class_cmake
+ $(MAKE) -f admin/Makefile.common dist
+endif
+ debian/rules clean
+
+.tdepkginfo:
+ echo "# TDE package information" >.tdepkginfo
+ dpkg-parsechangelog | sed -n "s|^Source: |Name: |p" >>.tdepkginfo
+ dpkg-parsechangelog | sed -n "s|^Version: |Version: |p" >>.tdepkginfo
+ date +"DateTime: %m/%d/%Y %H:%M" -u -d "$$(dpkg-parsechangelog | sed -n 's|^Date: ||p')" >>.tdepkginfo
+
+post-patches:: .tdepkginfo
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+ # update multi-arch path in install files
+ ls -d debian/* | \
+ grep -E "(install|links)$$" | \
+ while read a; do \
+ [ -d $$a ] || [ -f $$a.arch ] || \
+ ! grep -q "\$$(DEB_HOST_MULTIARCH)" $$a || \
+ sed -i.arch "s|\$$(DEB_HOST_MULTIARCH)|$(DEB_HOST_MULTIARCH)|g" $$a; \
+ done
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+ # revert multi-arch path in install files
+ ls -d debian/* | \
+ grep -E "(install|links)$$" | \
+ while read a; do \
+ [ ! -f $$a.arch ] || \
+ mv $$a.arch $$a; \
+ done
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ done
+
+common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+DESTDIR=$(DEB_DESTDIR) $(DEB_MAKE_INVOKE) install-apidox)
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+clean::
+ifndef _cdbs_class_cmake
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+endif
+ rm -f .tdepkginfo
+ rm -f debian/stamp-kde-apidox
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/debian/_base/applications/settings/kiosktool/debian/cdbs/versions.pl b/debian/_base/applications/settings/kiosktool/debian/cdbs/versions.pl
new file mode 100644
index 000000000..75c9add4b
--- /dev/null
+++ b/debian/_base/applications/settings/kiosktool/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "KDE-Version3=$version3\n";
+print "KDE-Version2=$version2\n";
+print "KDE-Next-Version3=$version3_next\n";
+print "KDE-Next-Version2=$version2_next\n";
diff --git a/debian/_base/applications/settings/kiosktool/debian/changelog b/debian/_base/applications/settings/kiosktool/debian/changelog
new file mode 100644
index 000000000..a81e4659e
--- /dev/null
+++ b/debian/_base/applications/settings/kiosktool/debian/changelog
@@ -0,0 +1,92 @@
+kiosktool-trinity (1.0-2.0ubuntu0) maverick; urgency=low
+
+ * Trinity rebuild
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Sat, 15 Oct 2011 04:19:00 -0600
+
+kiosktool (1.0-1.1ubuntu6) hardy; urgency=low
+
+ * Rebuild with recent g++ compiler version.
+
+ -- Matthias Klose <doko@ubuntu.com> Thu, 03 Apr 2008 11:24:40 +0000
+
+kiosktool (1.0-1.1ubuntu5) gutsy; urgency=low
+
+ * Add kubuntu_03_sudo_support.diff to support sudo
+ * Add depend on kdesudo
+ * Move maintainer to XSBC-Original-Maintainer:
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Fri, 20 Jul 2007 16:57:11 +0100
+
+kiosktool (1.0-1.1ubuntu4) edgy; urgency=low
+
+ * Rebuild so it doesnt depend on libgamin0
+
+ -- Sarah Hobbs <hobbsee@ubuntu.com> Tue, 25 Jul 2006 13:25:55 +1000
+
+kiosktool (1.0-1.1ubuntu3) dapper; urgency=low
+
+ * Add kubuntu_02_kmenu.diff use the correct menu file
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Sun, 18 Dec 2005 15:46:35 +0000
+
+kiosktool (1.0-1.1ubuntu2) dapper; urgency=low
+
+ * Add automake1.9 build-dep
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Wed, 14 Dec 2005 17:43:36 +0000
+
+kiosktool (1.0-1.1ubuntu1) dapper; urgency=low
+
+ * Rebuild for libstdc++ transition
+ * Add kubuntu_01_kdepot.diff for .pot generation
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Wed, 14 Dec 2005 11:35:56 +0000
+
+kiosktool (1.0-1.1) unstable; urgency=medium
+
+ * Non-maintainer upload.
+ * Trigger rebuild for the Qt/KDE transition, no source changes needed.
+ (Closes: #327996)
+
+ -- Adeodato Simó <asp16@alu.ua.es> Tue, 27 Sep 2005 16:07:52 +0200
+
+kiosktool (1.0-1) unstable; urgency=low
+
+ * Released kiosktool 1.0
+
+ -- Pedro Jurado Maqueda <melenas@kdehispano.org> Tue, 26 Apr 2005 22:38:16 +0200
+
+kiosktool (0.9-2) unstable; urgency=low
+
+ * Solved a problem with upstream sources due to some messages translated to Spanish
+ * Changed description
+ * First Debian upload, closes: #267595
+ * Erased line Categories=Qt;KDE;System in kiosktool.desktop because this file is installed in Utilities category
+
+ -- Pedro Jurado Maqueda <melenas@kdehispano.org> Wed, 5 Jan 2005 15:18:17 +0100
+
+kiosktool (0.9-1) unstable; urgency=low
+
+ * Released kiosktool 0.9
+
+ -- Pedro Jurado Maqueda <melenas@kdehispano.org> Wed, 13 Oct 2004 14:57:28 +0200
+
+kiosktool (0.8-1) unstable; urgency=low
+
+ * First use of cdbs for packaging
+ * Created a man page with kdemangen.pl (thanks to Dominique Devriese)
+
+ -- Pedro Jurado Maqueda <melenas@kdehispano.org> Mon, 23 Aug 2004 11:53:37 +0200
+
+kiosktool (0.7-1) unstable; urgency=low
+
+ * Correct a semantic error in description
+
+ -- Pedro Jurado Maqueda <melenas@kdehispano.org> Wed, 7 Jul 2004 15:19:42 +0200
+
+kiosktool (0.6-1) unstable; urgency=low
+
+ * Initial release
+
+ -- Pedro Jurado Maqueda <melenas@kdehispano.org> Wed, 7 Jul 2004 15:19:42 +0200
diff --git a/debian/_base/applications/settings/kiosktool/debian/compat b/debian/_base/applications/settings/kiosktool/debian/compat
new file mode 100644
index 000000000..7f8f011eb
--- /dev/null
+++ b/debian/_base/applications/settings/kiosktool/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/_base/applications/settings/kiosktool/debian/control b/debian/_base/applications/settings/kiosktool/debian/control
new file mode 100644
index 000000000..1005343c6
--- /dev/null
+++ b/debian/_base/applications/settings/kiosktool/debian/control
@@ -0,0 +1,15 @@
+Source: kiosktool-trinity
+Section: kde
+Priority: optional
+Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
+XSBC-Original-Maintainer: Pedro Jurado Maqueda <melenas@kdehispano.org>
+Build-Depends: debhelper (>= 7.0.50~), quilt, cdbs, kdelibs4-trinity-dev, automake, autoconf, libtool, libltdl-dev
+Standards-Version: 3.8.4
+
+Package: kiosktool-trinity
+Architecture: any
+Depends: ${shlibs:Depends}, kdesudo-trinity
+Description: tool to configure the TDE kiosk framework
+ A Point&Click tool for system administrators to enable
+ TDE's KIOSK features or otherwise preconfigure TDE for
+ groups of users.
diff --git a/debian/_base/applications/settings/kiosktool/debian/copyright b/debian/_base/applications/settings/kiosktool/debian/copyright
new file mode 100644
index 000000000..a88b1d8d2
--- /dev/null
+++ b/debian/_base/applications/settings/kiosktool/debian/copyright
@@ -0,0 +1,29 @@
+This package was debianized by Pedro Jurado Maqueda <melenas@kdehispano.org> on
+Fri, 14 Jul 2004 12:49:42 +0200.
+
+It was downloaded from ftp://ftp.kde.org/pub/kde/stable/apps/KDE3.x/admin
+
+Upstream Author: Waldo Bastian <waldo@kde.org>
+
+Copyright:
+ 2003, 2004 Waldo Bastian <bastian@kde.org>
+ 2004 Martijn Klingens <klingens@kde.org>
+
+License:
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; version 2 dated June, 1991.
+
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this package; if not, write to the Free Software
+ Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
+ 02111-1307, USA.
+
+On Debian systems, the complete text of the GNU General Public License
+version 2 can be found in `/usr/share/common-licenses/GPL-2'.
+
diff --git a/debian/_base/applications/settings/kiosktool/debian/kiosktool-kdedirs-trinity.1 b/debian/_base/applications/settings/kiosktool/debian/kiosktool-kdedirs-trinity.1
new file mode 100644
index 000000000..62faad5d3
--- /dev/null
+++ b/debian/_base/applications/settings/kiosktool/debian/kiosktool-kdedirs-trinity.1
@@ -0,0 +1,146 @@
+.\" This file was generated by kdemangen.pl
+.TH KIOSKTOOL\-KDEDIRS 1 "Ago 2004" "K Desktop Environment" "A tool to set $KDEDIRS according to the current user profile."
+.SH NAME
+kiosktool\-kdedirs
+\- A tool to set $KDEDIRS according to the current user profile.
+.SH SYNOPSIS
+kiosktool\-kdedirs [Qt\-options] [KDE\-options] [options]
+.SH DESCRIPTION
+
+.SH OPTIONS
+.SS Options:
+.TP
+.B \-\-check
+Output currently active prefixes
+.SS Generic options:
+.TP
+.B \-\-help
+Show help about options
+.TP
+.B \-\-help\-qt
+Show Qt specific options
+.TP
+.B \-\-help\-kde
+Show KDE specific options
+.TP
+.B \-\-help\-all
+Show all options
+.TP
+.B \-\-author
+Show author information
+.TP
+.B \-v, \-\-version
+Show version information
+.TP
+.B \-\-license
+Show license information
+.TP
+.B \-\-
+End of options
+.SS
+.SS KDE options:
+.TP
+.B \-\-caption <caption>
+Use 'caption' as name in the titlebar.
+.TP
+.B \-\-icon <icon>
+Use 'icon' as the application icon.
+.TP
+.B \-\-miniicon <icon>
+Use 'icon' as the icon in the titlebar.
+.TP
+.B \-\-config <filename>
+Use alternative configuration file.
+.TP
+.B \-\-dcopserver <server>
+Use the DCOP Server specified by 'server'.
+.TP
+.B \-\-nocrashhandler
+Disable crash handler, to get core dumps.
+.TP
+.B \-\-waitforwm
+Waits for a WM_NET compatible windowmanager.
+.TP
+.B \-\-style <style>
+sets the application GUI style.
+.TP
+.B \-\-geometry <geometry>
+sets the client geometry of the main widget.
+.SS
+.SS Qt options:
+.TP
+.B \-\-display <displayname>
+Use the X\-server display 'displayname'.
+.TP
+.B \-\-session <sessionId>
+Restore the application for the given 'sessionId'.
+.TP
+.B \-\-cmap
+Causes the application to install a private color
+map on an 8\-bit display.
+.TP
+.B \-\-ncols <count>
+Limits the number of colors allocated in the color
+cube on an 8\-bit display, if the application is
+using the QApplication::ManyColor color
+specification.
+.TP
+.B \-\-nograb
+tells Qt to never grab the mouse or the keyboard.
+.TP
+.B \-\-dograb
+running under a debugger can cause an implicit
+\-nograb, use \-dograb to override.
+.TP
+.B \-\-sync
+switches to synchronous mode for debugging.
+.TP
+.B \-\-fn, \-\-font <fontname>
+defines the application font.
+.TP
+.B \-\-bg, \-\-background <color>
+sets the default background color and an
+application palette (light and dark shades are
+calculated).
+.TP
+.B \-\-fg, \-\-foreground <color>
+sets the default foreground color.
+.TP
+.B \-\-btn, \-\-button <color>
+sets the default button color.
+.TP
+.B \-\-name <name>
+sets the application name.
+.TP
+.B \-\-title <title>
+sets the application title (caption).
+.TP
+.B \-\-visual TrueColor
+forces the application to use a TrueColor visual on
+an 8\-bit display.
+.TP
+.B \-\-inputstyle <inputstyle>
+sets XIM (X Input Method) input style. Possible
+values are onthespot, overthespot, offthespot and
+root.
+.TP
+.B \-\-im <XIM server>
+set XIM server.
+.TP
+.B \-\-noxim
+disable XIM.
+.TP
+.B \-\-reverse
+mirrors the whole layout of widgets.
+.SS
+
+.SH SEE ALSO
+Full user documentation is available through the KDE Help Center. You can also enter the URL
+.BR help:/kiosktool\-kdedirs/
+directly into konqueror or you can run
+.BR "`khelpcenter help:/kiosktool\-kdedirs/'"
+from the command\-line.
+.br
+.SH AUTHORS
+.nf
+
diff --git a/debian/_base/applications/settings/kiosktool/debian/kiosktool-trinity.1 b/debian/_base/applications/settings/kiosktool/debian/kiosktool-trinity.1
new file mode 100644
index 000000000..08ba2ec80
--- /dev/null
+++ b/debian/_base/applications/settings/kiosktool/debian/kiosktool-trinity.1
@@ -0,0 +1,150 @@
+.\" This file was generated by kdemangen.pl
+.TH KIOSKTOOL 1 "Ago 2004" "K Desktop Environment" "KIOSK Admin Tool"
+.SH NAME
+kiosktool
+\- KIOSK Admin Tool
+.SH SYNOPSIS
+kiosktool [Qt\-options] [KDE\-options] [options]
+.SH DESCRIPTION
+With this application we can lock the access to some parts of KDE desktop
+and its applications.
+
+.SH OPTIONS
+.SS Options:
+.TP
+.B \-\-kderc <file>
+kderc file to save settings to [/etc/kderc]
+.SS Generic options:
+.TP
+.B \-\-help
+Show help about options
+.TP
+.B \-\-help\-qt
+Show Qt specific options
+.TP
+.B \-\-help\-kde
+Show KDE specific options
+.TP
+.B \-\-help\-all
+Show all options
+.TP
+.B \-\-author
+Show author information
+.TP
+.B \-v, \-\-version
+Show version information
+.TP
+.B \-\-license
+Show license information
+.TP
+.B \-\-
+End of options
+.SS
+.SS KDE options:
+.TP
+.B \-\-caption <caption>
+Use 'caption' as name in the titlebar.
+.TP
+.B \-\-icon <icon>
+Use 'icon' as the application icon.
+.TP
+.B \-\-miniicon <icon>
+Use 'icon' as the icon in the titlebar.
+.TP
+.B \-\-config <filename>
+Use alternative configuration file.
+.TP
+.B \-\-dcopserver <server>
+Use the DCOP Server specified by 'server'.
+.TP
+.B \-\-nocrashhandler
+Disable crash handler, to get core dumps.
+.TP
+.B \-\-waitforwm
+Waits for a WM_NET compatible windowmanager.
+.TP
+.B \-\-style <style>
+sets the application GUI style.
+.TP
+.B \-\-geometry <geometry>
+sets the client geometry of the main widget.
+.SS
+.SS Qt options:
+.TP
+.B \-\-display <displayname>
+Use the X\-server display 'displayname'.
+.TP
+.B \-\-session <sessionId>
+Restore the application for the given 'sessionId'.
+.TP
+.B \-\-cmap
+Causes the application to install a private color
+map on an 8\-bit display.
+.TP
+.B \-\-ncols <count>
+Limits the number of colors allocated in the color
+cube on an 8\-bit display, if the application is
+using the QApplication::ManyColor color
+specification.
+.TP
+.B \-\-nograb
+tells Qt to never grab the mouse or the keyboard.
+.TP
+.B \-\-dograb
+running under a debugger can cause an implicit
+\-nograb, use \-dograb to override.
+.TP
+.B \-\-sync
+switches to synchronous mode for debugging.
+.TP
+.B \-\-fn, \-\-font <fontname>
+defines the application font.
+.TP
+.B \-\-bg, \-\-background <color>
+sets the default background color and an
+application palette (light and dark shades are
+calculated).
+.TP
+.B \-\-fg, \-\-foreground <color>
+sets the default foreground color.
+.TP
+.B \-\-btn, \-\-button <color>
+sets the default button color.
+.TP
+.B \-\-name <name>
+sets the application name.
+.TP
+.B \-\-title <title>
+sets the application title (caption).
+.TP
+.B \-\-visual TrueColor
+forces the application to use a TrueColor visual on
+an 8\-bit display.
+.TP
+.B \-\-inputstyle <inputstyle>
+sets XIM (X Input Method) input style. Possible
+values are onthespot, overthespot, offthespot and
+root.
+.TP
+.B \-\-im <XIM server>
+set XIM server.
+.TP
+.B \-\-noxim
+disable XIM.
+.TP
+.B \-\-reverse
+mirrors the whole layout of widgets.
+.SS
+
+.SH SEE ALSO
+Full user documentation is available through the KDE Help Center. You can also enter the URL
+.BR help:/kiosktool/
+directly into konqueror or you can run
+.BR "`khelpcenter help:/kiosktool/'"
+from the command\-line.
+.br
+.SH AUTHORS
+.nf
+Waldo Bastian <bastian@kde.org>
+.br
+
diff --git a/debian/_base/applications/settings/kiosktool/debian/kiosktool-trinity.manpages b/debian/_base/applications/settings/kiosktool/debian/kiosktool-trinity.manpages
new file mode 100644
index 000000000..2d009e1db
--- /dev/null
+++ b/debian/_base/applications/settings/kiosktool/debian/kiosktool-trinity.manpages
@@ -0,0 +1,2 @@
+debian/kiosktool-trinity.1
+debian/kiosktool-kdedirs-trinity.1
diff --git a/debian/_base/applications/settings/kiosktool/debian/patches/series b/debian/_base/applications/settings/kiosktool/debian/patches/series
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/debian/_base/applications/settings/kiosktool/debian/patches/series
diff --git a/debian/_base/applications/settings/kiosktool/debian/rules b/debian/_base/applications/settings/kiosktool/debian/rules
new file mode 100755
index 000000000..6bf27ed9c
--- /dev/null
+++ b/debian/_base/applications/settings/kiosktool/debian/rules
@@ -0,0 +1,11 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
diff --git a/debian/_base/applications/settings/kiosktool/debian/source/format b/debian/_base/applications/settings/kiosktool/debian/source/format
new file mode 100644
index 000000000..163aaf8d8
--- /dev/null
+++ b/debian/_base/applications/settings/kiosktool/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/_base/applications/settings/kiosktool/debian/source/options b/debian/_base/applications/settings/kiosktool/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/debian/_base/applications/settings/kiosktool/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*