summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/smartcardauth/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/smartcardauth/debian/rules')
-rwxr-xr-xdebian/_base/applications/smartcardauth/debian/rules16
1 files changed, 16 insertions, 0 deletions
diff --git a/debian/_base/applications/smartcardauth/debian/rules b/debian/_base/applications/smartcardauth/debian/rules
new file mode 100755
index 000000000..fb1fa68e3
--- /dev/null
+++ b/debian/_base/applications/smartcardauth/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+include /usr/share/cdbs/1/class/makefile.mk
+include /usr/share/cdbs/1/rules/debhelper.mk
+
+DEB_BUILD_OPTIONS := nostrip
+export DEB_BUILD_OPTIONS = debug nostrip
+
+CFLAGS=-g -Wall -fPIC
+
+DEB_MAKE_INSTALL_TARGET := install DESTDIR="$(DEB_DESTDIR)"
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+DEB_DH_SHLIBDEPS_ARGS_ALL=--dpkg-shlibdeps-params=--ignore-missing-info