summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/smartcardauth/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/smartcardauth/debian/rules')
-rwxr-xr-xdebian/_base/applications/smartcardauth/debian/rules7
1 files changed, 7 insertions, 0 deletions
diff --git a/debian/_base/applications/smartcardauth/debian/rules b/debian/_base/applications/smartcardauth/debian/rules
index b5f130de7..14ccf6018 100755
--- a/debian/_base/applications/smartcardauth/debian/rules
+++ b/debian/_base/applications/smartcardauth/debian/rules
@@ -11,8 +11,15 @@ CFLAGS=-g -Wall -fPIC
DEB_MAKE_INSTALL_TARGET := install DESTDIR="$(DEB_DESTDIR)"
DEB_INSTALL_DOCS_ALL :=
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+endif
DEB_DH_SHLIBDEPS_ARGS_ALL=--dpkg-shlibdeps-params=--ignore-missing-info