summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/system/adept/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/system/adept/debian/rules')
-rwxr-xr-xdebian/_base/applications/system/adept/debian/rules21
1 files changed, 21 insertions, 0 deletions
diff --git a/debian/_base/applications/system/adept/debian/rules b/debian/_base/applications/system/adept/debian/rules
new file mode 100755
index 000000000..83626c5cb
--- /dev/null
+++ b/debian/_base/applications/system/adept/debian/rules
@@ -0,0 +1,21 @@
+#!/usr/bin/make -f
+
+# Currently is not possible to build piklab with --enable-final
+DEB_BUILD_OPTIONS += noopt
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_MAKE_CHECK_TARGET := check
+DEB_CONFIGURE_EXTRA_FLAGS += --enable-adept --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
+
+# Enable us to locate the old libept-trinity library and includes
+CPPFLAGS += -I/opt/trinity/include
+LDFLAGS += -L/opt/trinity/lib -lept