summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/system/dolphin/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/system/dolphin/debian/rules')
-rwxr-xr-xdebian/_base/applications/system/dolphin/debian/rules22
1 files changed, 22 insertions, 0 deletions
diff --git a/debian/_base/applications/system/dolphin/debian/rules b/debian/_base/applications/system/dolphin/debian/rules
new file mode 100755
index 000000000..ffb1212cf
--- /dev/null
+++ b/debian/_base/applications/system/dolphin/debian/rules
@@ -0,0 +1,22 @@
+#!/usr/bin/make -f
+
+# Set LD_LIBRARY_PATH to the installed library directory to allow dh_shlibdeps to function
+# Also include the main Trinity path
+ifeq ("$(LD_LIBRARY_PATH)", "")
+LD_LIBRARY_PATH=debian/tmp/opt/trinity/lib
+else
+LD_LIBRARY_PATH += :debian/tmp/opt/trinity/lib
+endif
+export LD_LIBRARY_PATH
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CMAKE_EXTRA_FLAGS := -DLIB_SUFFIX="" -DCMAKE_INSTALL_PREFIX="/opt/trinity" -DCONFIG_INSTALL_DIR="/etc/trinity" -DSYSCONF_INSTALL_DIR="/etc/trinity" -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" -DCMAKE_LIBRARY_PATH="/opt/trinity/lib" -DCMAKE_INCLUDE_PATH="/opt/trinity/include/" -DAUTODETECT_QT_DIRS="ON" -DCMAKE_VERBOSE_MAKEFILE="ON" -DBUILD_ALL="ON" -DCMAKE_SKIP_RPATH="OFF" \
+-DCMAKE_BUILD_TYPE=RelWithDebInfo
+
+binary-install/dolphin-trinity::
+ mkdir -p debian/dolphin-trinity/opt/trinity/bin
+ ln -s d3lphin debian/dolphin-trinity/opt/trinity/bin/dolphin
+ mv debian/dolphin-trinity/usr/share/man debian/dolphin-trinity/opt/trinity/share/