summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/system/smartcardauth/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/system/smartcardauth/debian')
-rwxr-xr-xdebian/_base/applications/system/smartcardauth/debian/changelog5
-rwxr-xr-xdebian/_base/applications/system/smartcardauth/debian/compat1
-rwxr-xr-xdebian/_base/applications/system/smartcardauth/debian/control23
-rwxr-xr-xdebian/_base/applications/system/smartcardauth/debian/dirs1
-rwxr-xr-xdebian/_base/applications/system/smartcardauth/debian/rules14
-rwxr-xr-xdebian/_base/applications/system/smartcardauth/debian/smartcardauth.postinst9
-rw-r--r--debian/_base/applications/system/smartcardauth/debian/source/format1
-rw-r--r--debian/_base/applications/system/smartcardauth/debian/source/options6
8 files changed, 60 insertions, 0 deletions
diff --git a/debian/_base/applications/system/smartcardauth/debian/changelog b/debian/_base/applications/system/smartcardauth/debian/changelog
new file mode 100755
index 000000000..4d5f37dad
--- /dev/null
+++ b/debian/_base/applications/system/smartcardauth/debian/changelog
@@ -0,0 +1,5 @@
+smartcardauth (1.0-3ubuntu5) karmic; urgency=low
+
+ * Karmic build
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 23 Jul 2009 10:42:00 -0600
diff --git a/debian/_base/applications/system/smartcardauth/debian/compat b/debian/_base/applications/system/smartcardauth/debian/compat
new file mode 100755
index 000000000..7f8f011eb
--- /dev/null
+++ b/debian/_base/applications/system/smartcardauth/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/_base/applications/system/smartcardauth/debian/control b/debian/_base/applications/system/smartcardauth/debian/control
new file mode 100755
index 000000000..938ebada5
--- /dev/null
+++ b/debian/_base/applications/system/smartcardauth/debian/control
@@ -0,0 +1,23 @@
+Source: smartcardauth
+Section: kde
+Priority: extra
+Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
+Uploaders: Timothy Pearson <kb9vqf@pearsoncomputing.net>
+Build-Depends: debhelper (>= 7.0.50~), quilt, cdbs, pcsc-tools, pcscd-nodbus, initramfs-tools, libpcsc-perl, libpcsclite1, libccid, opensc, libpar-packer-perl, libdb-dev (>= 4.7), libpam0g-dev, libssl-dev, libkrb5-dev, libtqtinterface-dev
+Standards-Version: 3.8.4
+
+Package: smartcardauth
+Architecture: any
+Depends: pcsc-tools, pcscd-nodbus, initramfs-tools, libpcsc-perl, libpcsclite1, libccid, opensc, zenity, gksu
+Conflicts: openct
+Description: SmartCard Login and LUKS Decrypt, Setup Utility
+ This utility will allow you to set up your computer to accept a SmartCard as an authentication source for:
+ - Your encrypted LUKS partition
+ - TDE3.x, including automatic login, lock, and unlock features
+ It is designed to work with any ISO 7816-1,2,3,4 compliant smartcard
+ Examples of such cards are:
+ - The Schlumberger MultiFlex
+ - The ACS ACOS5 / ACOS6 series of cryptographic ISO 7816 cards
+ If a card is chosen that has PKSC support, such as the ACOS cards, this utility can run
+ simultaneously with the certificate reading program(s) to provide single sign on
+ in addition to the PKCS certificate functionality
diff --git a/debian/_base/applications/system/smartcardauth/debian/dirs b/debian/_base/applications/system/smartcardauth/debian/dirs
new file mode 100755
index 000000000..73752c9ae
--- /dev/null
+++ b/debian/_base/applications/system/smartcardauth/debian/dirs
@@ -0,0 +1 @@
+usr
diff --git a/debian/_base/applications/system/smartcardauth/debian/rules b/debian/_base/applications/system/smartcardauth/debian/rules
new file mode 100755
index 000000000..fe74e584a
--- /dev/null
+++ b/debian/_base/applications/system/smartcardauth/debian/rules
@@ -0,0 +1,14 @@
+#!/usr/bin/make -f
+include /usr/share/cdbs/1/class/makefile.mk
+include /usr/share/cdbs/1/rules/debhelper.mk
+
+DEB_BUILD_OPTIONS := nostrip
+export DEB_BUILD_OPTIONS = debug nostrip
+
+CFLAGS=-g -Wall -fPIC
+
+DEB_MAKE_INSTALL_TARGET := install DESTDIR="$(DEB_DESTDIR)"
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
diff --git a/debian/_base/applications/system/smartcardauth/debian/smartcardauth.postinst b/debian/_base/applications/system/smartcardauth/debian/smartcardauth.postinst
new file mode 100755
index 000000000..842e0017d
--- /dev/null
+++ b/debian/_base/applications/system/smartcardauth/debian/smartcardauth.postinst
@@ -0,0 +1,9 @@
+#!/bin/bash
+
+set -e
+
+if [[ $1 = "configure" ]]; then
+ /usr/bin/setupcard.sh upgrade
+fi
+
+
diff --git a/debian/_base/applications/system/smartcardauth/debian/source/format b/debian/_base/applications/system/smartcardauth/debian/source/format
new file mode 100644
index 000000000..163aaf8d8
--- /dev/null
+++ b/debian/_base/applications/system/smartcardauth/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/_base/applications/system/smartcardauth/debian/source/options b/debian/_base/applications/system/smartcardauth/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/debian/_base/applications/system/smartcardauth/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*