summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/tde-guidance/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/tde-guidance/debian/rules')
-rwxr-xr-xdebian/_base/applications/tde-guidance/debian/rules7
1 files changed, 7 insertions, 0 deletions
diff --git a/debian/_base/applications/tde-guidance/debian/rules b/debian/_base/applications/tde-guidance/debian/rules
index 0cbf1123b..54328b46d 100755
--- a/debian/_base/applications/tde-guidance/debian/rules
+++ b/debian/_base/applications/tde-guidance/debian/rules
@@ -22,8 +22,15 @@ PYSUPPORT_PATH = $(DEB_DESTDIR)$(PYSUPPORT_INST_PATH)
DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/tde
LDFLAGS_APPEND := -L/opt/trinity/lib
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+endif
post-patches::
# make sure that python binary exists