summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/tdeio-gopher/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/tdeio-gopher/debian')
-rw-r--r--debian/_base/applications/tdeio-gopher/debian/cdbs/debian-qt-kde.mk111
-rw-r--r--debian/_base/applications/tdeio-gopher/debian/cdbs/kde.mk89
-rw-r--r--debian/_base/applications/tdeio-gopher/debian/cdbs/versions.pl19
-rw-r--r--debian/_base/applications/tdeio-gopher/debian/changelog6
-rw-r--r--debian/_base/applications/tdeio-gopher/debian/compat1
-rw-r--r--debian/_base/applications/tdeio-gopher/debian/control19
-rw-r--r--debian/_base/applications/tdeio-gopher/debian/copyright16
-rw-r--r--debian/_base/applications/tdeio-gopher/debian/patches/series0
-rwxr-xr-xdebian/_base/applications/tdeio-gopher/debian/rules32
-rw-r--r--debian/_base/applications/tdeio-gopher/debian/source/format1
-rw-r--r--debian/_base/applications/tdeio-gopher/debian/source/options6
11 files changed, 300 insertions, 0 deletions
diff --git a/debian/_base/applications/tdeio-gopher/debian/cdbs/debian-qt-kde.mk b/debian/_base/applications/tdeio-gopher/debian/cdbs/debian-qt-kde.mk
new file mode 100644
index 000000000..68dca1718
--- /dev/null
+++ b/debian/_base/applications/tdeio-gopher/debian/cdbs/debian-qt-kde.mk
@@ -0,0 +1,111 @@
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ touch debian/stamp-cvs-make
+
+include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
+
+ifndef _cdbs_rules_patchsys_quilt
+DEB_PATCHDIRS := debian/patches/common debian/patches
+endif
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ done
+
+clean::
+ rm -f debian/stamp-cvs-make
+
+endif
+
+#common-build-indep:: debian/stamp-kde-apidox
+#debian/stamp-kde-apidox:
+# $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+# touch $@
+#
+#common-install-indep:: common-install-kde-apidox
+#common-install-kde-apidox::
+# $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
+#
+#clean::
+# rm -f debian/stamp-kde-apidox
diff --git a/debian/_base/applications/tdeio-gopher/debian/cdbs/kde.mk b/debian/_base/applications/tdeio-gopher/debian/cdbs/kde.mk
new file mode 100644
index 000000000..f5d237249
--- /dev/null
+++ b/debian/_base/applications/tdeio-gopher/debian/cdbs/kde.mk
@@ -0,0 +1,89 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Description: A class for KDE packages; sets KDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+
+ifndef _cdbs_class_kde
+_cdbs_class_kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+# include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/tde/HTML
+
+ifeq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include/"
+DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+common-build-arch common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+# $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-arch common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+# $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
+
+clean::
+ rm -f debian/stamp-kde-apidox
+
+# This is a convenience target for calling manually. It's not part of
+# the build process.
+buildprep: clean apply-patches
+ $(MAKE) -f admin/Makefile.common dist
+ debian/rules clean
+
+endif
diff --git a/debian/_base/applications/tdeio-gopher/debian/cdbs/versions.pl b/debian/_base/applications/tdeio-gopher/debian/cdbs/versions.pl
new file mode 100644
index 000000000..1b110f7af
--- /dev/null
+++ b/debian/_base/applications/tdeio-gopher/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "TDE-Version3=$version3\n";
+print "TDE-Version2=$version2\n";
+print "TDE-Next-Version3=$version3_next\n";
+print "TDE-Next-Version2=$version2_next\n";
diff --git a/debian/_base/applications/tdeio-gopher/debian/changelog b/debian/_base/applications/tdeio-gopher/debian/changelog
new file mode 100644
index 000000000..42dfe20d9
--- /dev/null
+++ b/debian/_base/applications/tdeio-gopher/debian/changelog
@@ -0,0 +1,6 @@
+tdeio-gopher-trinity (0.1.4-1debian0) buster; urgency=low
+
+ * Buster rebuild
+
+ -- Michele Calgaro <michele.calgaro@yahoo.it> Sat, 25 Aug 2018 21:56:00 +0900
+
diff --git a/debian/_base/applications/tdeio-gopher/debian/compat b/debian/_base/applications/tdeio-gopher/debian/compat
new file mode 100644
index 000000000..7f8f011eb
--- /dev/null
+++ b/debian/_base/applications/tdeio-gopher/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/_base/applications/tdeio-gopher/debian/control b/debian/_base/applications/tdeio-gopher/debian/control
new file mode 100644
index 000000000..8d61c5428
--- /dev/null
+++ b/debian/_base/applications/tdeio-gopher/debian/control
@@ -0,0 +1,19 @@
+Source: tdeio-gopher-trinity
+Section: tde
+Priority: optional
+Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
+XSBC-Original-Maintainer: Albert Astals Cid <aacid@kde.org>
+Build-Depends: cdbs, debhelper (>= 7.0.50~), quilt, tdelibs14-trinity-dev, cmake
+Standards-Version: 3.8.4
+
+Package: tdeio-gopher-trinity
+Architecture: any
+Depends: ${shlibs:Depends}
+Replaces: kio-gopher-trinity (<< 4:14.0.0~)
+Breaks: kio-gopher-trinity (<< 4:14.0.0~)
+Conflicts: kdebase-kio-plugins-trinity (<< 4:14.1.0~), tdebase-tdeio-plugins-trinity (<< 4:14.1.0~)
+Description: tdeio-slave for the gopher protocol [Trinity]
+ Adds support for the "gopher:" protocol
+ to Konqueror and other TDE applications.
+ .
+ This enables you to perform gopher searches in Konqueror.
diff --git a/debian/_base/applications/tdeio-gopher/debian/copyright b/debian/_base/applications/tdeio-gopher/debian/copyright
new file mode 100644
index 000000000..31f347396
--- /dev/null
+++ b/debian/_base/applications/tdeio-gopher/debian/copyright
@@ -0,0 +1,16 @@
+This package was debianized by Michele Calgaro <michele.calgaro@yahoo.it> on
+Sat, 25 Aug 2018 21:56:00 +0900
+
+Copyright:
+ This program was initially written by Albert Astals Cid.
+ Copyright (C) 2003-2008 by Albert Astals Cid
+ aacid@kde.org
+
+Upstream Authors:
+ Albert Astals Cid <aacid@kde.org>
+
+License:
+ You are free to distribute this software under the terms of
+ the GNU General Public License.
+ On Debian systems, the complete text of the GNU General Public
+ License can be found in the file `/usr/share/common-licenses/GPL'.
diff --git a/debian/_base/applications/tdeio-gopher/debian/patches/series b/debian/_base/applications/tdeio-gopher/debian/patches/series
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/debian/_base/applications/tdeio-gopher/debian/patches/series
diff --git a/debian/_base/applications/tdeio-gopher/debian/rules b/debian/_base/applications/tdeio-gopher/debian/rules
new file mode 100755
index 000000000..d8c40442f
--- /dev/null
+++ b/debian/_base/applications/tdeio-gopher/debian/rules
@@ -0,0 +1,32 @@
+#!/usr/bin/make -f
+
+# Set LD_LIBRARY_PATH to the installed library directory to allow dh_shlibdeps to function
+# Also include the main Trinity path
+ifeq ("$(LD_LIBRARY_PATH)", "")
+LD_LIBRARY_PATH=debian/tmp/opt/trinity/lib
+else
+LD_LIBRARY_PATH += :debian/tmp/opt/trinity/lib
+endif
+export LD_LIBRARY_PATH
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include /usr/share/cdbs/1/rules/utils.mk
+include debian/cdbs/debian-qt-kde.mk
+
+DEB_KDE_APIDOX := yes
+
+CXXFLAGS := -DSMB_CTX_FLAG_USE_KERBEROS -DSMB_CTX_FLAG_FALLBACK_AFTER_KERBEROS -g -Wall $(DEB_OPT_FLAG)
+
+DEB_CMAKE_EXTRA_FLAGS := -DLIB_SUFFIX="" -DCMAKE_INSTALL_PREFIX="/opt/trinity" -DCONFIG_INSTALL_DIR="/etc/trinity" -DSYSCONF_INSTALL_DIR="/etc/trinity" -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" -DCMAKE_LIBRARY_PATH="/opt/trinity/lib" -DCMAKE_INCLUDE_PATH="/opt/trinity/include/" -DAUTODETECT_QT_DIRS="ON" -DCMAKE_VERBOSE_MAKEFILE="ON" -DBUILD_ALL="ON" -DCMAKE_SKIP_RPATH="OFF" \
+-DCMAKE_BUILD_TYPE=RelWithDebInfo
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+# Honour "parallel=N" option of DEB_BUILD_OPTIONS. Comment out to
+# never build in parallel, regardless of DEB_BUILD_OPTIONS.
+DEB_BUILD_PARALLEL = true
+
+DEB_INSTALL_DOCS_tdeio-gopher-trinity := -XREADME -XNEWS -XTODO -XAUTHORS
diff --git a/debian/_base/applications/tdeio-gopher/debian/source/format b/debian/_base/applications/tdeio-gopher/debian/source/format
new file mode 100644
index 000000000..163aaf8d8
--- /dev/null
+++ b/debian/_base/applications/tdeio-gopher/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/_base/applications/tdeio-gopher/debian/source/options b/debian/_base/applications/tdeio-gopher/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/debian/_base/applications/tdeio-gopher/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*