summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/themes/kde-style-qtcurve
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/themes/kde-style-qtcurve')
-rw-r--r--debian/_base/applications/themes/kde-style-qtcurve/debian/cdbs/debian-tde.mk246
-rw-r--r--debian/_base/applications/themes/kde-style-qtcurve/debian/cdbs/versions.pl19
-rw-r--r--debian/_base/applications/themes/kde-style-qtcurve/debian/changelog171
-rw-r--r--debian/_base/applications/themes/kde-style-qtcurve/debian/compat1
-rw-r--r--debian/_base/applications/themes/kde-style-qtcurve/debian/control27
-rw-r--r--debian/_base/applications/themes/kde-style-qtcurve/debian/copyright33
-rw-r--r--debian/_base/applications/themes/kde-style-qtcurve/debian/docs2
-rw-r--r--debian/_base/applications/themes/kde-style-qtcurve/debian/kde-style-qtcurve-trinity.install1
-rw-r--r--debian/_base/applications/themes/kde-style-qtcurve/debian/patches/series0
-rwxr-xr-xdebian/_base/applications/themes/kde-style-qtcurve/debian/rules23
-rw-r--r--debian/_base/applications/themes/kde-style-qtcurve/debian/scan-version41
-rw-r--r--debian/_base/applications/themes/kde-style-qtcurve/debian/source/format1
-rw-r--r--debian/_base/applications/themes/kde-style-qtcurve/debian/source/options6
13 files changed, 571 insertions, 0 deletions
diff --git a/debian/_base/applications/themes/kde-style-qtcurve/debian/cdbs/debian-tde.mk b/debian/_base/applications/themes/kde-style-qtcurve/debian/cdbs/debian-tde.mk
new file mode 100644
index 000000000..f36e3527c
--- /dev/null
+++ b/debian/_base/applications/themes/kde-style-qtcurve/debian/cdbs/debian-tde.mk
@@ -0,0 +1,246 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Copyright © 2019 TDE Team
+# Description: A class for TDE packages; sets TDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+endif
+ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
+endif
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
+ touch debian/stamp-cvs-make
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+ifndef _cdbs_class_cmake
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+endif
+
+ifdef _cdbs_class_cmake
+ifneq "$(wildcard /usr/bin/ninja)" ""
+MAKE = ninja -v
+DEB_MAKE_ENVVARS += DESTDIR=$(DEB_DESTDIR)
+DEB_MAKE_INSTALL_TARGET = install
+DEB_CMAKE_NORMAL_ARGS += -GNinja
+endif
+endif
+
+ifndef _cdbs_rules_patchsys_quilt
+DEB_PATCHDIRS := debian/patches/common debian/patches
+endif
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/tde/HTML
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
+DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+DEB_BUILD_PARALLEL ?= true
+
+cdbs_configure_flags += \
+ --with-qt-dir=/usr/share/qt3 \
+ --disable-rpath \
+ --with-xinerama \
+ $(cdbs_kde_enable_final) \
+ $(cdbs_kde_enable_debug)
+
+
+# This is a convenience target for calling manually.
+# It's not part of the build process.
+buildprep: clean apply-patches
+ifndef _cdbs_class_cmake
+ $(MAKE) -f admin/Makefile.common dist
+endif
+ debian/rules clean
+
+.tdepkginfo:
+ echo "# TDE package information" >.tdepkginfo
+ dpkg-parsechangelog | sed -n "s|^Source: |Name: |p" >>.tdepkginfo
+ dpkg-parsechangelog | sed -n "s|^Version: |Version: |p" >>.tdepkginfo
+ date +"DateTime: %m/%d/%Y %H:%M" -u -d "$$(dpkg-parsechangelog | sed -n 's|^Date: ||p')" >>.tdepkginfo
+
+post-patches:: .tdepkginfo
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+ # update multi-arch path in install files
+ ls -d debian/* | \
+ grep -E "(install|links)$$" | \
+ while read a; do \
+ [ -d $$a ] || [ -f $$a.arch ] || \
+ ! grep -q "\$$(DEB_HOST_MULTIARCH)" $$a || \
+ sed -i.arch "s|\$$(DEB_HOST_MULTIARCH)|$(DEB_HOST_MULTIARCH)|g" $$a; \
+ done
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+ # revert multi-arch path in install files
+ ls -d debian/* | \
+ grep -E "(install|links)$$" | \
+ while read a; do \
+ [ ! -f $$a.arch ] || \
+ mv $$a.arch $$a; \
+ done
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ done
+
+common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+DESTDIR=$(DEB_DESTDIR) $(DEB_MAKE_INVOKE) install-apidox)
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+clean::
+ifndef _cdbs_class_cmake
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+endif
+ rm -f .tdepkginfo
+ rm -f debian/stamp-kde-apidox
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/debian/_base/applications/themes/kde-style-qtcurve/debian/cdbs/versions.pl b/debian/_base/applications/themes/kde-style-qtcurve/debian/cdbs/versions.pl
new file mode 100644
index 000000000..75c9add4b
--- /dev/null
+++ b/debian/_base/applications/themes/kde-style-qtcurve/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "KDE-Version3=$version3\n";
+print "KDE-Version2=$version2\n";
+print "KDE-Next-Version3=$version3_next\n";
+print "KDE-Next-Version2=$version2_next\n";
diff --git a/debian/_base/applications/themes/kde-style-qtcurve/debian/changelog b/debian/_base/applications/themes/kde-style-qtcurve/debian/changelog
new file mode 100644
index 000000000..b89b8bc90
--- /dev/null
+++ b/debian/_base/applications/themes/kde-style-qtcurve/debian/changelog
@@ -0,0 +1,171 @@
+kde-style-qtcurve-trinity (0.55.2-1ubuntu8) karmic; urgency=low
+
+ * Now provides kde-style-qtcurve for backward compatibility
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 17 Sep 2009 16:05:00 -0600
+
+kde-style-qtcurve-trinity (0.55.2-1ubuntu7) karmic; urgency=low
+
+ * Karmic rebuild
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 02 July 2009 16:08:00 -0600
+
+kde-style-qtcurve-trinity (0.55.2-1ubuntu6) intrepid; urgency=low
+
+ * Moved Trinity to /opt/trinity
+ * Integrated properly with KDE4.2+
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Wed, 03 March 2009 21:15:00 -0600
+
+kde-style-qtcurve-trinity (0.55.2-1ubuntu5) intrepid; urgency=low
+
+ * Added -trinity suffix
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Wed, 03 Dec 2008 18:37:00 -0600
+
+kde-style-qtcurve (0.55.2-1ubuntu3) hardy; urgency=low
+
+ * Set toolbar handles to sunken lines by default in
+ kubuntu_01_default_settings.diff
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Mon, 31 Mar 2008 13:04:55 +0100
+
+kde-style-qtcurve (0.55.2-1ubuntu2) hardy; urgency=low
+
+ * Add kubuntu_01_default_settings.diff for nicer defaults. Flat
+ toolbars and don't darken menubars.
+ * Build in !=srcdir so it can clean properly
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Mon, 17 Mar 2008 14:54:33 +0000
+
+kde-style-qtcurve (0.55.2-1ubuntu1) hardy; urgency=low
+
+ * Merge from debian unstable, remaining changes:
+ - debian/scan-version: Script to scan and download new upstream releases
+ (uscan will not work with links from kde-look.org).
+ - debian/copyright:
+ - Replaced FSF address.
+ - Removed dh_make comments.
+ - debian/rules:
+ - Added get-orig-source rule.
+ - Use cmake to build.
+ - debian/dirs:
+ - Deleted, not needed (and creates empty /usr/bin).
+
+ -- Stephan Hermann <sh@sourcecode.de> Mon, 21 Jan 2008 19:23:02 +0100
+
+kde-style-qtcurve (0.55.2-1) unstable; urgency=low
+
+ * New upstream version (Closes: #449309)
+
+ -- Bastian Venthur <venthur@debian.org> Sun, 20 Jan 2008 17:17:49 +0100
+
+kde-style-qtcurve (0.55.1-0ubuntu1) hardy; urgency=low
+
+ * New upstream release. (LP: #179655)
+ * debian/scan-version: Script to scan and download new upstream releases
+ (uscan will not work with links from kde-look.org).
+ * debian/control:
+ - Build-depend on cmake.
+ - Updated Standards-Version.
+ * debian/copyright:
+ - Replaced FSF address.
+ - Removed dh_make comments.
+ * debian/rules:
+ - Added get-orig-source rule.
+ - Use cmake to build.
+ * debian/dirs:
+ - Deleted, not needed (and creates empty /usr/bin).
+
+ -- Matvey Kozhev <sikon@lucidfox.org> Tue, 01 Jan 2008 17:08:56 +0600
+
+kde-style-qtcurve (0.52.3-1) unstable; urgency=low
+
+ * Don't lighten border of disabled check/radio buttons.
+ * Lighten trough of disabled slider.
+ * Modify khtml check to also check to see if widget name == "__khtml"
+ * Store khtml widgets in a map, to speed up checking.
+ * Fix shadow on comboboxes.
+ * Draw background of checked menuitem icons as per KDE4.
+
+ -- Bastian Venthur <venthur@debian.org> Fri, 10 Aug 2007 10:10:55 +0200
+
+kde-style-qtcurve (0.52.2-1) unstable; urgency=low
+
+ New upstream version
+
+ [0.52.2]
+
+ * Fix crash when slider color == button.
+
+ [0.52.1]
+
+ * Draw emphasis around menus when not lightening.
+ * Use button colors to border entry fields.
+ * Don't allow scrollbars to be recolored.
+ * Fix amarok menus!
+
+
+ -- Bastian Venthur <venthur@debian.org> Sun, 24 Jun 2007 13:13:10 +0200
+
+kde-style-qtcurve (0.52-1) unstable; urgency=low
+
+ * New upstream version
+
+ * Use 'dull glass' as the default gradient - previous default is now
+ called 'Clean'.
+ * Darken slider mouse over colour if slider is not shaded.
+ * Use thinner slider mouse over sections if slider is not shaded.
+ * Improve look of small V arrows.
+ * Even duller dull glass, but much more useable.
+ * Fix setting of check/radio colour.
+ * Only highlight editable combo arrow when mouse over arrow, not over edit
+ field - more Gtk like.
+ * Added one config file option (no gui):
+ gtkScrollViews set to 'true' to have the scrollbars drawn outside of
+ scrollviews. (However, doesn't look very good)
+ * Lighten combo list frame.
+ * Dont round MDI buttons.
+ * Fix opera's MDI buttons within menubars.
+ * Always assume PE_ButtonBevel is enabled - used for QtConfig's colour
+ buttons
+
+ -- Bastian Venthur <venthur@debian.org> Tue, 19 Jun 2007 17:35:33 +0200
+
+kde-style-qtcurve (0.51-2) unstable; urgency=low
+
+ * Changed priority from extra to optional
+
+ -- Bastian Venthur <venthur@debian.org> Mon, 11 Jun 2007 11:21:00 +0200
+
+kde-style-qtcurve (0.51-1) unstable; urgency=low
+
+ * New upstream version (Closes: #427043)
+
+ * Changed shading to use HSL colour space. This can be altered by editing
+ $XDG_CONFIG_HOME/qtcurvestylerc and setting 'shading=simple' for the
+ previous method, or 'shading=hsv' to use HSV.
+ * Add options:
+ Border all of menu/toolbars.
+ Darker borders.
+ 'V' arrows.
+ * Fix raised listview headers.
+ * Fix glass style menuitem appearance.
+ * Modifed look of dullglass, looks "softer"
+ * Improve look of plastik mouse-over for non coloured scrollbars.
+ * For disabled buttons, use standard fill but lighten border.
+ * Use darker colours for mouse-over and default button - helps with light
+ colour schemes.
+ * Dont draw sunken panel around checked menuitems.
+ * Fix karm (and others?) statusbar icon.
+ * Fix for radio buttons in apps where
+ QApplication::NormalColor!=QApplication::colorSpec() (e.g. designer)
+
+ -- Bastian Venthur <venthur@debian.org> Mon, 11 Jun 2007 10:42:01 +0200
+
+kde-style-qtcurve (0.50-1) unstable; urgency=low
+
+ * Initial release
+
+ -- Bastian Venthur <venthur@debian.org> Fri, 25 May 2007 12:38:49 +0200
+
diff --git a/debian/_base/applications/themes/kde-style-qtcurve/debian/compat b/debian/_base/applications/themes/kde-style-qtcurve/debian/compat
new file mode 100644
index 000000000..7f8f011eb
--- /dev/null
+++ b/debian/_base/applications/themes/kde-style-qtcurve/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/_base/applications/themes/kde-style-qtcurve/debian/control b/debian/_base/applications/themes/kde-style-qtcurve/debian/control
new file mode 100644
index 000000000..527a558e0
--- /dev/null
+++ b/debian/_base/applications/themes/kde-style-qtcurve/debian/control
@@ -0,0 +1,27 @@
+Source: kde-style-qtcurve-trinity
+Section: kde
+Priority: optional
+Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
+XSBC-Original-Maintainer: Bastian Venthur <venthur@debian.org>
+Build-Depends: cdbs, debhelper (>= 7.0.50~), quilt, cmake-trinity, ninja-build, kdelibs4-trinity-dev
+Standards-Version: 3.8.4
+
+Package: kde-style-qtcurve-trinity
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Recommends: gtk2-engines-qtcurve
+Provides: kde-style-qtcurve
+Description: This is a set of widget styles for Trinity based apps
+ This package together with gtk2-engines-qtcurve aim to provide a unified look
+ and feel on the desktop when using KDE and Gnome applications.
+ .
+ This package is most useful when installed together with
+ gtk2-engines-qtcurve.
+
+Package: qtcurve-trinity
+Architecture: any
+Depends: kde-style-qtcurve-trinity, gtk2-engines-qtcurve
+Description: This is a set of widget styles for Trinity and Gtk2 based apps
+ This is an empty dummy package which will drag the packages
+ kde-style-qtcurve and gtk2-engines-qtcurve in your system.
+
diff --git a/debian/_base/applications/themes/kde-style-qtcurve/debian/copyright b/debian/_base/applications/themes/kde-style-qtcurve/debian/copyright
new file mode 100644
index 000000000..055d8a659
--- /dev/null
+++ b/debian/_base/applications/themes/kde-style-qtcurve/debian/copyright
@@ -0,0 +1,33 @@
+This package was debianized by Bastian Venthur <venthur@debian.org> on
+Fri, 25 May 2007 12:52:24 +0200.
+
+It was downloaded from <http://www.kde-look.org/content/show.php/QtCurve+%28KDE4%2C+Trinity%2C+%26+Gtk2+Theme%29?content=40492>
+
+Upstream Author:
+
+ Craig Drummond <Craig.Drummond@lycos.co.uk>
+
+Copyright:
+
+ Copyright (C) 2007 Craig Drummond
+
+License:
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public
+ License along with this program; if not, write to the
+ Free Software Foundation, Inc., 51 Franklin St, Fifth Floor, Boston,
+ MA 02110-1301, USA.
+
+
+The Debian packaging is (C) 2007, Bastian Venthur <venthur@debian.org> and
+is licensed under the GPL, see `/usr/share/common-licenses/GPL'.
diff --git a/debian/_base/applications/themes/kde-style-qtcurve/debian/docs b/debian/_base/applications/themes/kde-style-qtcurve/debian/docs
new file mode 100644
index 000000000..724e08449
--- /dev/null
+++ b/debian/_base/applications/themes/kde-style-qtcurve/debian/docs
@@ -0,0 +1,2 @@
+README
+TODO
diff --git a/debian/_base/applications/themes/kde-style-qtcurve/debian/kde-style-qtcurve-trinity.install b/debian/_base/applications/themes/kde-style-qtcurve/debian/kde-style-qtcurve-trinity.install
new file mode 100644
index 000000000..003761370
--- /dev/null
+++ b/debian/_base/applications/themes/kde-style-qtcurve/debian/kde-style-qtcurve-trinity.install
@@ -0,0 +1 @@
+debian/tmp/opt
diff --git a/debian/_base/applications/themes/kde-style-qtcurve/debian/patches/series b/debian/_base/applications/themes/kde-style-qtcurve/debian/patches/series
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/debian/_base/applications/themes/kde-style-qtcurve/debian/patches/series
diff --git a/debian/_base/applications/themes/kde-style-qtcurve/debian/rules b/debian/_base/applications/themes/kde-style-qtcurve/debian/rules
new file mode 100755
index 000000000..f9774bf4b
--- /dev/null
+++ b/debian/_base/applications/themes/kde-style-qtcurve/debian/rules
@@ -0,0 +1,23 @@
+#!/usr/bin/make -f
+
+PATH := /opt/trinity/bin:$(PATH)
+
+# Set LD_LIBRARY_PATH to the installed library directory to allow dh_shlibdeps to function
+# Also include the main Trinity path
+ifeq ("$(LD_LIBRARY_PATH)", "")
+LD_LIBRARY_PATH=debian/tmp/opt/trinity/lib
+else
+LD_LIBRARY_PATH += :debian/tmp/opt/trinity/lib
+endif
+export LD_LIBRARY_PATH
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_KDE_APIDOX := yes
+
+CXXFLAGS := -DSMB_CTX_FLAG_USE_KERBEROS -DSMB_CTX_FLAG_FALLBACK_AFTER_KERBEROS -g -Wall $(DEB_OPT_FLAG)
+
+DEB_CMAKE_EXTRA_FLAGS := -DLIB_SUFFIX="" -DCMAKE_INSTALL_PREFIX="/opt/trinity" -DCONFIG_INSTALL_DIR="/etc/trinity" -DSYSCONF_INSTALL_DIR="/etc/trinity" -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" -DCMAKE_LIBRARY_PATH="/opt/trinity/lib" -DCMAKE_INCLUDE_PATH="/opt/trinity/include/" -DAUTODETECT_QT_DIRS="ON" -DCMAKE_VERBOSE_MAKEFILE="ON" -DBUILD_ALL="ON" -DCMAKE_SKIP_RPATH="OFF" \
+-DCMAKE_BUILD_TYPE=RelWithDebInfo
diff --git a/debian/_base/applications/themes/kde-style-qtcurve/debian/scan-version b/debian/_base/applications/themes/kde-style-qtcurve/debian/scan-version
new file mode 100644
index 000000000..640ea27c7
--- /dev/null
+++ b/debian/_base/applications/themes/kde-style-qtcurve/debian/scan-version
@@ -0,0 +1,41 @@
+#!/usr/bin/make -sf
+
+DL_LINK = http://www.kde-look.org/content/download.php?content=40492&id=2
+DL_LINK_REAL = $(shell LANG=C wget --spider "$(DL_LINK)" 2>&1 | grep "Location: " | sed "s/Location: //" | sed "s/ \[following\]//")
+PACKAGE = $(shell dpkg-parsechangelog | egrep '^Source: ' | sed s/"Source: "//)
+DEBIAN_VERSION = $(shell dpkg-parsechangelog | egrep '^Version: ' | sed s/"Version: "//)
+UPSTREAM_VERSION = $(shell echo $(DEBIAN_VERSION) | sed s/-.*//)
+FILE_NAME = $(shell echo "$(DL_LINK_REAL)" | sed s/\\//\\n/g | tail -n 1)
+FILE_EXT = $(shell echo "$(DL_LINK_REAL)" | sed s/\\./\\n/g | tail -n 1)
+NET_VERSION = $(shell echo "$(FILE_NAME)" | egrep -o "[0-9]+\.[0-9]+(\.[0-9]+)?")
+ORIG_TAR_GZ = ../$(PACKAGE)_$(NET_VERSION).orig.tar.gz
+
+all:
+ echo "Usage: debian/scan-version {scan|download|get-orig-source}"
+ exit 1
+
+scan:
+ dh_testdir
+ echo "URL: $(DL_LINK_REAL)"
+ echo "File: $(FILE_NAME)"
+ echo "Current version: $(UPSTREAM_VERSION)"
+ echo "Available version: $(NET_VERSION)"
+ echo
+ echo "If the available version is higher, type \"debian/scan-version download\" to download it."
+
+download:
+ dh_testdir
+ echo "Downloading $(DL_LINK_REAL)..."
+ wget $(DL_LINK_REAL) -O "../$(FILE_NAME)" 2> /dev/null
+ echo "Successfully downloaded to ../$(FILE_NAME)"
+
+get-orig-source: download
+ echo "Creating $(ORIG_TAR_GZ)..."
+ if [ "$(FILE_EXT)" = "gz" ]; then \
+ cp "../$(FILE_NAME)" "$(ORIG_TAR_GZ)"; \
+ else \
+ bunzip2 -c "../$(FILE_NAME)" | gzip -9c > "$(ORIG_TAR_GZ)"; \
+ fi
+ echo
+
+.PHONY: all parse-url scan download get-orig-source
diff --git a/debian/_base/applications/themes/kde-style-qtcurve/debian/source/format b/debian/_base/applications/themes/kde-style-qtcurve/debian/source/format
new file mode 100644
index 000000000..163aaf8d8
--- /dev/null
+++ b/debian/_base/applications/themes/kde-style-qtcurve/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/_base/applications/themes/kde-style-qtcurve/debian/source/options b/debian/_base/applications/themes/kde-style-qtcurve/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/debian/_base/applications/themes/kde-style-qtcurve/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*