summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/utilities/krename
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/utilities/krename')
-rw-r--r--debian/_base/applications/utilities/krename/debian/cdbs/debian-tde.mk246
-rw-r--r--debian/_base/applications/utilities/krename/debian/cdbs/versions.pl19
-rw-r--r--debian/_base/applications/utilities/krename/debian/changelog129
-rw-r--r--debian/_base/applications/utilities/krename/debian/compat1
-rw-r--r--debian/_base/applications/utilities/krename/debian/control18
-rw-r--r--debian/_base/applications/utilities/krename/debian/copyright34
-rw-r--r--debian/_base/applications/utilities/krename/debian/docs2
-rw-r--r--debian/_base/applications/utilities/krename/debian/krename.187
-rw-r--r--debian/_base/applications/utilities/krename/debian/krename.manpages1
-rw-r--r--debian/_base/applications/utilities/krename/debian/patches/series0
-rwxr-xr-xdebian/_base/applications/utilities/krename/debian/rules15
-rw-r--r--debian/_base/applications/utilities/krename/debian/source/format1
-rw-r--r--debian/_base/applications/utilities/krename/debian/source/options6
-rw-r--r--debian/_base/applications/utilities/krename/debian/watch6
14 files changed, 565 insertions, 0 deletions
diff --git a/debian/_base/applications/utilities/krename/debian/cdbs/debian-tde.mk b/debian/_base/applications/utilities/krename/debian/cdbs/debian-tde.mk
new file mode 100644
index 000000000..f36e3527c
--- /dev/null
+++ b/debian/_base/applications/utilities/krename/debian/cdbs/debian-tde.mk
@@ -0,0 +1,246 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Copyright © 2019 TDE Team
+# Description: A class for TDE packages; sets TDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+endif
+ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
+endif
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
+ touch debian/stamp-cvs-make
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+ifndef _cdbs_class_cmake
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+endif
+
+ifdef _cdbs_class_cmake
+ifneq "$(wildcard /usr/bin/ninja)" ""
+MAKE = ninja -v
+DEB_MAKE_ENVVARS += DESTDIR=$(DEB_DESTDIR)
+DEB_MAKE_INSTALL_TARGET = install
+DEB_CMAKE_NORMAL_ARGS += -GNinja
+endif
+endif
+
+ifndef _cdbs_rules_patchsys_quilt
+DEB_PATCHDIRS := debian/patches/common debian/patches
+endif
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/tde/HTML
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
+DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+DEB_BUILD_PARALLEL ?= true
+
+cdbs_configure_flags += \
+ --with-qt-dir=/usr/share/qt3 \
+ --disable-rpath \
+ --with-xinerama \
+ $(cdbs_kde_enable_final) \
+ $(cdbs_kde_enable_debug)
+
+
+# This is a convenience target for calling manually.
+# It's not part of the build process.
+buildprep: clean apply-patches
+ifndef _cdbs_class_cmake
+ $(MAKE) -f admin/Makefile.common dist
+endif
+ debian/rules clean
+
+.tdepkginfo:
+ echo "# TDE package information" >.tdepkginfo
+ dpkg-parsechangelog | sed -n "s|^Source: |Name: |p" >>.tdepkginfo
+ dpkg-parsechangelog | sed -n "s|^Version: |Version: |p" >>.tdepkginfo
+ date +"DateTime: %m/%d/%Y %H:%M" -u -d "$$(dpkg-parsechangelog | sed -n 's|^Date: ||p')" >>.tdepkginfo
+
+post-patches:: .tdepkginfo
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+ # update multi-arch path in install files
+ ls -d debian/* | \
+ grep -E "(install|links)$$" | \
+ while read a; do \
+ [ -d $$a ] || [ -f $$a.arch ] || \
+ ! grep -q "\$$(DEB_HOST_MULTIARCH)" $$a || \
+ sed -i.arch "s|\$$(DEB_HOST_MULTIARCH)|$(DEB_HOST_MULTIARCH)|g" $$a; \
+ done
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+ # revert multi-arch path in install files
+ ls -d debian/* | \
+ grep -E "(install|links)$$" | \
+ while read a; do \
+ [ ! -f $$a.arch ] || \
+ mv $$a.arch $$a; \
+ done
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ done
+
+common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+DESTDIR=$(DEB_DESTDIR) $(DEB_MAKE_INVOKE) install-apidox)
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+clean::
+ifndef _cdbs_class_cmake
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+endif
+ rm -f .tdepkginfo
+ rm -f debian/stamp-kde-apidox
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/debian/_base/applications/utilities/krename/debian/cdbs/versions.pl b/debian/_base/applications/utilities/krename/debian/cdbs/versions.pl
new file mode 100644
index 000000000..75c9add4b
--- /dev/null
+++ b/debian/_base/applications/utilities/krename/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "KDE-Version3=$version3\n";
+print "KDE-Version2=$version2\n";
+print "KDE-Next-Version3=$version3_next\n";
+print "KDE-Next-Version2=$version2_next\n";
diff --git a/debian/_base/applications/utilities/krename/debian/changelog b/debian/_base/applications/utilities/krename/debian/changelog
new file mode 100644
index 000000000..d574638b6
--- /dev/null
+++ b/debian/_base/applications/utilities/krename/debian/changelog
@@ -0,0 +1,129 @@
+krename-trinity (3.0.14~1ubuntu0) karmic; urgency=low
+
+ * Karmic rebuild
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 02 Jul 2009 16:08:00 -0600
+
+krename-trinity (3.0.14~0ubuntu6) intrepid; urgency=low
+
+ * Moved Trinity to /opt/trinity
+ * Integrated properly with KDE4.2+
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 05 March 2009 29:52:00 -0600
+
+krename-trinity (3.0.14~0ubuntu5) intrepid; urgency=low
+
+ * Added -trinity suffix
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Fri, 12 Dec 2008 14:34:00 -0600
+
+krename (3.0.14-1) unstable; urgency=low
+
+ * New Upstream Release (Closes: #402859, #423440)
+ * Adopted Package - New Maintainer & Uploaders
+ * debian/control:
+ - Maintainer set to Debian KDE Extras Team
+ - Richard A. Johnson set to uploaders
+ - updated standards to version 3.7.2 - no changes necessary
+ - updated build-dep debhelper >= 5 (changes to compat)
+ - added libtool and automake1.10 to build-dep for Relibtoolization
+ - added Krenames URL to description
+ * debian/rules:
+ - cleaned out commented lines
+ - Relibtoolization at build time
+ * Updated debian/copyright
+
+ -- Richard A. Johnson <nixternal@ubuntu.com> Fri, 18 May 2007 21:54:22 -0500
+
+krename (3.0.9-2.1) unstable; urgency=low
+
+ * NMU.
+ * Remove build dependency on g++-3.4. Closes: #385835.
+
+ -- Matthias Klose <doko@debian.org> Sun, 3 Sep 2006 13:41:32 +0000
+
+krename (3.0.9-2) unstable; urgency=low
+
+ * No more Build-Depend on xlibs-dev
+
+ -- Roman Kreisel <roman.kreisel@web.de> Wed, 30 Nov 2005 13:46:48 +0100
+
+krename (3.0.9-1) unstable; urgency=low
+
+ * New upstream release
+
+ -- Roman Kreisel <roman.kreisel@web.de> Fri, 28 Oct 2005 21:56:34 +0200
+
+krename (3.0.8-1) unstable; urgency=low
+
+ * New upstream release (Closes: #329969)
+
+ -- Roman Kreisel <roman.kreisel@web.de> Sat, 24 Sep 2005 19:22:44 +0200
+
+krename (3.0.7-4) unstable; urgency=low
+
+ * Use GCC 3.4 on arm, m68k and hppa
+ * updated manpage
+ * Build-Dependency on xlibs-dev
+ * moved from "utils - optional" to "kde - optional"
+
+ -- Roman Kreisel <roman.kreisel@web.de> Tue, 6 Sep 2005 01:30:57 +0200
+
+krename (3.0.7-3) unstable; urgency=low
+
+ * moved from dpatch to simple-patchsys of cdbs
+ * Corrected a typo in copyright-file (wrong telephone-no. of fsf)
+ * No more "0 errors occurred"-Message on successful operation. Fixed by
+ upstream. (Closes: #309253)
+
+ -- Roman Kreisel <roman.kreisel@web.de> Fri, 2 Sep 2005 16:15:32 +0200
+
+krename (3.0.7-2) unstable; urgency=low
+
+ * Updated/corrected german translation (Closes: #313984)
+
+ -- Roman Kreisel <roman.kreisel@web.de> Fri, 2 Sep 2005 14:59:04 +0200
+
+krename (3.0.7-1) unstable; urgency=low
+
+ * New upstream release
+
+ -- Roman Kreisel <roman.kreisel@web.de> Mon, 29 Aug 2005 16:13:56 +0200
+
+krename (3.0.6-1) unstable; urgency=low
+
+ * New upstream release
+
+ -- Roman Kreisel <roman.kreisel@web.de> Thu, 18 Aug 2005 15:34:07 +0200
+
+krename (3.0.4-1) unstable; urgency=low
+
+ * New upstream release
+
+ -- Roman Kreisel <roman.kreisel@web.de> Thu, 21 Apr 2005 18:00:14 +0200
+
+krename (3.0.3-2) unstable; urgency=low
+
+ * Initial Debian release (Closes: #286278, #279143)
+
+ -- Roman Kreisel <roman.kreisel@web.de> Mon, 14 Feb 2005 20:38:59 +0100
+
+krename (3.0.3-1) unstable; urgency=low
+
+ * New upstream release
+ * Fixed Build-Depends
+
+ -- Roman Kreisel <roman.kreisel@web.de> Mon, 14 Feb 2005 20:27:10 +0100
+
+krename (3.0.2-2) staging; urgency=low
+
+ * Added debian/watch for easier updating
+
+ -- Roman Kreisel <roman.kreisel@web.de> Sat, 15 Jan 2005 18:46:03 +0100
+
+krename (3.0.2-1) staging; urgency=low
+
+ * Initial Release.
+
+ -- Roman Kreisel <roman.kreisel@web.de> Sun, 14 Nov 2004 23:23:38 +0100
+
diff --git a/debian/_base/applications/utilities/krename/debian/compat b/debian/_base/applications/utilities/krename/debian/compat
new file mode 100644
index 000000000..7f8f011eb
--- /dev/null
+++ b/debian/_base/applications/utilities/krename/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/_base/applications/utilities/krename/debian/control b/debian/_base/applications/utilities/krename/debian/control
new file mode 100644
index 000000000..a05fa0309
--- /dev/null
+++ b/debian/_base/applications/utilities/krename/debian/control
@@ -0,0 +1,18 @@
+Source: krename-trinity
+Section: kde
+Priority: optional
+Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
+Uploaders: Richard A. Johnson <nixternal@ubuntu.com>
+Build-Depends: debhelper (>= 7.0.50~), quilt, cdbs, kdelibs4-trinity-dev, patchutils, libx11-dev, libxext-dev, libxpm-dev, x-dev | x11proto-core-dev | libx11-dev, perl, automake, autoconf, libtool, libltdl-dev
+Standards-Version: 3.8.4
+
+Package: krename-trinity
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: Powerful batch renamer for KDE 3.x [Trinity]
+ This package contains a very powerful batch file renamer for Trinity
+ which can rename a list of files based on a set of expressions.
+ It can copy/move the files to another directory or simply rename
+ the input files.
+ .
+ Homepage: http://www.krename.net
diff --git a/debian/_base/applications/utilities/krename/debian/copyright b/debian/_base/applications/utilities/krename/debian/copyright
new file mode 100644
index 000000000..e90f32cab
--- /dev/null
+++ b/debian/_base/applications/utilities/krename/debian/copyright
@@ -0,0 +1,34 @@
+This package was debianized by Roman Kreisel <roman.kreisel@web.de> on
+Sun, 14 Nov 2004 23:23:38 +0100.
+
+Maintenance was taken over by the Debian KDE Extras Team on Thu, 17 May 2007
+15:01:00 -0600
+
+It was downloaded from http://www.krename.net/
+
+Copyright: 2001-2007 Dominik Seichter <domseichter@web.de>
+
+Upstream Author: Dominik Seichter
+
+License:
+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; version 2 dated June, 1991.
+
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this package; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA
+ 02110-1301, USA.
+
+On Debian systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL'.
+
+The Debian packaging is
+(C) 2007 Richard A. Johnson <nixternal@ubuntu.com>
+and is licensed under the GPL, see above.
diff --git a/debian/_base/applications/utilities/krename/debian/docs b/debian/_base/applications/utilities/krename/debian/docs
new file mode 100644
index 000000000..724e08449
--- /dev/null
+++ b/debian/_base/applications/utilities/krename/debian/docs
@@ -0,0 +1,2 @@
+README
+TODO
diff --git a/debian/_base/applications/utilities/krename/debian/krename.1 b/debian/_base/applications/utilities/krename/debian/krename.1
new file mode 100644
index 000000000..153c74797
--- /dev/null
+++ b/debian/_base/applications/utilities/krename/debian/krename.1
@@ -0,0 +1,87 @@
+.\" DO NOT MODIFY THIS FILE! It was generated by help2man 1.35.
+.TH QT: "1" "September 2005" "Qt: 3.3.5" "User Commands"
+.SH NAME
+Qt: \- manual page for Qt: 3.3.5
+.SH SYNOPSIS
+.B krename
+[\fIQt-options\fR] [\fIKDE-options\fR] [\fIfile\fR]
+.SH DESCRIPTION
+KRename is a batch file renamer which can rename a
+list of files based on a set of expressions.
+.PP
+If you like KRename you may want to support it.
+Testing, bug fixes and feature request are as welcome
+as financial support (everybody needs money ;)
+See help files for details.
+.SS "Generic options:"
+.TP
+\fB\-\-help\fR
+Show help about options
+.TP
+\fB\-\-help\-qt\fR
+Show Qt specific options
+.TP
+\fB\-\-help\-kde\fR
+Show KDE specific options
+.TP
+\fB\-\-help\-all\fR
+Show all options
+.TP
+\fB\-\-author\fR
+Show author information
+.TP
+\fB\-v\fR, \fB\-\-version\fR
+Show version information
+.TP
+\fB\-\-license\fR
+Show license information
+.TP
+\fB\-\-\fR
+End of options
+.SS "Arguments:"
+.TP
+file
+file will be added to the list of files for renaming
+.SH OPTIONS
+.TP
+\fB\-r\fR +[dir]
+add directory recursively
+.TP
+\fB\-\-template\fR +
+set a template
+.TP
+\fB\-\-extension\fR +
+set a template for the file extension
+.TP
+\fB\-\-use\-plugin\fR +
+enable a plugin for use
+.TP
+\fB\-\-copy\fR +[dir]
+copy files to directory
+.TP
+\fB\-\-move\fR +[dir]
+move files to directory
+.TP
+\fB\-\-profile\fR +[profile]
+load the profile named [profile] on startup
+.TP
+\fB\-\-start\fR
+start renaming immediately
+.TP
+\fB\-\-nopreview\fR
+create no realtime preview
+.PP
+KDE: 3.4.2
+KRename: 3.0.8
+.SH "SEE ALSO"
+The full documentation for
+.B Qt:
+is maintained as a Texinfo manual. If the
+.B info
+and
+.B Qt:
+programs are properly installed at your site, the command
+.IP
+.B info Qt:
+.PP
+should give you access to the complete manual.
diff --git a/debian/_base/applications/utilities/krename/debian/krename.manpages b/debian/_base/applications/utilities/krename/debian/krename.manpages
new file mode 100644
index 000000000..ded8f6473
--- /dev/null
+++ b/debian/_base/applications/utilities/krename/debian/krename.manpages
@@ -0,0 +1 @@
+debian/krename.1
diff --git a/debian/_base/applications/utilities/krename/debian/patches/series b/debian/_base/applications/utilities/krename/debian/patches/series
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/debian/_base/applications/utilities/krename/debian/patches/series
diff --git a/debian/_base/applications/utilities/krename/debian/rules b/debian/_base/applications/utilities/krename/debian/rules
new file mode 100755
index 000000000..d43628ccb
--- /dev/null
+++ b/debian/_base/applications/utilities/krename/debian/rules
@@ -0,0 +1,15 @@
+#!/usr/bin/make -f
+
+DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/kde
diff --git a/debian/_base/applications/utilities/krename/debian/source/format b/debian/_base/applications/utilities/krename/debian/source/format
new file mode 100644
index 000000000..163aaf8d8
--- /dev/null
+++ b/debian/_base/applications/utilities/krename/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/_base/applications/utilities/krename/debian/source/options b/debian/_base/applications/utilities/krename/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/debian/_base/applications/utilities/krename/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*
diff --git a/debian/_base/applications/utilities/krename/debian/watch b/debian/_base/applications/utilities/krename/debian/watch
new file mode 100644
index 000000000..47a31479a
--- /dev/null
+++ b/debian/_base/applications/utilities/krename/debian/watch
@@ -0,0 +1,6 @@
+# Example watch control file for uscan
+# Rename this file to "watch" and then you can run the "uscan" command
+# to check for upstream updates and more.
+# Site Directory Pattern Version Script
+version=2
+http://heanet.dl.sourceforge.net/sourceforge/krename/krename-(.*)\.tar\.bz2 debian uupdate