summaryrefslogtreecommitdiffstats
path: root/debian/lenny/applications/k3b-i18n/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/lenny/applications/k3b-i18n/debian/rules')
-rwxr-xr-xdebian/lenny/applications/k3b-i18n/debian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/lenny/applications/k3b-i18n/debian/rules b/debian/lenny/applications/k3b-i18n/debian/rules
index 2048362b9..1e6d35926 100755
--- a/debian/lenny/applications/k3b-i18n/debian/rules
+++ b/debian/lenny/applications/k3b-i18n/debian/rules
@@ -15,6 +15,9 @@ DEB_CONFIGURE_PREFIX := /opt/trinity
DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
CFLAGS = -Wall -g
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
@@ -102,7 +105,7 @@ binary-indep: build install
dh_shlibdeps
dh_gencontrol
dh_md5sums
- dh_builddeb -- -Z bzip2
+ dh_builddeb $(DEB_DH_BUILDDEB_ARGS)
# Build architecture-dependent files here.
binary-arch: build install