summaryrefslogtreecommitdiffstats
path: root/debian/lenny/applications/kchmviewer/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/lenny/applications/kchmviewer/debian/rules')
-rwxr-xr-xdebian/lenny/applications/kchmviewer/debian/rules5
1 files changed, 3 insertions, 2 deletions
diff --git a/debian/lenny/applications/kchmviewer/debian/rules b/debian/lenny/applications/kchmviewer/debian/rules
index e3fdf7aac..9f09d3cea 100755
--- a/debian/lenny/applications/kchmviewer/debian/rules
+++ b/debian/lenny/applications/kchmviewer/debian/rules
@@ -23,7 +23,7 @@ DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
CFLAGS = -Wall -g
-CONFIGURE_OPTIONS_KDE = \
+CONFIGURE_OPTIONS_TDE = \
--host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
--prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib \
--includedir=/opt/trinity/include/tde --mandir=/opt/trinity/share/man \
@@ -57,7 +57,8 @@ debian/build-kde:
test -e config.guess -a -L config.guess || \
ln -sf /usr/share/misc/config.guess config.guess
- mkdir build-kde && cd build-kde && ../configure CFLAGS="$(CFLAGS)" $(CONFIGURE_OPTIONS_KDE)
+ [ -d build-kde ] || mkdir build-kde
+ cd build-kde && ../configure CFLAGS="$(CFLAGS)" $(CONFIGURE_OPTIONS_TDE)
$(MAKE) -C build-kde
touch debian/build-kde