summaryrefslogtreecommitdiffstats
path: root/debian/lenny/applications/ksquirrel/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/lenny/applications/ksquirrel/debian/rules')
-rwxr-xr-xdebian/lenny/applications/ksquirrel/debian/rules121
1 files changed, 0 insertions, 121 deletions
diff --git a/debian/lenny/applications/ksquirrel/debian/rules b/debian/lenny/applications/ksquirrel/debian/rules
deleted file mode 100755
index 328283c93..000000000
--- a/debian/lenny/applications/ksquirrel/debian/rules
+++ /dev/null
@@ -1,121 +0,0 @@
-#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
-# These are used for cross-compiling and for saving the configure script
-# from having to guess our platform (since we know it already)
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
-
-config.status: configure
- dh_testdir
-
-configure:
- dh_testdir
-
- # Regenerate build system
-ifneq "$(wildcard /usr/share/libtool/ltmain.sh)" ""
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -f /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-ifneq "$(wildcard /usr/share/misc/config.sub)" ""
- cp -f /usr/share/misc/config.sub admin/config.sub
-endif
-ifneq "$(wildcard /usr/share/misc/config.guess)" ""
- cp -f /usr/share/misc/config.guess admin/config.guess
-endif
-
- make -f admin/Makefile.common cvs
- touch debian/stamp-bootstrap
-
- # Add here commands to configure the package.
- PKG_CONFIG_PATH='/opt/trinity/lib/pkgconfig' kde_confdir=/etc/trinity ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/opt/trinity --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info CFLAGS="$(CFLAGS)" LDFLAGS="-Wl,-z,defs" --disable-rpath
-# Tricks for Intrepid
-#--disable-kexif --enable-mt --x-includes=/usr/include/qt4/Qt
-
-build: build-stamp
-
-build-stamp: config.status
- dh_testdir
-
- # Add here commands to compile the package.
- $(MAKE)
- #docbook-to-man debian/ksquirrel.sgml > ksquirrel.1
-
- touch $@
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp
-
- # Add here commands to clean up after the build process.
- [ ! -f Makefile ] || $(MAKE) distclean
- rm -f config.sub config.guess
-
- dh_clean
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- # Add here commands to install the package into debian/ksquirrel-trinity.
- $(MAKE) DESTDIR=$(CURDIR)/debian/ksquirrel-trinity install
-
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
- dh_testdir
- dh_testroot
-# dh_install
- dh_installchangelogs ChangeLog
- dh_installdocs
- dh_installexamples
- dh_installman debian/ksquirrel-libs-configurator.1
- cp -a debian/ksquirrel-trinity/usr/share/man debian/ksquirrel-trinity/opt/trinity/share/
- rm -fr debian/ksquirrel-trinity/usr/share/man
- dh_link \
- opt/trinity/share/man/man1/ksquirrel-libs-configurator.1 \
- opt/trinity/share/man/man1/ksquirrel-libs-configurator-real.1
- dh_strip
- dh_compress
- dh_fixperms
- dh_makeshlibs
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb $(DEB_DH_BUILDDEB_ARGS)
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install