summaryrefslogtreecommitdiffstats
path: root/debian/squeeze/applications/adept/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/squeeze/applications/adept/debian/rules')
-rwxr-xr-xdebian/squeeze/applications/adept/debian/rules3
1 files changed, 3 insertions, 0 deletions
diff --git a/debian/squeeze/applications/adept/debian/rules b/debian/squeeze/applications/adept/debian/rules
index ee86e8e4f..742307eb6 100755
--- a/debian/squeeze/applications/adept/debian/rules
+++ b/debian/squeeze/applications/adept/debian/rules
@@ -14,6 +14,9 @@ cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xine
DEB_MAKE_CHECK_TARGET := check
DEB_CONFIGURE_EXTRA_FLAGS += --enable-adept --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
# Enable us to locate the old libept-trinity library and includes
CPPFLAGS += -I/opt/trinity/include
LDFLAGS += -L/opt/trinity/lib -lept