summaryrefslogtreecommitdiffstats
path: root/debian/squeeze/dependencies/tqca-tls/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/squeeze/dependencies/tqca-tls/debian/rules')
-rwxr-xr-xdebian/squeeze/dependencies/tqca-tls/debian/rules9
1 files changed, 8 insertions, 1 deletions
diff --git a/debian/squeeze/dependencies/tqca-tls/debian/rules b/debian/squeeze/dependencies/tqca-tls/debian/rules
index 2ea43315e..22ec88d79 100755
--- a/debian/squeeze/dependencies/tqca-tls/debian/rules
+++ b/debian/squeeze/dependencies/tqca-tls/debian/rules
@@ -14,6 +14,7 @@ DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
# from having to guess our platform (since we know it already)
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
CFLAGS = -Wall -g
@@ -69,9 +70,15 @@ install: build
dh_clean -k
dh_installdirs
+ # update multi-arch path in install files
+ for a in debian/*install; do \
+ [ -d $$a ] || [ -f $$a.arch ] || \
+ sed -i.arch "s|\$$(DEB_HOST_MULTIARCH)|$(DEB_HOST_MULTIARCH)|g" $$a; \
+ done
+
# Add here commands to install the package into debian/tmp
$(MAKE) install INSTALL_ROOT=$(CURDIR)/debian/tmp/
- [ -e $(CURDIR)/debian/tmp/usr/lib/tqt3/plugins/crypto/libtqca-tls.so ] || ( echo "libtqca-tls.so not in usr/lib/tqt3/plugins/crypto/libtqca-tls.so" && exit 1 )
+ [ -e $(CURDIR)/debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/tqt3/plugins/crypto/libtqca-tls.so ] || ( echo "libtqca-tls.so not in usr/lib/$(DEB_HOST_MULTIARCH)/tqt3/plugins/crypto/libtqca-tls.so" && exit 1 )
# Build architecture-independent files here.