summaryrefslogtreecommitdiffstats
path: root/debian/squeeze/libraries/mlt++/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/squeeze/libraries/mlt++/debian/rules')
-rwxr-xr-xdebian/squeeze/libraries/mlt++/debian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/squeeze/libraries/mlt++/debian/rules b/debian/squeeze/libraries/mlt++/debian/rules
index 0232c83be..99606e440 100755
--- a/debian/squeeze/libraries/mlt++/debian/rules
+++ b/debian/squeeze/libraries/mlt++/debian/rules
@@ -10,6 +10,9 @@ DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
version := $(shell sed -n 's/Package: \(.*\)/\1/p' debian/control | head -n 1)
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
@@ -88,7 +91,7 @@ binary-arch: build install
dh_shlibdeps -l/opt/trinity/lib
dh_gencontrol
dh_md5sums
- dh_builddeb
+ dh_builddeb $(DEB_DH_BUILDDEB_ARGS)
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install