summaryrefslogtreecommitdiffstats
path: root/debian/wheezy/dependencies/sip4-tqt/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/wheezy/dependencies/sip4-tqt/debian/rules')
-rwxr-xr-xdebian/wheezy/dependencies/sip4-tqt/debian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/wheezy/dependencies/sip4-tqt/debian/rules b/debian/wheezy/dependencies/sip4-tqt/debian/rules
index 0dd14099f..2286739d5 100755
--- a/debian/wheezy/dependencies/sip4-tqt/debian/rules
+++ b/debian/wheezy/dependencies/sip4-tqt/debian/rules
@@ -2,6 +2,9 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
export DH_OPTIONS
INSTDIR=$(CURDIR)/debian
@@ -134,7 +137,7 @@ endif
dh_shlibdeps
dh_gencontrol
dh_md5sums
- dh_builddeb
+ dh_builddeb $(DEB_DH_BUILDDEB_ARGS)
# Build architecture independant packages using the common target.
binary-indep: