summaryrefslogtreecommitdiffstats
path: root/debian/wheezy/dependencies/tqca-tls/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/wheezy/dependencies/tqca-tls/debian/rules')
-rwxr-xr-xdebian/wheezy/dependencies/tqca-tls/debian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/wheezy/dependencies/tqca-tls/debian/rules b/debian/wheezy/dependencies/tqca-tls/debian/rules
index 4ffaf90dc..fc9e58e55 100755
--- a/debian/wheezy/dependencies/tqca-tls/debian/rules
+++ b/debian/wheezy/dependencies/tqca-tls/debian/rules
@@ -6,6 +6,9 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
# These are used for cross-compiling and for saving the configure script
# from having to guess our platform (since we know it already)
@@ -104,7 +107,7 @@ binary-arch: build install
dh_shlibdeps
dh_gencontrol
dh_md5sums
- dh_builddeb
+ dh_builddeb $(DEB_DH_BUILDDEB_ARGS)
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install