summaryrefslogtreecommitdiffstats
path: root/dilos/core/tdebindings/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'dilos/core/tdebindings/debian/patches')
-rw-r--r--dilos/core/tdebindings/debian/patches/common/04_am_maintainer_mode.diff11
-rw-r--r--dilos/core/tdebindings/debian/patches/common/05_pedantic-errors.diff12
-rw-r--r--dilos/core/tdebindings/debian/patches/common/06_disable_no_undefined.diff18
-rw-r--r--dilos/core/tdebindings/debian/patches/common/kubuntu_01_kdepot.diff26
-rw-r--r--dilos/core/tdebindings/debian/patches/dilos.patch98
-rw-r--r--dilos/core/tdebindings/debian/patches/series1
6 files changed, 166 insertions, 0 deletions
diff --git a/dilos/core/tdebindings/debian/patches/common/04_am_maintainer_mode.diff b/dilos/core/tdebindings/debian/patches/common/04_am_maintainer_mode.diff
new file mode 100644
index 000000000..391a80285
--- /dev/null
+++ b/dilos/core/tdebindings/debian/patches/common/04_am_maintainer_mode.diff
@@ -0,0 +1,11 @@
+--- a/admin/configure.in.min
++++ b/admin/configure.in.min
+@@ -38,6 +38,8 @@
+ dnl Automake doc recommends to do this only here. (Janos)
+ AM_INIT_AUTOMAKE(@MODULENAME@, @VERSION@) dnl searches for some needed programs
+
++AM_MAINTAINER_MODE
++
+ KDE_SET_PREFIX
+
+ dnl generate the config header
diff --git a/dilos/core/tdebindings/debian/patches/common/05_pedantic-errors.diff b/dilos/core/tdebindings/debian/patches/common/05_pedantic-errors.diff
new file mode 100644
index 000000000..ce2883918
--- /dev/null
+++ b/dilos/core/tdebindings/debian/patches/common/05_pedantic-errors.diff
@@ -0,0 +1,12 @@
+--- a/admin/acinclude.m4.in
++++ b/admin/acinclude.m4.in
+@@ -2144,9 +2144,6 @@
+ save_CXXFLAGS="$CXXFLAGS"
+ kde_safe_LIBS="$LIBS"
+ LIBS="$LIBS $X_EXTRA_LIBS"
+-if test "$GXX" = "yes"; then
+-CXXFLAGS="$CXXFLAGS -pedantic-errors"
+-fi
+ AC_TRY_COMPILE([
+ $2
+ ],
diff --git a/dilos/core/tdebindings/debian/patches/common/06_disable_no_undefined.diff b/dilos/core/tdebindings/debian/patches/common/06_disable_no_undefined.diff
new file mode 100644
index 000000000..05c932c3c
--- /dev/null
+++ b/dilos/core/tdebindings/debian/patches/common/06_disable_no_undefined.diff
@@ -0,0 +1,18 @@
+--- a/admin/acinclude.m4.in
++++ b/admin/acinclude.m4.in
+@@ -1689,15 +1689,6 @@
+ KDE_USE_CLOSURE_TRUE="#"
+ KDE_USE_CLOSURE_FALSE=""
+ KDE_NO_UNDEFINED=""
+- case $host in
+- *-*-linux-gnu)
+- KDE_CHECK_COMPILER_FLAG([Wl,--no-undefined],
+- [KDE_CHECK_COMPILER_FLAG([Wl,--allow-shlib-undefined],
+- [KDE_NO_UNDEFINED="-Wl,--no-undefined -Wl,--allow-shlib-undefined"],
+- [KDE_NO_UNDEFINED=""])],
+- [KDE_NO_UNDEFINED=""])
+- ;;
+- esac
+ fi
+ AC_SUBST(KDE_USE_CLOSURE_TRUE)
+ AC_SUBST(KDE_USE_CLOSURE_FALSE)
diff --git a/dilos/core/tdebindings/debian/patches/common/kubuntu_01_kdepot.diff b/dilos/core/tdebindings/debian/patches/common/kubuntu_01_kdepot.diff
new file mode 100644
index 000000000..28c95742b
--- /dev/null
+++ b/dilos/core/tdebindings/debian/patches/common/kubuntu_01_kdepot.diff
@@ -0,0 +1,26 @@
+--- kde/admin/cvs.sh 2005-11-26 02:42:02.000000000 +0000
++++ kde/admin/cvs.sh 2005-11-26 02:42:26.000000000 +0000
+@@ -537,6 +537,8 @@
+ if test -z "$PREPARETIPS"; then PREPARETIPS=preparetips ; fi
+ export EXTRACTRC PREPARETIPS
+
++kdepotpath=/usr/include/tde/tde.pot
++
+ for subdir in $dirs; do
+ test -z "$VERBOSE" || echo "Making messages in $subdir"
+ (cd $subdir
+@@ -554,10 +556,10 @@
+ fi
+ perl -e '$mes=0; while (<STDIN>) { next if (/^(if\s|else\s|endif)/); if (/^messages:/) { $mes=1; print $_; next; } if ($mes) { if (/$\\(XGETTEXT\)/ && / -o/) { s/ -o \$\(podir\)/ _translatorinfo.cpp -o \$\(podir\)/ } print $_; } else { print $_; } }' < Makefile.am | egrep -v '^include ' > _transMakefile
+
+- kdepotpath=${includedir:-`tde-config --expandvars --install include`}/tde.pot
+- if ! test -f $kdepotpath; then
+- kdepotpath=`tde-config --expandvars --prefix`/include/tde.pot
+- fi
++# kdepotpath=${includedir:-`tde-config --expandvars --install include`}/tde.pot
++# if ! test -f $kdepotpath; then
++# kdepotpath=`tde-config --expandvars --prefix`/include/tde.pot
++# fi
+
+ $MAKE -s -f _transMakefile podir=$podir EXTRACTRC="$EXTRACTRC" PREPARETIPS="$PREPARETIPS" srcdir=. \
+ XGETTEXT="${XGETTEXT:-xgettext} --foreign-user -C -ci18n -ki18n -ktr2i18n -kI18N_NOOP -kI18N_NOOP2 -kaliasLocale -x $kdepotpath" messages
diff --git a/dilos/core/tdebindings/debian/patches/dilos.patch b/dilos/core/tdebindings/debian/patches/dilos.patch
new file mode 100644
index 000000000..89ff7e33f
--- /dev/null
+++ b/dilos/core/tdebindings/debian/patches/dilos.patch
@@ -0,0 +1,98 @@
+Index: tdebindings/korundum/bin/krubyinit.cpp
+===================================================================
+--- tdebindings.orig/korundum/bin/krubyinit.cpp
++++ tdebindings/korundum/bin/krubyinit.cpp
+@@ -31,6 +31,42 @@
+ // to detect what they were started with
+ static const char* script_name = "krubyinit_app";
+
++/*#ifdef __dilos__
++#include <tdeglobal.h>
++
++class TDEGlobalNetworkManager;
++class TDEGlobalNetworkManager;
++class TDEHardwareDevices;
++
++TDEGlobalNetworkManager *
++TDEInstance::networkManager()const
++{
++
++ return (NULL);
++}
++
++TDEHardwareDevices *
++TDEInstance::hardwareDevices()const
++{
++
++ return (NULL);
++}
++
++TDEGlobalNetworkManager *
++TDEGlobal::networkManager()
++{
++
++ return (NULL);
++}
++
++TDEHardwareDevices *
++TDEGlobal::hardwareDevices()
++{
++
++ return (NULL);
++}
++#endif*/ /* __dilos__ */
++
+ int main(int argc, char **argv) {
+ ruby_init();
+ ruby_script((char*)script_name);
+Index: tdebindings/smoke/tde/Makefile.am
+===================================================================
+--- tdebindings.orig/smoke/tde/Makefile.am
++++ tdebindings/smoke/tde/Makefile.am
+@@ -1,3 +1,4 @@
++CPPFLAGS+= -D__TDE_HAVE_TDEHWLIB
+ lib_LTLIBRARIES = libsmoketde.la
+
+ # set the include path for X, qt and KDE
+@@ -16,11 +17,15 @@ x_sources = x_1.cpp x_2.cpp x_3.cpp x_4
+ x_16.cpp x_17.cpp x_18.cpp x_19.cpp x_20.cpp
+
+ # which sources should be compiled for perlqttde
+-libsmoketde_la_SOURCES = $(x_sources) smokedata.cpp
++libsmoketde_la_SOURCES = $(x_sources) smokedata.cpp dilos_smoke_tde.cpp
+
+ $(x_sources) smokedata.cpp:
+ perl generate.pl
+
++dilos_smoke_tde.cpp:
++ cp -f $(top_srcdir)/debian/local/$@ $@
++
+ CLEANFILES = $(libsmoketde_la_SOURCES)
+
+ .NOTPARALLEL:
++
+Index: tdebindings/admin/acinclude.m4.in
+===================================================================
+--- tdebindings.orig/admin/acinclude.m4.in
++++ tdebindings/admin/acinclude.m4.in
+@@ -1586,7 +1586,7 @@ if AC_TRY_EVAL(kde_line); then
+ # if you're trying to debug this check and think it's incorrect,
+ # better check your installation. The check _is_ correct - your
+ # installation is not.
+- if test -f actest.cpp && grep klineedit actest.cpp > /dev/null; then
++ if test -f actest.cpp && grep -i klineedit actest.cpp > /dev/null; then
+ kde_cv_uic_plugins=yes
+ fi
+ fi
+Index: tdebindings/kjsembed/docs/embedding/simple-embed/embedview.ui
+===================================================================
+--- tdebindings.orig/kjsembed/docs/embedding/simple-embed/embedview.ui
++++ tdebindings/kjsembed/docs/embedding/simple-embed/embedview.ui
+@@ -180,4 +180,7 @@
+ <includehint>kpushbutton.h</includehint>
+ <includehint>kpushbutton.h</includehint>
+ </includehints>
++<includes>
++ <include>kpushbutton.h</include>
++</includes>
+ </UI>
diff --git a/dilos/core/tdebindings/debian/patches/series b/dilos/core/tdebindings/debian/patches/series
new file mode 100644
index 000000000..c77ae3ebe
--- /dev/null
+++ b/dilos/core/tdebindings/debian/patches/series
@@ -0,0 +1 @@
+dilos.patch